Page 1 of 1

webproxy troubleshooting

Posted: Fri May 02, 2008 11:23 pm
by Krusty
Hello everybody

I got this problem:
I use firewall to block access to the router from the Internet and my proxy does not work.
so I have found a solution
Make sure you allow established TCP connections with tcp option 'non-syn-only' to the router before blocking everything else. In v2.5, the rule is like this:
'/ip firewall rule input add protocol=tcp tcp-options=non-syn-only connection-state=established'


but, can somebody tell me how can I set tcp-options=non-syn-only in routerOS v 3.7 ???
maybe Im too stupid for this :shock:

thx lot

Re: webproxy troubleshooting

Posted: Sun May 04, 2008 9:23 pm
by Krusty
somebody help please ...
24 reads and no reply ???

Re: webproxy troubleshooting

Posted: Sun May 04, 2008 9:56 pm
by hilton
What about this?;

/ip firewall filter add chain=input protocol=tcp tcp-flags=!,syn etc

Re: webproxy troubleshooting

Posted: Sun May 04, 2008 10:44 pm
by Krusty
What about this?;

/ip firewall filter add chain=input protocol=tcp tcp-flags=!,syn etc
still dont work :(

I have tried this:

tcp-flags=!,syn
tcp-flags=syn
tcp-flags=!,ack
tcp-flags=ack
tcp-flags=!,urg
tcp-flags=urg
tcp-flags=!,cwr
tcp-flags=cwr


dont know about other but I think there wont be difference