Community discussions

MikroTik App
 
User avatar
Equis
Forum Veteran
Forum Veteran
Topic Author
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Adding Routes with DHCP

Thu May 15, 2008 5:30 am

Hello

I would like to not add defulat route but add subnet routes via DHCP (default will be vpn after establised)

Does anyone know how to do this?

I need to tell cleint how to get to vpn server with routes and I have 500 clienst to do
DCHP would be easy if I knwo how.

Thanks :-)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8464
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Adding Routes with DHCP

Fri May 16, 2008 2:46 am

/ip dhcp-server option
add code=249 name="static-routes" value="0x080ac0a810fa10c0a8c0a810fa" - sets two static routes on Windows XP: 08 = mask /8, 0a = 10.0.0.0 (with mask /8), gateway c0a810fa = 192.168.16.250; and 10 = mask /16, c0a8 = 192.168.0.0 (/16), and the same gw.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
Equis
Forum Veteran
Forum Veteran
Topic Author
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Re: Adding Routes with DHCP

Fri May 16, 2008 4:53 am

Hello

I am very gratefull for that, thanks

Can you tell me will Microtil dhcp cleint work with that?

Also, do you have a table that shows those funky letters I need to make IP address?

Thanks again

:-)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8464
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Adding Routes with DHCP

Fri May 16, 2008 4:58 am

funky? it's hexadecimal numbers =)

option 249 (in rfc, it is 121, in windows - 249 =) ): http://www.ietf.org/rfc/rfc3442.txt
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
Equis
Forum Veteran
Forum Veteran
Topic Author
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Re: Adding Routes with DHCP

Fri May 16, 2008 5:13 am

Thank you again.

I have added that but it did not give my mikrotik client and static routes, perhaps it doesn't support it?
 
olmi
just joined
Posts: 19
Joined: Thu Apr 26, 2007 3:58 pm

Re: Adding Routes with DHCP

Mon Sep 29, 2008 10:13 pm

I have version 2.9.27

/ip dhcp-server option
add code=249 name="static-routes" value="0x080ac0a810fa10c0a8c0a810fa" - sets two static routes on Windows XP: 08 = mask /8, 0a = 10.0.0.0 (with mask /8), gateway c0a810fa = 192.168.16.250; and 10 = mask /16, c0a8 = 192.168.0.0 (/16), and the same gw.

Not work. help me make static routes via DHCP options.
 
changeip
Forum Guru
Forum Guru
Posts: 3823
Joined: Fri May 28, 2004 5:22 pm

Re: Adding Routes with DHCP

Mon Sep 29, 2008 10:27 pm

upgrade, 2.9.27 is unsupported. 2.9.51 is free and fixes many of those issues.
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
changeip
Forum Guru
Forum Guru
Posts: 3823
Joined: Fri May 28, 2004 5:22 pm

Re: Adding Routes with DHCP

Mon Sep 29, 2008 10:53 pm

What's new in 2.9.51:

*) fixed bug - dhcp server failed to give out options with code > 127;
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
User avatar
enk
Member Candidate
Member Candidate
Posts: 165
Joined: Fri Aug 17, 2007 8:59 am
Location: Russia
Contact:

Re: Adding Routes with DHCP

Thu Oct 02, 2008 4:21 pm

upgrade, 2.9.27 is unsupported. 2.9.51 is free and fixes many of those issues.

If he uses 2.9.27, it is likely that he has cracked version. Why do you say that 2.9.51 free? =)
as known as shados.
blog: http://betep.wpl.ru
A karma increase would be cool if you think I earned it.
 
changeip
Forum Guru
Forum Guru
Posts: 3823
Joined: Fri May 28, 2004 5:22 pm

Re: Adding Routes with DHCP

Thu Oct 02, 2008 7:32 pm

because a legal copy of 2.9.27 can be upgraded to 2.9.51 for free. If it's not legal then too bad, suffer with the bugs.
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
Pepo
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Thu May 29, 2008 1:34 am

Re: Adding Routes with DHCP

Thu Oct 02, 2008 7:34 pm

i want to ask is this method will be work Well for load balancing if we use it ???
:D
 
retaheri
just joined
Posts: 15
Joined: Thu Oct 17, 2019 12:22 pm

Re: Adding Routes with DHCP

Sat Sep 12, 2020 9:57 am

I tried to add more than 1 static route (in addition to default route) but it did not work! just 1 static route works:
0x18AC1401AC154601
route above works good but below not (that contains 4 route):
0x18AC1401AC154601AC1402AC154601AC1403AC154601AC1406AC154601
even 2 static routes did not work:
0x18AC1401AC154601AC1402AC154601
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8464
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Adding Routes with DHCP

Sat Sep 12, 2020 2:38 pm

You forgot subnet mask, each route should contain it. Wrong:
0x18AC1401AC154601AC1402AC154601AC1403AC154601AC1406AC154601
Correct:
0x18AC1401AC15460118AC1402AC15460118AC1403AC15460118AC1406AC154601
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
retaheri
just joined
Posts: 15
Joined: Thu Oct 17, 2019 12:22 pm

[SOLVED] Adding Routes with DHCP

Sun Sep 13, 2020 8:49 am

You forgot subnet mask, each route should contain it. Wrong:
0x18AC1401AC154601AC1402AC154601AC1403AC154601AC1406AC154601
Correct:
0x18AC1401AC15460118AC1402AC15460118AC1403AC15460118AC1406AC154601

Thanks alot! that's it!
it seems there is no option to mark as "true answer" for the question in the forum!
any way
thank you
 
mkx
Forum Guru
Forum Guru
Posts: 4593
Joined: Thu Mar 03, 2016 10:23 pm

Re: [SOLVED] Adding Routes with DHCP

Mon Sep 14, 2020 9:06 am

it seems there is no option to mark as "true answer" for the question in the forum!

There is a way, but only user that started a topic can do it.
BR,
Metod

Who is online

Users browsing this forum: b10up, Bing [Bot], pukkita, Renfrew and 114 guests