Community discussions

MikroTik App
 
CarulloS
Member
Member
Topic Author
Posts: 406
Joined: Thu Feb 02, 2006 5:52 am

VLAN Question - Tagged & Untagged - Rather Urgent Thanks

Thu May 29, 2008 1:19 pm

I have searched the forum, looked through the wiki, and read the docs to no avail.

I do this with lots of gear and with MT have had no luck and have spent hours trying, so if you kow how to do this please share simple steps to make it happen, don't point me at reading the docs or searching the forum - thanks in advance :)

I have two RB450

For example I have 4 vlans (101/102/103/104) and I want to accomplish the following.

I want devices on each RB450 to be able to only communicate with devices on the same port on the other RB450. There is a single ethernet cable on eth5 of each RB450 that connect the two and should carry the 4 vlans of tagged traffic (some call it trunked) between the two. All traffic on ports 1-4 need to be untagged.

To test proper operation I should be able to take 2 devices which do not support vlans and give them each an ip in a class c (say 192.168.1.1 & .2 & .3) I should be able to plug two of the devices into the same port on each RB450 (say ether3 on each) and ping each other. This should only work from the same ethernet port on each RB450 and not from any other combination of ports (ether2-ether3 on same rb450 or ether2-ether3 on each rb450 --- should not work)

I am only having problem with the untagged part - otherwise communicating with tagged vlans on MT is no problem. Thanks in advance for your time.

If you have not actually done this please do not reply - guesses or suggestions without having done it will not help me.

Scott
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8709
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: VLAN Question - Tagged & Untagged - Rather Urgent Thanks

Thu May 29, 2008 2:11 pm

simply add 4 bridges to each MT:

bridge1 = eth1 + vlan1
bridge1 = eth2 + vlan2
bridge1 = eth3 + vlan3
bridge1 = eth4 + vlan4

all vlans are on eth5
Last edited by Chupaka on Thu May 29, 2008 2:12 pm, edited 1 time in total.
 
Gerard
Trainer
Trainer
Posts: 336
Joined: Wed Apr 26, 2006 4:21 am
Location: Kentucky, USA
Contact:

Re: VLAN Question - Tagged & Untagged - Rather Urgent Thanks

Thu May 29, 2008 2:13 pm

You should be able to copy/paste this into both 450's and it should work.. I didn't test but I've done this numerous times...

/interface vlan add name=vlan101 vlan-id=101 interface=ether5
/interface vlan add name=vlan102 vlan-id=102 interface=ether5
/interface vlan add name=vlan103 vlan-id=103 interface=ether5
/interface vlan add name=vlan104 vlan-id=104 interface=ether5

/interface bridge add name=bridge_vlan101
/interface bridge port add bridge=bridge_vlan101 interface=ether1
/interface bridge port add bridge=bridge_vlan101 interface=vlan101

/interface bridge add name=bridge_vlan102
/interface bridge port add bridge=bridge_vlan102 interface=ether2
/interface bridge port add bridge=bridge_vlan102 interface=vlan102

/interface bridge add name=bridge_vlan103
/interface bridge port add bridge=bridge_vlan103 interface=ether3
/interface bridge port add bridge=bridge_vlan103 interface=vlan103

/interface bridge add name=bridge_vlan104
/interface bridge port add bridge=bridge_vlan104 interface=ether4
/interface bridge port add bridge=bridge_vlan104 interface=vlan104

-Gerard
 
CarulloS
Member
Member
Topic Author
Posts: 406
Joined: Thu Feb 02, 2006 5:52 am

Re: VLAN Question - Tagged & Untagged - Rather Urgent Thanks

Thu May 29, 2008 2:16 pm

Hello Scott,

Add VLAN interface to Ethernet 5 interface:
VLAN1, VLAN2, VLAN3, VLAN4

Create bridge for each VLAN interface [4 bridges],
add to bridge ports VLAN1 and Ethernet 1
add to second bridge VLAN2 and Ethernet2, and so on.

The same configuration for second router.

Regards,
Sergejs
 
CarulloS
Member
Member
Topic Author
Posts: 406
Joined: Thu Feb 02, 2006 5:52 am

Re: VLAN Question - Tagged & Untagged - Rather Urgent Thanks

Thu May 29, 2008 2:19 pm

Thanks, I received three replies with the same answer basically so I'll test it and see if it works. Not sure what I tried the first few hours :)

Appreciate the quick responses.

Scott
 
CarulloS
Member
Member
Topic Author
Posts: 406
Joined: Thu Feb 02, 2006 5:52 am

Re: VLAN Question - Tagged & Untagged - Rather Urgent Thanks

Thu May 29, 2008 2:28 pm

That worked...

Thanks again.

Scott

Who is online

Users browsing this forum: Bing [Bot], jorgepft, jubelor, K0NCTANT1N and 117 guests