Community discussions

MikroTik App
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

BGP not advertising /routing bgp networks

Mon Jun 02, 2008 9:33 am

We have problem with BGP after upgrade from v.3.7 to 3.10. All routes in /routing bgp networks are not advertised.

Is it a bug? Or we need to change some settings?
 
User avatar
sioannou
Member Candidate
Member Candidate
Posts: 121
Joined: Tue Apr 29, 2008 3:14 pm

Re: BGP not advertising /routing bgp networks

Mon Jun 02, 2008 11:45 am

Hey Mapik,

I got 3.10 running on my systems and BGP looks ok. Do you want to give a bit more info on your config and I'll have a look wats going maybe I can give you a hand on this one.

Check if you have an explicit deny on your filters. Where it blocks any kind of advertisment.
01010011011011110111010001101001011100100110100101110011
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

Re: BGP not advertising /routing bgp networks

Mon Jun 02, 2008 5:41 pm

Thank you for your reply.

Our test configuration:
/routing bgp instance
set default as=1 client-to-client-reflection=yes comment="" disabled=no ignore-as-path-len=no name=default out-filter="" redistribute-connected=no \
    redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=0.0.0.0
add as=44065 client-to-client-reflection=yes comment="" disabled=no ignore-as-path-len=no name=netair out-filter=bgp-networks \
    redistribute-connected=yes redistribute-ospf=yes redistribute-other-bgp=no redistribute-rip=no redistribute-static=yes router-id=10.0.18.8
/routing bgp network
add disabled=no instance=netair network=10.0.1.0/24 synchronize=no
/routing bgp peer
add address-families=ip comment="" disabled=no hold-time=3m in-filter="" instance=netair multihop=no name=roudnice-esus nexthop-choice=default \
    out-filter=to-esus remote-address=79.98.156.205 remote-as=44065 route-reflect=no tcp-md5-key="" ttl=255
add address-families=ip comment="" disabled=no hold-time=3m in-filter="" instance=netair multihop=no name=benecko nexthop-choice=default out-filter=\
    to-benecko remote-address=79.98.156.226 remote-as=44065 route-reflect=yes tcp-md5-key="" ttl=255

/routing filter
add action=reject chain=bgp-networks comment="" disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=16-32
add action=passthrough chain=to-esus comment="" disabled=no invert-match=no set-out-nexthop=79.98.156.206
add action=passthrough chain=to-benecko comment="" disabled=no invert-match=no set-bgp-local-pref=50 set-out-nexthop=79.98.156.225
OSPF and static routes are advertised fine, but network set in /routing bgp networks is not advertised...

With the same configuration on 3.7 net 10.0.1.0/24 advertised without problems...
 
User avatar
sioannou
Member Candidate
Member Candidate
Posts: 121
Joined: Tue Apr 29, 2008 3:14 pm

Re: BGP not advertising /routing bgp networks

Sat Jul 26, 2008 1:44 pm

Hi Mapik,

Sorry for the delay but I had a lot of work cut out for me lately. First things first. In bgp you never set the IP of instance to 0.0.0.0 because the router might end up advertising something you don't really want to advertise. In general the router will pick up the highest IP in the stack and advertise it. So change that.

For advertising the network you should set the synchronise to yes in the bgp network settings.

Also do you use this as iBGP or eBGP there is a difference when it comes to setting up the BGP with this two. As I came to find out the harsh way.
Also do a debug on the bgp through logging to see what is going on that will also give you an inside. I have MT 3.4 up to 3.10 communicating with BGP and I don't have any problems so far.

Sotiris
01010011011011110111010001101001011100100110100101110011
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

Re: BGP not advertising /routing bgp networks

Sun Jul 27, 2008 9:17 am

Hi Mapik,

Sorry for the delay but I had a lot of work cut out for me lately. First things first. In bgp you never set the IP of instance to 0.0.0.0 because the router might end up advertising something you don't really want to advertise. In general the router will pick up the highest IP in the stack and advertise it. So change that.

For advertising the network you should set the synchronise to yes in the bgp network settings.

Also do you use this as iBGP or eBGP there is a difference when it comes to setting up the BGP with this two. As I came to find out the harsh way.
Also do a debug on the bgp through logging to see what is going on that will also give you an inside. I have MT 3.4 up to 3.10 communicating with BGP and I don't have any problems so far.

Sotiris
Thank you for your reply. Problem was with both iBGP and eBGP. But since 3.11 there are some changes in this (not property of "instance" in "networks") and now it works fine without problems. ID 0.0.0.0 was set only in "default" and it is not used.

Thank you once again

Have a nice day
Martin
 
User avatar
sioannou
Member Candidate
Member Candidate
Posts: 121
Joined: Tue Apr 29, 2008 3:14 pm

Re: BGP not advertising /routing bgp networks

Mon Jul 28, 2008 10:06 pm

Sweet Martin so you know whats going on the instance is the session of BGP you want to use (that as a future reference)

All the best

Sotiris
01010011011011110111010001101001011100100110100101110011

Who is online

Users browsing this forum: arifbudiw, Bing [Bot] and 207 guests