Community discussions

MUM Europe 2020
 
paulchops
newbie
Topic Author
Posts: 42
Joined: Sat Feb 02, 2008 6:33 pm

DHCP Relay problems

Fri Jun 20, 2008 4:09 am

I use DHCP relay to get packets back a central server that hands out Static IPs. Have used this in one form or another for many years.

I found a situation where the packets never make it back to the server at all and need to be able to troubleshoot it, and find where it breaks

I have Central NOC, Tower A (RB600) that connects to Tower B (RB150) - only 9 customers now. I have used RB150s successfully in this exact scenario before. both Towers have Canopy equipment (Advantage APs - 14Mbit) and I have less than 2 MB steady (up/down combined) on Tower A and hardly any traffic on Tower B.

DHCP requests coming in to Tower B from customer routers never make it back to the NOC. Tower A has no problem.

I use port 1 of RB150 as the WAN BH and then a routed block of IPs on ports 2,3,4,5 combined into a bridge I call "Switch".

Same config as other places. How do I tell for certain that DHCP packets are leaving Tower B and making it to Tower A?

I dont do anything with Delay Threshold because A) none of the other towers use it, and B) I dont know exact how it might or might not factor in).

I have other towers that go A to B like this (with more traffic) and dont have a problem.

config ...

/ip dhcp-relay
add delay-threshold=none dhcp-server=x.x.x.2 disabled=no interface=Switch \
local-address=y.y.y.1 name="Switch"

DHCP server is set to IP of our DHCP server
local-address is set to the gateway of the subnet that is attached to the Switch bridge

If I knew EXACTLY how to see such a request leave Tower B and reach Tower A, then I would know for certain where it "stops" and that would help me figure out why exactly.

Who is online

Users browsing this forum: ahmedit, Google [Bot], MSN [Bot], t3jrH and 119 guests