Community discussions

MUM Europe 2020
 
kostil
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Wed Jun 18, 2008 6:01 pm
Location: Moscow region, Russia

ospf distribut list

Fri Jun 27, 2008 2:18 pm

i cut some not usefull routes from incoming and outgoing redistribute like this on my cisco router
i leave only needed routes in this example
.....
router ospf 999
router-id X.X.X.X
log-adjacency-changes
network X.X.X.X 0.0.0.7 area 0
distribute-list 30 out
distribute-list 30 in
.....
access-list 30 permit Y.Y.Y.0 0.0.0.63
access-list 30 permit Z.Z.Z.0 0.0.0.127
access-list 30 permit A.A.A.128 0.0.0.127
access-list 30 permit S.S.S.0 0.0.0.255
.....

how can i make this on mikrotik?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8346
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: ospf distribut list

Fri Jun 27, 2008 3:36 pm

Routing - Filters?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
kostil
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Wed Jun 18, 2008 6:01 pm
Location: Moscow region, Russia

Re: ospf distribut list

Fri Jun 27, 2008 3:59 pm

could you give me more concrete example?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5971
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ospf distribut list

Sat Jun 28, 2008 1:05 pm

To filter ospf routes use ospf-in and ospf-out chains.
Example drop all incoming routes except default route:

/routing filter
add chain=ospf-in prefix=0.0.0.0/0 invert-match=yes action=discard

Routing filter manual:
http://www.mikrotik.com/testdocs/ros/2. ... filter.php
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8346
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: ospf distribut list

Sat Jun 28, 2008 1:08 pm

hm... why 'invert-match=yes'?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5971
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ospf distribut list

Sat Jun 28, 2008 1:19 pm

drop all incoming routes except default route
 
kostil
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Wed Jun 18, 2008 6:01 pm
Location: Moscow region, Russia

Re: ospf distribut list

Sat Jun 28, 2008 1:40 pm

and how i can to accept two or three net?

/routing filter
add chain=ospf-in prefix=A.A.A.A/24 invert-match=yes action=discard
add chain=ospf-in prefix=B.B.B.B/24 invert-match=yes action=discard

in this case net A.A.A.A/24 accepted but B.B.B.B/24 not :(
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5971
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ospf distribut list

Sat Jun 28, 2008 1:53 pm

/routing filter
add chain=ospf-in prefix=A.A.A.A/24 invert-match=no action=accept
add chain=ospf-in prefix=B.B.B.B/24 invert-match=no action=accept
add chain=ospf-in action=drop
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8346
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: ospf distribut list

Sat Jun 28, 2008 3:59 pm

why is there another filtering in RIP? what is difference?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
che
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Fri Oct 07, 2005 1:04 pm

Re: ospf distribut list

Sat Jun 28, 2008 6:46 pm

I have one question regarding this.

Is there a way of blocking large segment of distributed routes instead of filthering exact small segments? For example, I have /30 networks that are distributed and are part of /24 segment, and when I try to use more globar rule it does nothing. I have to have exact rule for every distributed network in route list, no matter the size?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8346
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: ospf distribut list

Sat Jun 28, 2008 7:01 pm

use 'prefix length', set it to '24-32', for example
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
che
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Fri Oct 07, 2005 1:04 pm

Re: ospf distribut list

Sun Jun 29, 2008 1:06 am

Thank you. :)

Who is online

Users browsing this forum: MSN [Bot] and 108 guests