Community discussions

 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

PPTP connection drops when user has Linksys wireless router

Tue Jul 08, 2008 12:15 am

I have a Mikrotik router that NAT's a Microsoft RRAS server at each of my offices. I recently upgraded the OS on 2 of the Mikrotik routers to 3.6 from 2.9 and began seeing the following problem: Users who have Linksys wireless routers at home can no longer maintain a VPN connection through the routers with the 3.x OS. I updated each router to 3.10 and double checked all of the configurations and still no luck. I have a Mikrotik at home and have no problems with the VPN but all users with Linksys can no longer VPN through any of the 3.x routers. One of my engineers has a Linksys router but uses a Linux OS rather than the shipped Linksys OS and his works ok so I suspect that somehting with the PPTP pass through on the Linksys is to blame.

Is there anything I can do on the Mikrotik OS to let users with Linksys routers at home use the VPN?
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: PPTP connection drops when user has Linksys wireless router

Tue Jul 08, 2008 3:20 pm

Check that you have PPTP enabled in 'ip firewall service-ports'.
Do you have bridge on the router, where PPTP is not going trough.
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Tue Jul 08, 2008 7:55 pm

There is no bridge, it is configured as a router. Here is a print of the firewall service-ports:

# NAME PORTS
0 ftp 21
1 tftp 69
2 irc 6667
3 h323
4 sip
5 pptp
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: PPTP connection drops when user has Linksys wireless router

Wed Jul 09, 2008 3:36 pm

If you do not have any firewall rules I don't see the reason, why MikroTik router can block PPTP.
PPTP passthrough is working flawlessly in all V3.
 
bluecrow76
just joined
Posts: 19
Joined: Wed Sep 13, 2006 11:55 pm

Re: PPTP connection drops when user has Linksys wireless router

Mon Dec 22, 2008 7:55 pm

I have had similar issues with PPTP passthrough since the introduction of V3, regardless of minor revision. I haven't been able to nail down the cause, but I will have 20 people in an organization and 18 of them will all work fine but two will not. We will perform firmware updates on their current router and the problem will still persist.

The only solution I have found has been to setup RAS authenticated PPTP server on the Mikrotik. This introduces other issues, but at least things work.

The moment I revert back to V2 of RouterOS the problems go away.
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Mon Dec 22, 2008 8:58 pm

I have not figured this out yet; I have been sending the users with the problem to a router running version 2. I have considered adding Radius and using the PPTP server on the router. If you find a solution I sure would like to know.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: PPTP connection drops when user has Linksys wireless router

Tue Dec 23, 2008 2:17 pm

Perhaps check for the latest firmware on Lynksys router. We didn't receive any similar reports about PPTP passthrough and v3 routers.
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Tue Dec 23, 2008 8:33 pm

We have checked for the latest firmware on the Linksys routers but it did not make a difference. We have several clients with Mikrotik routers and various use configurations and the only thing that has solved the problem at any of the locations is to move the Mikrotik routers back to version 2.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: PPTP connection drops when user has Linksys wireless router

Tue Dec 30, 2008 3:13 pm

So, we need to check whether such setup is working,
PPTP-Client ---> MikroTik Router NAT ---> PPTP-server.
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Tue Dec 30, 2008 7:05 pm

The typical setup that fails is:

PPTP client is behind Linksysy router (we have tried various models with various firmware versions, the Linksys router works with Linux OS installed instead of Linksys OS)

Our router is Mikrotik version 3 OS using NAT to pass 1723 to our PPTP server

Our PPTP server is a Windows 2003 server with RRAS (all latest Microsoft updates are applied)
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: PPTP connection drops when user has Linksys wireless router

Mon Jan 05, 2009 4:38 pm

PPTP additionally to 1723 TCP port uses GRE protocol, you need to NAT GRE (protocol 47) as well.
 
User avatar
dankerr
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Wed Sep 12, 2007 10:56 pm
Location: Atlanta, GA USA

Re: PPTP connection drops when user has Linksys wireless router

Mon Jan 05, 2009 5:54 pm

The typical setup that fails is:

PPTP client is behind Linksysy router (we have tried various models with various firmware versions, the Linksys router works with Linux OS installed instead of Linksys OS)

Our router is Mikrotik version 3 OS using NAT to pass 1723 to our PPTP server

Our PPTP server is a Windows 2003 server with RRAS (all latest Microsoft updates are applied)
There are known issues with the newer Linksys and PPTP vpn connections (do a google). It's hit or miss if it's going to work, I've seen the issue with MikroTik PPTP server, Microsoft RAS and a Firebox PPTP connection. I've also seen the same client work behind one Linksys and not another with the same configuration. In some cases enabling UPnP on the Linksys and affected client fixes the issue.
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Mon Jan 05, 2009 9:21 pm

I have searched the web extensivley and found lots of hits but nothing has solved the problem except to rollback to Mikrotik version 2.
 
User avatar
jp
Long time Member
Long time Member
Posts: 599
Joined: Wed Mar 02, 2005 5:06 am
Location: Maine
Contact:

Re: PPTP connection drops when user has Linksys wireless router

Tue Jan 06, 2009 5:52 am

I would make sure connection tracking is on in your MT. We've seen pptp and ipsec stop working or never start if connection tracking isn't enabled. pptp is a connection oriented link, and ipsec needs it because it causes fragmentation.

I would update right to the latest MT OS for testing; you'd probably be fine doing that for a simple wired router.
 
User avatar
dankerr
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Wed Sep 12, 2007 10:56 pm
Location: Atlanta, GA USA

Re: PPTP connection drops when user has Linksys wireless router

Tue Jan 06, 2009 8:59 am

I would make sure connection tracking is on in your MT. We've seen pptp and ipsec stop working or never start if connection tracking isn't enabled. pptp is a connection oriented link, and ipsec needs it because it causes fragmentation.

I would update right to the latest MT OS for testing; you'd probably be fine doing that for a simple wired router.
ROS v3.17 works just fine running PPTP on Mikrotik or with NAT to Microsoft RAS. We run it both ways without issue on x86 systems and RB1000. That is if NAT for both GRE and TCP 1723 are configured properly. Adding rules to allow all "related" and "establed" connections will help too (connection tracking needs to be enabled).
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Tue Jan 06, 2009 10:50 pm

I am using version 3.17 with NAT to a Microsoft 2003 RRAS server and I have tried with and with out GRE. Perhaps I need some help with your advice "That is if NAT for both GRE and TCP 1723 are configured properly. Adding rules to allow all "related" and "establed" connections will help too (connection tracking needs to be enabled)." If you can provide an example of those configurations I would sure appreciate it.
 
User avatar
dankerr
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Wed Sep 12, 2007 10:56 pm
Location: Atlanta, GA USA

Re: PPTP connection drops when user has Linksys wireless router

Tue Jan 06, 2009 11:29 pm

I am using version 3.17 with NAT to a Microsoft 2003 RRAS server and I have tried with and with out GRE. Perhaps I need some help with your advice "That is if NAT for both GRE and TCP 1723 are configured properly. Adding rules to allow all "related" and "establed" connections will help too (connection tracking needs to be enabled)." If you can provide an example of those configurations I would sure appreciate it.

/ip firewall filter
add action=accept chain=forward comment="Allow established connections" \
connection-state=established disabled=no
add action=accept chain=forward comment="Allow related connections" \
connection-state=related disabled=no
add action=accept chain=input comment="Allow established connections" \
connection-state=established disabled=no
add action=accept chain=input comment="Allow related connections" \
connection-state=related disabled=no
/ip firewall nat
add action=dst-nat chain=dstnat comment="NAT INcoming GRE - PPTP VPN" \
disabled=no in-interface=ether0-Public protocol=gre to-addresses=\
172.16.1.2
add action=dst-nat chain=dstnat comment=\
"NAT INcoming Port 1723 TCP - PPTP VPN" disabled=no dst-port=1723 \
in-interface=ether0-Public protocol=tcp to-addresses=172.16.1.2 \
to-ports=1723
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Sat Jan 24, 2009 4:25 am

Well I finally found some time to get back to this; I added the forward filter rules and tested again with the same results. I also updated the Mikrotik OS to 3.19.
 
altere
just joined
Posts: 19
Joined: Tue Apr 03, 2007 7:13 pm

Re: PPTP connection drops when user has Linksys wireless router

Tue Mar 17, 2009 11:49 pm

Wondering if anyone has resolved this as we are having the same issue. Customers connecting to a VPN get disconnected within a matter of a few minutes or less. We will be upgrading to 3.22 later this evening to see if this resolves the problem.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24272
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: PPTP connection drops when user has Linksys wireless router

Wed Mar 18, 2009 3:21 pm

enable PPTP debug logs and see what it says there
system logging add topics=pptp,debug action=memory 
No answer to your question? How to write posts
 
User avatar
enk
Member Candidate
Member Candidate
Posts: 165
Joined: Fri Aug 17, 2007 8:59 am
Location: Russia
Contact:

Re: PPTP connection drops when user has Linksys wireless router

Wed Mar 18, 2009 5:10 pm

try to test your linksys router with native linux pptpd.
We have found similar problem with Zyxel P330W, when encryption enabled. But with linux pptpd this problem exists too.
as known as shados.
blog: http://betep.wpl.ru
A karma increase would be cool if you think I earned it.
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Sun Mar 22, 2009 2:43 am

normis; I have added the pptp debug logging, I will post back the results.

enk; I don't know what "native linux pptpd" is?
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless router

Sun Mar 29, 2009 10:21 pm

macbeton; To reply to your post, I have already established that other (non-Linksys) firmware DOES resolve the problem, however I can't expect normal users who barley know what a router is to replace the shipped firmware on thier router with an open source firmaware to make it work with our Mikrotik routers. Your post is not helpful and inappropriate since you posted with an assumption that I had not alrady tried that.
 
pbcconsulting
just joined
Posts: 6
Joined: Tue Jan 25, 2011 5:19 am

Re: PPTP connection drops when user has Linksys wireless rou

Tue Jan 25, 2011 5:38 am

Hello -

I can see that there's been little action on this thread for some time now - But I'm having a similar problem and I need some guidance... Here's the situation -

This is a Natted RB450G, with 2 x dstnat:

- PPTP (1723) to internal Microsoft RRAS server
- GRE to the same internal RRAS server

The firewall is set to accept input 1723 (TCP) as well as GRE.

I have 5 users connecting VPN:

- some can connect without any problems
- some connect but get disconnected after 1 or 2 minutes
- some simply cannot connect

And here's the catch:

The issue doesn't seem to be related to either a user's router or their ISP - why? Because if I replace this RB450G by a generic $79 Linksys with PPTP pass-thru enabled and forward of 1723, it works for everyone! :?

Any suggestion welcome -
 
jonnchapman
just joined
Topic Author
Posts: 11
Joined: Mon Jul 07, 2008 11:10 pm

Re: PPTP connection drops when user has Linksys wireless rou

Tue Jan 25, 2011 7:08 pm

Hello pbconsulting,

This topic has not had discussion in a while, it seems that Mikrotik is ignoring this issue. I did find two solutions, some might consider them to be workarounds rather than solutions but I think that solution one is a much better method of handling VPN.

1. Let the Mikrotik router be the VPN server. If you use an internal authentication system such as Active Directory, then setup RADIUS on the Mikrotik and IAS on the domain controller. I have found this to be better since I can use both local secrets on the Mikrotik and RADIUS simultaniously thus allowing me to connect even if RRAS is down.

2. Use any version of Mikrotik Router OS before 3.x, it was with 3.x that this problem surfaced. I still have 2.x routers out there that work just fine for basic configurations so the older version is not a problem.

I hope that helps...
 
pbcconsulting
just joined
Posts: 6
Joined: Tue Jan 25, 2011 5:19 am

Re: PPTP connection drops when user has Linksys wireless rou

Wed Feb 02, 2011 5:34 pm

@jonnchapman

Hey John - Thanks for your reply.

I have created a new thread for this issue:

http://forum.mikrotik.com/viewtopic.php ... 08#p247908

Like you, I have come to the conclusion that I am better off having the RB450G do the PPTP server job and authenticate with RADIUS against IAS. :)

I identified (part of) the issue: Cisco-based firmware (such as linksys or PIX routers) located at the tunnel origin (such as end users's home routers). It seems the issue occurs from a certain inability of the part of Microtik routers (recent firmware) to correctly deal with GRE encapsulation initiating from such Cisco-based firmware? Or else the combination of double NAT with GRE encapsulation? I can't tell for sure... A very patient man at Microtik would need to test this with Wireshark ;-)

The issue doesn't happen with other common ISP routers that I have tested - thanks to my users (Netgear, DD-WRT, Verizon-branded ActionTec, SpeedTouch, etc...)

Cheers - Phil.
 
User avatar
sjoram
Member Candidate
Member Candidate
Posts: 117
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Re: PPTP connection drops when user has Linksys wireless rou

Tue Feb 26, 2013 9:33 pm

Just to advise that I seem to be having PPTP VPN on 2k3 server dropping after around 30-45mins of running OK using a RB750.
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
2x RB750Gr3
Draytek Vigor 120v2 ADSL2+ Annex M
Draytek Vigor 130 FTTC (VDSL)

Who is online

Users browsing this forum: No registered users and 82 guests