Page 1 of 1

OSPF in 311

Posted: Tue Jul 15, 2008 11:25 pm
by spikes

I have a problem. V3.11 is logging this message, and route table was crashing...

Whats wrong?

Re: OSPF in 311

Posted: Wed Jul 23, 2008 1:13 am
by spikes
Router is RB 433AH, with three R52. If working two R52 (third disabled) everythink is OK...

Re: OSPF in 311

Posted: Wed Jul 23, 2008 12:56 pm
by che
I have same behaviour at one site with RB333.

I checked routing config, and started troubleshooting the PHY link. It didn't deauth, and main OSPF table refreshes on seemingly random intervals from uplink interface which is CM9 card. Could be 30 seconds, could be 30 mins, and wireless link is working without interruptions but there is more than 1000 OSPF neighbor state changes during approx 5 days uptime. I think problem started with v3.10, and is the same on v3.11 and fw 2.16. I have 3 CM9 cards on this router.

Manifestation of this problem is packet loss during refreshing of the routing table, usually ~10 pings drop while router learns the table from his uplink neighbor.

Strangelly enough, I have same base config principle on every site in network and few RB333 work perfectly with v3.10 and 3.11 and new (and newest) fw with same OSPF table, but those routers have only one or two wireless interfaces.

I'm clueless about this, so I spent 30 mins announcing networks on another router, and putting static routes on troublesome RB333. This solved packet loss problems, but I dont count it as 'solved issue' for I dont know what was happening with OSPF, because disabling one wi-fi interface is not an option in my case. Considering it has 3 wi-fi interfaces and other sites that work correctly have 1 or 2, could be zillion of possible issues, but I dont have freedom of playing with that link, or time to test out OSPF with 3 wi-fi interfaces in lab conditions.

Any advice would be appreciated. :)