Community discussions

MUM Europe 2020
 
wsgtrsys
newbie
Topic Author
Posts: 36
Joined: Sat Dec 25, 2004 2:22 pm

lan pc how to use ipv6?

Sun Jul 20, 2008 1:04 pm

i set my routeros use 6to4, and i link to ipv6 net.
and i wan't set lan use ipv6 over routeros's 6to4.
but i can't know how to set it.
under is my set:
[admin@routeros] /ipv6> export
#
/ipv6 address
add address=2001:470:1f06:69c::2/64 advertise=yes disabled=no eui-64=no \
interface=sit1
/ipv6 nd
add advertise-mac-address=yes disabled=no hop-limit=unspecified interface=all \
mtu=unspecified ra-delay=3s ra-interval=3m20s-10m ra-lifetime=30m \
reachable-time=unspecified retransmit-interval=unspecified
/ipv6 nd prefix default
set autoconfig=yes on-link=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add disabled=no distance=1 dst-address=::/0 gateway=::209.51.161.14,sit1 \
scope=30 target-scope=10
[admin@routeros] /ipv6>
and i set my windows:
interface ipv6 add address "本地连接" 2001:470:1f06:69c::4/64
Last edited by wsgtrsys on Mon Jul 21, 2008 2:55 am, edited 2 times in total.
 
wsgtrsys
newbie
Topic Author
Posts: 36
Joined: Sat Dec 25, 2004 2:22 pm

Re: lan pc how to use ipv6?

Mon Jul 21, 2008 2:46 am

i found a:
http://www.tunnelbroker.net/forums/inde ... opic=142.0

it said:
Also no you don't need to run BGP. I set up a similar test network up several times a week without issue, except I don't try and hardcode the address on the client, I just RADVD advertise and the systems pick everything up. The basic radvd config I use is:

interface eth0
{
AdvSendAdvert on;
AdvHomeAgentFlag off;
MinRtrAdvInterval 30;
MaxRtrAdvInterval 100;
prefix 2001:470:A:B::/64
{
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
};
};

sorry its late and im not reading everything. you dont need to make tunnel interfaces on the clients that want to use the routed /64. if they have ipv6 enabled they should get the address from radvd. unless you are creating sit interfaces for the clients on the linux box, using their tunnel interfaces won't work.

Basically:

1) configure tunnel on linux machine.
2) configure first usable IP of routed range on the interface that faces the LAN (in your case eth2)
3) configure radvd to advertise that range over that interface
4) configure client machines on the LAN to support IPv6, and after 30 seconds they should automatically assign an address

XP/2000/2003 will require an IPv4 nameserver connection for DNS resolution, Vista/2008 won't.
Mac/Linux/BSD are generally already IPv6 enabled and will get an address.
mean is must run "radvd",so lan can auto get ipv6 addr and route out!
 
mahtin
just joined
Posts: 1
Joined: Mon Jul 21, 2008 9:07 pm
Location: California, USA
Contact:

Re: lan pc how to use ipv6?

Mon Jul 21, 2008 9:31 pm

If you are running IPv6 with Hurricane Electric's tunnelbroker (at http://tunnelbroker.net/ ), then you are allocated TWO IPv6 /64 blocks.

One is for the tunnel itself and uses the :1 and :2 addresses from the /64. The second /64 is for your LAN and unless you route it, it won't be used.

Here is an example of my setup. These are cut-n-paste from the tunnelbroker account details:
Server IPv4 address: 72.52.104.74
Server IPv6 address: 2001:470:xxxx:xxxx::1/64
Client IPv4 address: [Update] ###.###.###.###
Client IPv6 address: 2001:470:xxxx:xxxx::2/64
The :2 address (shown in red) is the address of your host or router. You can't use an other addresses from that /64.

Then in the next section, I get:
Routed /48: none
Routed /64: 2001:470:yyyy:yyyy::/64
It's that second section, where the LAN /64 is shown. Normally when you are running just a single host at the end of a tunnel, you can just use the :2 address of the tunnel endpoint as your access to the IPv6 world; however, there really is a second set of addresses available to you. If you are running a router, then you should use those second IP's for the LAN side of a box.

Once that is setup, you can go ahead with radvd as you have already found out.

BTW: It's that second /64 that you can setup custom DNS on.

If you have any question - drop me at line at my username at username dot com.

Who is online

Users browsing this forum: merchedahmar and 78 guests