Page 1 of 1

Web Proxy redirect

Posted: Wed Aug 13, 2008 1:02 am
by pauljr
I have web proxy successully running without cacheing. When I change my proxy access rule to deny and choose redirect to http://www.domain.com it no longer works. I'm just testing by putting my mtik ip as my proxy in my browser right now. Any suggestions?

When I make that work then I will have firewall rules setup to detect port scanners etc and add their source ip to an address list. Then I have a nat rule to dst-nat TCP/80 and redirect it to the mtik web proxy port. Then I want the Mtik web proxy port to redirect them to a URL.

Basically when I block/firewall somones internet access now they think their wireless service went down not knowing that I actually blocked their traffic for abuse etc. I want them to hit a page explaining to them why they were blocked.

Re: Web Proxy redirect

Posted: Wed Aug 13, 2008 5:03 pm
by pauljr
Any help on this would be appreciated.. Running on x86 and 3.11 mtik version

Re: Web Proxy redirect

Posted: Wed Aug 13, 2008 7:45 pm
by pauljr
I decided to test with firefox and this is what i get. I'm simply choosing deny and redirect to http://www.exampledomain.com.


Firefox error:

Redirect Loop

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.


The browser has stopped trying to retrieve the requested item. The site is redirecting the request in a way that will never complete.

* Have you disabled or blocked cookies required by this site?
* NOTE: If accepting the site's cookies does not resolve the problem, it is likely a server configuration issue and not your computer.

Re: Web Proxy redirect

Posted: Thu Aug 14, 2008 2:13 pm
by hilton
I've just tested this and it works as expected. I'm also running x86 3.11.

Minor difference is that I am using the cache and I have a firewall rule to catch all traffic destined on port 80 and send it to the proxy.

Post your config.

Re: Web Proxy redirect

Posted: Thu Aug 14, 2008 4:34 pm
by pauljr
They only way I was able to get it working was to set the parent proxy/port to the web server I want them to redirected to. I'm not sure about adverse effects doing it this way but it appears to be working.