Community discussions

MikroTik App
 
IVB
just joined
Topic Author
Posts: 8
Joined: Tue Jul 29, 2008 12:37 pm
Location: Ukraine
Contact:

RouterOS v3.13: portmapping don't work.

Fri Aug 15, 2008 6:16 pm

I need to portmap port 25 from MikroTik interface to our SMTP server.
/ip firewall nat add action=dst-nat chain=dstnat dst-address=82.207.85.177 dst-port=25 protocol=tcp to-addresses=194.79.8.34 to-ports=25
winbox (IP/Firewall/NAT) shows packets on this rule, but SMTP server don't receive this packets.

Is this my mistake (than please point me on it) or error in RouterOS?

RouterOS v3.13, hardware RB1000.
 
User avatar
parrini
Frequent Visitor
Frequent Visitor
Posts: 85
Joined: Thu Dec 13, 2007 5:11 am
Location: Bahia, Brazil

Re: RouterOS v3.13: portmapping don't work.

Fri Aug 15, 2008 7:40 pm

Have you checked your incoming chain to se if the connection is permitted?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8493
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: RouterOS v3.13: portmapping don't work.

Sat Aug 16, 2008 12:58 pm

are 82.207.85.177 and 194.79.8.34 on different interfaces?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
IVB
just joined
Topic Author
Posts: 8
Joined: Tue Jul 29, 2008 12:37 pm
Location: Ukraine
Contact:

Re: RouterOS v3.13: portmapping don't work.

Thu Sep 18, 2008 10:30 am

Have you checked your incoming chain to se if the connection is permitted?
Yes, connection is permitted.
 
IVB
just joined
Topic Author
Posts: 8
Joined: Tue Jul 29, 2008 12:37 pm
Location: Ukraine
Contact:

Re: RouterOS v3.13: portmapping don't work.

Thu Sep 18, 2008 10:36 am

are 82.207.85.177 and 194.79.8.34 on different interfaces?
The case is more difficult - 194.79.8.34 is on another device, not on MikroTik. I need to pass traffic through MikroTik to mailserver.
 
mangot
just joined
Posts: 16
Joined: Sat May 12, 2007 9:30 pm

Re: RouterOS v3.13: portmapping don't work.

Thu Sep 18, 2008 5:13 pm

Hi,

Try specifying incoming interface, instead of dst-address. For me it works fine that way.

Mangot

Who is online

Users browsing this forum: ashoka, Bing [Bot], bugino, mojojojo, narkeshbneha and 166 guests