Page 1 of 1

high priority

Posted: Tue Aug 26, 2008 7:20 am
by Pepo
hi all,
I'm using mikrotik server as hotspot and pppoe server at the same time, also i want to give more priority to port 15779 as a TCP port for an online game named Silkroad.
i want to give this port priority 1
:lol:

Re: high priority

Posted: Tue Aug 26, 2008 8:05 am
by pokeman
Hi There

i am not geek for MT but here is configuration. if i am getting wrong please correct this

ether1 = WAN

/ip firewall mangle
add chain=prerouting in-interface=ether1 protocol=tcp src-port=15779 action=mark-packet new-packet-mark=silkroad_in passthrough=no
add chain=postrouting out-interface=ether1 protocol=tcp dst-port=15779 action=mark-packet new-packet-mark=silkroad_out passthrough=no

/queue tree
add name=silkroad_down parent=global-in packet-mark=dns_in limit-at=0 queue=wireless-default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
add name=silkroad_up parent=global-out packet-mark=dns_out limit-at=0 queue=wireless-default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

Re: high priority

Posted: Tue Aug 26, 2008 10:38 pm
by Pepo
Thanks my friend,
it seems nice, but realy we need some one who is more experience that us to say if it work or not ...
:D :lol:

Re: high priority

Posted: Wed Aug 27, 2008 12:18 am
by NickOlsen
You can't just prioritize one type of traffic.
You have to prioritize it all, then give the app priority over another.

What is posted above is good.
I would add these under the rules that he posted

add action=mark-packet chain=prerouting comment=udp disabled=no in-interface=\
wan0 new-packet-mark=udp_in passthrough=no protocol=udp
add action=mark-packet chain=postrouting comment="" disabled=no \
new-packet-mark=udp_out out-interface=wan0 passthrough=no protocol=udp
add action=mark-packet chain=prerouting comment=tcp disabled=no in-interface=\
wan0 new-packet-mark=tcp_in passthrough=no protocol=tcp
add action=mark-packet chain=postrouting comment="" disabled=no \
new-packet-mark=tcp_out out-interface=wan0 passthrough=no protocol=tcp
add action=mark-packet chain=prerouting comment=other disabled=no \
in-interface=wan0 new-packet-mark=other_in passthrough=no
add action=mark-packet chain=postrouting comment="" disabled=no \
new-packet-mark=other_out out-interface=wan0 passthrough=no


This marks all other traffic, You would then add a queue for these and give it a priority of 8 or anything lower then the rules for the game.

Re: high priority

Posted: Wed Aug 27, 2008 6:40 am
by pokeman
Hi NickOlsen

if you are creating the simple queue the default priority is 8 then why we are going to mark other traffic ?

Re: high priority

Posted: Wed Aug 27, 2008 9:19 am
by NickOlsen
These are queue trees not simple queues.
if you mark just one type of traffic and set it to priority 1 it takes no priority over non-prioritized traffic.
Thats why you have to mark all traffic as 8 or so and just up the priority on what you want to have priority (with other mangle rules).

Re: high priority

Posted: Wed Aug 27, 2008 10:34 am
by pokeman
These are queue trees not simple queues.
if you mark just one type of traffic and set it to priority 1 it takes no priority over non-prioritized traffic.
Thats why you have to mark all traffic as 8 or so and just up the priority on what you want to have priority (with other mangle rules).
thanks for your suggestion i am changes in my MT can you please find any error bellow

/ip firewall mangle

7 ;;; DNS
chain=prerouting in-interface=ether1 protocol=udp src-port=53 action=mark-packet new-packet-mark=dns_in passthrough=no

8 chain=postrouting out-interface=ether1 protocol=udp dst-port=53 action=mark-packet new-packet-mark=dns_out passthrough=no

9 ;;; ssl
chain=prerouting in-interface=ether1 protocol=tcp src-port=443 action=mark-packet new-packet-mark=ssl_in passthrough=no

10 chain=postrouting out-interface=ether1 protocol=tcp dst-port=443 action=mark-packet new-packet-mark=ssl_out passthrough=no

11 ;;; http
chain=prerouting in-interface=ether1 protocol=tcp src-port=80 action=mark-packet new-packet-mark=http_in passthrough=no

12 chain=postrouting out-interface=ether1 protocol=tcp dst-port=80 action=mark-packet new-packet-mark=http_out passthrough=no

13 ;;; udp
chain=prerouting in-interface=ether1 protocol=udp action=mark-packet new-packet-mark=udp_in passthrough=no

14 chain=postrouting out-interface=ether1 protocol=udp action=mark-packet new-packet-mark=udp_out passthrough=no

15 ;;; tcp
chain=prerouting in-interface=ether1 protocol=tcp action=mark-packet new-packet-mark=tcp_in passthrough=no

16 chain=postrouting out-interface=ether1 protocol=tcp action=mark-packet new-packet-mark=tcp_out passthrough=no

17 ;;; other
chain=prerouting in-interface=ether1 action=mark-packet new-packet-mark=other_in passthrough=no

18 chain=postrouting out-interface=ether1 action=mark-packet new-packet-mark=other_out passthrough=no

19 ;;; Cache Hit
chain=postrouting tos=48 action=mark-packet new-packet-mark=proxy-hit passthrough=no


/queue tree print

0 name="pmark" parent=global-out packet-mark=proxy-hit limit-at=0 queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0
burst-time=0s

1 name="dns_down" parent=global-in packet-mark=dns_in limit-at=0 queue=wireless-default priority=1 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

2 name="dns_up" parent=global-out packet-mark=dns_out limit-at=0 queue=wireless-default priority=1 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

3 name="ssl_in" parent=global-in packet-mark=ssl_in limit-at=0 queue=wireless-default priority=1 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

4 name="ssl_out" parent=global-out packet-mark=ssl_out limit-at=0 queue=wireless-default priority=1 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

5 name="http_in" parent=global-in packet-mark=http_in limit-at=0 queue=wireless-default priority=4 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

6 name="http_out" parent=global-out packet-mark=http_out limit-at=0 queue=wireless-default priority=4 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

7 name="udp_down" parent=global-in packet-mark=udp_in limit-at=0 queue=wireless-default priority=8 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

8 name="udp_up" parent=global-out packet-mark=udp_out limit-at=0 queue=wireless-default priority=8 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

9 name="tcp_down" parent=global-in packet-mark=tcp_in limit-at=0 queue=wireless-default priority=8 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

10 name="tcp_up" parent=global-out packet-mark=tcp_out limit-at=0 queue=wireless-default priority=8 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

11 name="other_down" parent=global-in packet-mark=other_in limit-at=0 queue=wireless-default priority=8 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

12 name="other_up" parent=global-out packet-mark=other_out limit-at=0 queue=wireless-default priority=8 max-limit=0 burst-limit=0
burst-threshold=0 burst-time=0s

Re: high priority

Posted: Wed Aug 27, 2008 6:26 pm
by NickOlsen
It all looks good.
Is your wan interface ether 1?
are the rules getting increments on the hit counters? which would show that they are marking traffic.
are the queue rules getting increments? showing that they are prioritizing traffic to the rules that you have set.

What are you trying to give priority? Looks like just SSL and DNS
are you trying to give it priority in or out..or both.

You should see all traffic get in a queue one way or another.
If your downloading at 400KB/s from a website on HTTP you should see about the same on the HTTP queue rule.


Here is a screen shot of it http://141networks.com/files/queue.JPG

If you want a export of it its here http://141networks.com/files/queue.txt

Re: high priority

Posted: Wed Aug 27, 2008 9:46 pm
by pokeman
thanks mate this really help me out to Qos

Re: high priority

Posted: Thu Aug 28, 2008 4:25 am
by NickOlsen
Any time :D

Re: high priority

Posted: Thu Aug 28, 2008 1:16 pm
by pokeman
Any time :D
can you give me idea about this
http://forum.mikrotik.com/viewtopic.php?f=2&t=25958

Re: high priority

Posted: Thu Aug 28, 2008 4:51 pm
by NickOlsen
I have never done anything with hotspot so your guess is as good as mine. Sorry.

Re: high priority

Posted: Sun Sep 07, 2008 9:28 pm
by alex_rhys-hurn
@NickOlsen

Just looking through your QOS example. I pasted it in to a testbed router I have.

Can I just ask what the theory is behind you setting a MaxLimit o f1900k on your upload_wan1 parent queue in the queue tree?

I assume that this is the capacity you have from your ISP, but why set it on the uplink and not also on the download_wan1 queue as well.

Will this work just as well without that max limit set?

Cheers,

Alex

Re: high priority

Posted: Sun Sep 07, 2008 11:38 pm
by NickOlsen
Well, I only noticed problems when i maxed out my 2mbs upload, which is why its limited to 1900k just to cover some overhead of SNMP and other things that are outside that parent.
I never noticed a problem limiting the download. And my download bursts to 18mbs or so and I didn't want to get rid of the bursts it randomly hits.
You can set a limit, I was great without one. test it, see what works best for you. If you get a really stable constant download speed then i would set the queue to that speed.
YMMV

Re: high priority

Posted: Mon Oct 13, 2008 3:47 pm
by atila
Can somebody help me with this stuff. When I add last mangle for all other packets nothing is count ! I must disable that rule and everything is working.
Is that OK ?
I still want to limit one interface witch using this QoS on 1 Mbps. Can I use simple queue in combination with this rules in tree queue to limit all traffic on interface or I must add rule to tree queue as parent rule.

I hope you can understand me :)
Thanks !