Community discussions

MikroTik App
 
User avatar
nickb
Member
Member
Topic Author
Posts: 406
Joined: Thu Jan 26, 2006 6:24 pm
Location: Southeast Kansas
Contact:

What's the best way to queue this?

Mon Nov 17, 2008 3:05 am

Greetings,

I've mostly only used simple queues, so I'm curious if there's a better way to set up the queuing for this scenario in a way that would possibly allow for better distribution of bandwidth and avoid a contention situation.

I have a 20Mbps Internet Access uplink on fast ethernet, then two more ethernet ports on the router. Each one represents a subnetwork that should be allocated 10Mbps internet access, with 15Mbps bursting.

This is my current configuration with simple queues. Bursting is not enabled right now.
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
    0/0 max-limit=10000000/10000000 name="Coffey County" parent=none \
    priority=8 queue=default-small/default-small target-addresses=\
    192.168.1.0/24 total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
    0/0 max-limit=10000000/10000000 name=Valnet parent=none priority=8 queue=\
    default-small/default-small target-addresses=\
    192.168.2.0/24,192.168.3.0/24,192.168.4.0/24 total-queue=default-small
Is there a better way to do this? Should I be using something besides default-small (which is a PFIFO)? Would a queue-tree be better? I'm not familiar with implementation of a queue tree, and the documentation is somewhat confusing to me.

My goals are, in this order:

1) Preventing a congestion situation on the internet uplink
2) Lowest latency
3) Fairest distribution of bandwidth

Thanks in advance for any advice.
 
valens
Trainer
Trainer
Posts: 244
Joined: Tue Jun 01, 2004 5:42 pm
Location: INDONESIA
Contact:

Re: What's the best way to queue this?

Tue Nov 18, 2008 2:23 pm

It's better you make a parent queue and put 20 Mbps as the limit-at and max-limit.
For both child queue, put limit-at=10mbps and max-limit=15mbps.
if both client run together, they will have max 10 mbps each.
 
User avatar
nickb
Member
Member
Topic Author
Posts: 406
Joined: Thu Jan 26, 2006 6:24 pm
Location: Southeast Kansas
Contact:

Re: What's the best way to queue this?

Tue Nov 18, 2008 7:20 pm

So when creating the parent queue queue is that under queue-tree? would I use global-total, or do I have to make one for each direction? Do I need to use packet marks?

What's the best queue-type to use for pure ethernet traffic, when there may be congestion situations?

I'm sorry for all of the questions but the documentation for this is very confusing!
 
User avatar
nickb
Member
Member
Topic Author
Posts: 406
Joined: Thu Jan 26, 2006 6:24 pm
Location: Southeast Kansas
Contact:

Re: What's the best way to queue this?

Fri Aug 28, 2009 8:17 pm

Sorry to resurrect an old topic, but I never did get this completed... still just using simple queues.

I've been tinkering, and I came up with this configuration:
/ip firewall mangle
add action=mark-connection chain=forward comment="" disabled=no \
    new-connection-mark=group1 passthrough=yes src-address=192.168.1.0/24
add action=mark-connection chain=forward comment="" disabled=no \
    new-connection-mark=group1 passthrough=yes src-address=192.168.2.0/24
add action=mark-connection chain=forward comment="" disabled=no \
    new-connection-mark=group1 passthrough=yes src-address=192.168.3.0/24
add action=mark-connection chain=forward comment="" disabled=no \
    new-connection-mark=group1 passthrough=yes src-address=192.168.4.0/24
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=20M \
    max-limit=20M name=Internet packet-mark="" parent=ether1 priority=8 \
    queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=10M \
    max-limit=20M name=Group2 packet-mark=group2 parent=Internet priority=8 \
    queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=10M \
    max-limit=20M name=Group1 packet-mark=group1 parent=Internet priority=8 \
    queue=default
What I think this should do (please correct me if I am wrong!) is to group 192.168.1.0/24, 192.168.2.0/24, and 192.168.3.0/24 together into the "group1" child queue such that they will share that 10Mbps queue. Then 192.168.4.0/24 will have its' own "group2" child queue with 10Mbps. The children would then share the "Internet" queue that has a fixed 20Mbps.

Who is online

Users browsing this forum: CJWW, EmuAGR, Kuitz, NetHorror, TheCat12 and 81 guests