Community discussions

MUM Europe 2020
 
zikachu
newbie
Topic Author
Posts: 35
Joined: Sat May 26, 2007 4:08 am

PPPoE with userman and Simultaneous Use

Tue Nov 18, 2008 8:33 am

hi;

it is working with hotspot(userman and hotspot), there is an option, named as shared users. and it work corretcly.

When i want to use userman with PPPoE server, also there is an option named as as only-one.
My problem is, same account can login many times mikrotik PPPoE server.(PPPoE with userman),


in PPPoE only-one options is only works with the local secrets; not with the radius and userman. but i want to use with it userman.

is there any way to use with userman ?

or i will setup externel free-raadius and set the simultaneous checking ?


best regards.
 
sophal
newbie
Posts: 34
Joined: Thu Aug 07, 2008 6:09 am
Location: Cambodia

Re: PPPoE with userman and Simultaneous Use

Tue Nov 18, 2008 10:39 am

hi,

please you take this script control user log in two time(pppeo):

:local userX;
:local userY;
:local i;
:local u;
:local clogged 0;
:local addr;
:local addr2;

:foreach i in=[/ppp active find] do={
:set userX [/ppp active get $i name];
:set clogged 0;

:foreach u in=[/ppp active find name=$userX ] do={
:set clogged (clogged +1);

:if (clogged>1) do={
:set userY [/ppp active get $u name];
:set addr [/ppp active get $u caller-id];
:set addr2 [/ppp active get $i caller-id];

:if ($addr != addr2) do={
:log info "MPPP: FIRST ACTIVE <<$userX>> FROM IP $addr2";
:log info "MPPP: THE $clogged° <<$userY>> CALLING FROM IP $addr NOW DISCONNECTED";
/ppp active remove $u;
}

}
}
}

sophal
 
zikachu
newbie
Topic Author
Posts: 35
Joined: Sat May 26, 2007 4:08 am

Re: PPPoE with userman and Simultaneous Use

Tue Nov 18, 2008 1:37 pm

big thanks sophal;

but it is not a real solution.

i cant find out with mikrotik do simultaneous check with pppoe server.

your script will good work when the mikrotik has pppoe user login script.


best regards.

Who is online

Users browsing this forum: Bing [Bot], davidnvega, durrsaku, MSN [Bot] and 125 guests