Community discussions

MikroTik App
 
User avatar
chimaster
Member Candidate
Member Candidate
Topic Author
Posts: 133
Joined: Tue Feb 07, 2006 8:54 am
Location: Queenstown
Contact:

TOS / DSCP, Queues and Voip

Wed Nov 19, 2008 5:23 am

Hey all,

I've been trawling through the forum and I think I need to pose a question. We've just started testing VOIP in our office and are hoping to migrate our main lines to a hosted PABX solution. For the first week it ran quite well, now it's started to go pear shaped. I believe it may be an issues with our up stream provider, but I want to do everything I can to eliminate it being us. Our outbound pipe is getting quite full, but I have QOS turned right up for voip and am not seeing any packets queuing up. The problem is the call keeps dropping out. We have a client using the same up stream provider and they are having the same problem, they have 1000% less traffic on their network than ours.

I added the following rules http://wiki.slfree.net/index.php/QoS_fo ... n_Mikrotik to our routers. I see packets being marked and going through, but still have the dropout issue. I don't see any queued traffic.

A few questions.

1. On the other site we have ROS 3.14 installed, I can't seem to find a way to isolate the DSCP tos values for the queue up there (although there is little traffic, I want to do all I can to eliminate our side of the equation as being at fault.). I tried wireshark and it doesn't pickup any sip calls or rtp traffic when calling. (I also plugged in via hub)

2. How much traffic should a single voip call require? I see about 40 - 70kbps, stabilising on 50kbps

3. How else can I test voip / qos. What other tool can I put in place / work with to fine tune and get the most out of it.

4. I'm seeing a lot of SIP traffic overhead, I though rtp should be the bulk of it. i.e. voip-sip 40MiB up and down, voip-rtp 18.3MiB.

I look forward to some suggestions, feel free to point me towards reading material I might of missed. ;-)
 
User avatar
BrianHiggins
Forum Veteran
Forum Veteran
Posts: 702
Joined: Mon Jan 16, 2006 6:07 am
Location: Norwalk, CT
Contact:

Re: TOS / DSCP, Queues and Voip

Sat Nov 22, 2008 3:12 am

This is a basic form for what I use in our routers, if you want it to catch all SIP traffic to or from anywhere, remove one of the jump rules and change the remaining one to not match on the VoIP Servers address list, just the SIP connection type

Change your simple Queue settings to match the ammount of bandwidth you want to ensure the calls get.

and to answer the question about how much bandwidth a call uses, most normal SIP calls both transmit and receive 80kbps at 100 packets per second, however this can be changed in some cases by using different compression types.
/ip firewall mangle
add action=jump chain=prerouting comment=VoIP connection-type=sip disabled=no \
    dst-address-list="VoIP Servers" jump-target=VoIPChain
add action=jump chain=prerouting comment=VoIP connection-type=sip disabled=no \
    jump-target=VoIPChain src-address-list="VoIP Servers"
add action=mark-packet chain=VoIPChain comment="" disabled=no \
    new-packet-mark=VoIP passthrough=yes
add action=add-dst-to-address-list address-list="Active VoIP Clients" \
    address-list-timeout=1m chain=VoIPChain comment="" disabled=no \
    dst-address-list="!VoIP Servers"
add action=change-dscp chain=VoIPChain comment="" disabled=no dscp=!46 \
    new-dscp=46
add action=accept chain=VoIPChain comment="" disabled=no

/ip firewall address-list
add address=1.2.3.4/26 comment=UpstreamProviderName disabled=no list="VoIP Servers"


/queue type
add kind=pfifo name=VoIP pfifo-limit=10

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
    2000000/2000000 max-limit=10000000/10000000 name=VoIP packet-marks=VoIP \
    parent=none priority=1 queue=VoIP/VoIP total-queue=VoIP

Who is online

Users browsing this forum: GoogleOther [Bot], MarkusT and 137 guests