Community discussions

MUM Europe 2020
 
User avatar
omidkosari
Trainer
Trainer
Topic Author
Posts: 631
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Mikrotik PPPOE TIMEOUT BUG

Mon Dec 08, 2008 12:27 pm

This topic is resume of http://forum.mikrotik.com/viewtopic.php?f=2&t=26030 and http://forum.mikrotik.com/viewtopic.php?f=2&t=12572 .

Still i am connected and mikrotik shows that i am connected also

In the "time out" i have 2 choice
1.disconnect and connect again
2.wait to problem solve by itself

You can see swf file . it says everything.



Every suggestion appreciated .
Last edited by omidkosari on Tue Dec 09, 2008 5:44 pm, edited 1 time in total.
 
Inssomniak
Member
Member
Posts: 326
Joined: Fri Apr 13, 2007 11:21 pm

Re: Mikrotik PPPOE TIMEOUT BUG

Mon Dec 08, 2008 5:06 pm

I have ver 3.10 on p4 1.6 router (no wireless cards) thats working flawlessly uptime for 151 days with approx 65 PPPoE clients, yesterday I made some changes and created EOIP tunnels from my other APs to have all PPPoE sessions terminate on this core router, now about 175 PPPoE sessions.

12 hours later all PPPoE sessions stopped, and when ping watchdog timer of wireless CPE rebooted it, they reconnected. Same with a few PPTP connections stopped. Needed reconnecting to start allowing traffic.

There are 8 pppoe server interfaces with different service names connected to the EOIP tunnel interface

I dont see any advantage to upgrading, changelog indicates no fix.
 
User avatar
omidkosari
Trainer
Trainer
Topic Author
Posts: 631
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Mikrotik PPPOE TIMEOUT BUG

Mon Dec 08, 2008 8:34 pm

Actually the problem i said does not happen to all pppoe users at same time. it occurs randomly for users but as you see , when it occurs it makes the user very angry and the service is unusable for just that user. the worse thing is the pppoe connection is still connected at both client and mikrotik side . if it disconnets it is better because user can config auto reconnect .
 
User avatar
omidkosari
Trainer
Trainer
Topic Author
Posts: 631
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Mikrotik PPPOE TIMEOUT BUG

Wed Dec 10, 2008 7:06 pm

http://forum.mikrotik.com/viewtopic.php ... 05#p137705
there an option about timeout i recomend to increase it , it may solve the problem as it occurs when there hight demand of traffic from user

when the user read his max limit , so mikrotik can't ping the pppoe client so it will considered as dead but it will not disconnect it !
You mean Keepalive Timeout ? i tested it also . increased and decreased . no success .

actually it is random and it is the worst thing.
Can it caused by Encoding for example MPPE128 statefull ?
 
jcremin
Member
Member
Posts: 360
Joined: Fri May 25, 2007 7:57 am

Re: Mikrotik PPPOE TIMEOUT BUG

Fri Dec 12, 2008 7:18 am

Can it caused by Encoding for example MPPE128 statefull ?

I used to use MPPE encryption, but I had many users (only NON Mikrotik clients, UBNT, Windows, etc) whose PPPoE session would be active but no data would pass. I disabled encryption and everything has been fine since.

Who is online

Users browsing this forum: jonmansey, kez, MSN [Bot] and 77 guests