Community discussions

MikroTik App
 
Falconix
just joined
Topic Author
Posts: 11
Joined: Tue May 24, 2005 2:15 am
Contact:

Graphing each host

Wed Dec 31, 2008 12:52 am

In version 2.6 or something old like that we used to have simple queues for each host in our network that means every customer we have. and then do queuing with Queue Tree.
The only reason we used Simple queue for each host was to have graphing via MRTG on an external server and to be able to limit the speed on specific customers.

Now we use version 3.15 and we have our Queue Tree with the mangles in the firewall and marking packages. But the problem is that when we do that the simple queue's doesn't work, we can put our customers in there but can't see the counters going.
I there any good explanation for that?

I planing to solve the graphing with Accounting and a script but that is not accurate.

I can say that we use static ip's for all customers.


Any other idea how I should do to graph for each customer (host), or how i should do to get simple queues and tree queues to work at the same time
 
Madrox
Frequent Visitor
Frequent Visitor
Posts: 80
Joined: Mon Sep 03, 2007 12:24 am

Re: Graphing each host

Wed Dec 31, 2008 5:14 am

Did have this problem before.
One of the v3 versions they change Queue Type to
default-small as standard i think, try to change to default.
that did work for me.
Hope its work ;)
 
Falconix
just joined
Topic Author
Posts: 11
Joined: Tue May 24, 2005 2:15 am
Contact:

Re: Graphing each host

Wed Dec 31, 2008 4:10 pm

hmms I have done some testing with Queue Tree and Simple Queues.

I tested with one Simple Queue With a target to an IP which I can test against.

Then I did some Queues in Queue Tree. one Main In and one Main Out with two children which I called as class 1 and class 2.

Without any mangles I could see Simple Queues counting.
But when started to mangle traffic I could see that the protocol or Port I mangled disappeared from Simple Queue's counting and ended up in Queue Tree and counted there instead.

And as you said before, using Queue Type Default worked in Simple Queue but not when I was working with Queue Tree and mangles at the same time.

I can remember that this worked well in version 2.6. This test was run in Version 3.17

Conclusion: Queue Tree with Mangles and Simple Queue does not work along with each other, when I want to monitor one hosts traffic. I have no clue if this should work or not.

Did have this problem before.
One of the v3 versions they change Queue Type to
default-small as standard i think, try to change to default.
that did work for me.
Hope its work ;)
 
Madrox
Frequent Visitor
Frequent Visitor
Posts: 80
Joined: Mon Sep 03, 2007 12:24 am

Re: Graphing each host

Fri Jan 02, 2009 11:08 am

Im doing Simple queue and queue tree whit mangle,
post the simple queue conf, queue tree conf
 
Falconix
just joined
Topic Author
Posts: 11
Joined: Tue May 24, 2005 2:15 am
Contact:

Re: Graphing each host

Fri Jan 02, 2009 11:34 am

This is my configuration at the moment.
/ip firewall mangle
add action=mark-connection chain=prerouting comment="All Other : class2" disabled=no new-connection-mark=other_conn passthrough=yes
add action=mark-packet chain=prerouting comment="" connection-mark=other_conn disabled=no new-packet-mark=class2 passthrough=yes
add action=mark-connection chain=prerouting comment="HTTP: Class2" disabled=no layer7-protocol=http new-connection-mark=http_conn passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting comment="" connection-mark=http_conn disabled=no new-packet-mark=class2 passthrough=yes
add action=mark-connection chain=prerouting comment="SSH: Class1" disabled=no layer7-protocol=ssh new-connection-mark=ssh_conn passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=4141 new-connection-mark=ssh_conn passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting comment="" connection-mark=ssh_conn disabled=no new-packet-mark=class1 passthrough=yes
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=0/0 name=IP102 parent=none priority=8 \
    queue=default/default target-addresses=192.168.0.102/32 total-queue=default-small
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100000000 name=IN packet-mark="" parent=global-in priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100000000 name="class 1 in" packet-mark=class1 parent=IN priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100000000 name="class 2 in" packet-mark=class2 parent=IN priority=2 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100000000 name=OUT packet-mark="" parent=global-out priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100000000 name="class 1 out" packet-mark=class1 parent=OUT priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100000000 name="class 2 ut" packet-mark=class2 parent=OUT priority=2 queue=default
For the ssh mangle and http I use Layer 7
/ip firewall layer7-protocol
add comment="" name=http regexp="http/(0\\.9|1\\.0|1\\.1) [1-5][0-9][0-9] [\\x09-\\x0d -~]*(connection:|content-type:|content-length:|date:)|post [\\x09-\\x0d -~]* http/[01]\\.[019]"
add comment="" name=ssh regexp="^ssh-[12]\\.[0-9]"
Im doing Simple queue and queue tree whit mangle,
post the simple queue conf, queue tree conf

Who is online

Users browsing this forum: eworm, ieleja, joffrey575 and 153 guests