Community discussions

MikroTik App
 
phil1995
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Oct 26, 2007 5:54 am

Print system configuration

Fri Jan 09, 2009 10:08 pm

Can someone tell me how to print out the configuration of a router?

I am building up a new router that will have very similar configuration and would like to print out my current one and use it as a reference sheet.

Any help would be greatly appreciated.
 
User avatar
roadrunner
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Thu May 18, 2006 11:22 pm
Location: US

Re: Print system configuration

Fri Jan 09, 2009 10:39 pm

Try the command 'export' you do it in a specific directory to only save those settings if needed.
You can also just use the backup & restore system.

Export outputs a text file with all the commands, I don't think backup is a text file that can be read.
You might want to only export certain parts, exporting the whole configuration may generate too large of a file to easily use.
 
phil1995
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Oct 26, 2007 5:54 am

Re: Print system configuration

Fri Jan 09, 2009 10:47 pm

Thanks for you help.
 
ziigmund
just joined
Posts: 24
Joined: Sat Nov 17, 2018 10:39 am

Re: Print system configuration

Thu Nov 22, 2018 3:06 pm

/interface bridge
add fast-forward=no name=bridge1
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
/interface bridge settings
set use-ip-firewall=yes
/ip address
add address=10.1.1.50/24 network=10.1.1.0
/system routerboard settings
set silent-boot=no
The gateway is another mikrotik behind my bridge. I want to filter the traffic before the gateway.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1741
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: Print system configuration

Thu Nov 22, 2018 3:35 pm

You may have posten at a wrong location. This information has nothing to do with the topic :)
 
How to use Splunk to monitor your MikroTik Router(s)

MikroTik->Splunk
 
 
User avatar
Steveocee
Forum Guru
Forum Guru
Posts: 1127
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: Print system configuration

Thu Nov 22, 2018 4:42 pm

Using export via terminal is the best way to "see" your config in it's raw format. A slightly more person friendly approach would be to do something like;
export file=myrouterexport
This saves the export locally.
Then using Winbox go into "Files" and download the complete RSC file.
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials

Who is online

Users browsing this forum: bsafarli, eworm, sindy and 69 guests