Community discussions

 
godovic
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Sun Mar 08, 2009 11:52 pm

multi wan load balancing - ADSL, DSL, Cable modem

Tue Mar 10, 2009 2:39 pm

I need a solution how to setup 3 WAN ports from 3 different ISPs (PPPoE, Leased Line and Cable internet), so clients can use all of them with load balancing based either on least used bandwidth or round robin. I don’t want to separate clients in groups, but all of them should have access to all 3 WANs. If some of the WANs fall, the clients should be admitted to use only the working WANs. (WANs with positive uplink).

I had read some WIKIs about load balancing, but cannot find solution for my problem. I want to acknowledge that my requirement already works fine with Level1 FBR-4000 which have 4 WAN ports but is very slow and have freeze problems with QoS or bandwidth limiting.

I have router board RB493 with Mikrotik OS 3.11

Sorry for my English
Last edited by godovic on Thu Apr 23, 2009 12:29 am, edited 2 times in total.
 
User avatar
enk
Member Candidate
Member Candidate
Posts: 165
Joined: Fri Aug 17, 2007 8:59 am
Location: Russia
Contact:

Re: multi wan load balancing and aggregating?

Mon Mar 16, 2009 2:59 pm

try to search
http://forum.mikrotik.com/search.php?st ... +balancing
take for example this article:
http://wiki.mikrotik.com/wiki/Load_Bala ... e_Gateways
but if you don like group users, try to make as follow:
/ip firewall mangle
add action=mark-routing chain=prerouting comment="" disabled=no new-routing-mark=ISP_A passthrough=yes random=33 \
    src-address=10.0.0.0/24
add action=mark-routing chain=prerouting comment="" disabled=no new-routing-mark=ISP_B passthrough=yes random=33 \
    src-address=10.0.0.0/24
add action=mark-routing chain=prerouting comment="" disabled=no new-routing-mark=ISP_C passthrough=yes random=33 \
    src-address=10.0.0.0/24
This action will do somthing like equal bandwidth sharing for 3 ISP with 33% balance in theory. 10.0.0.0/24 - is you customers (users) subnetwork for example.
as known as shados.
blog: http://betep.wpl.ru
A karma increase would be cool if you think I earned it.
 
godovic
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Sun Mar 08, 2009 11:52 pm

Re: multi wan load balancing and aggregating?

Wed Apr 22, 2009 11:36 pm

Can someone post a configuration or simple walk-trough for multi wan configuration ?

The wiki about Load Balancing over Multiple Gateways does not solve the problem because If i divide the users in two or more groups I can use two or more stand alone routers.

And I need multiple interfaces not gateways because ADSL and Cable modem are using PPPoE and have dynamic IP addresses and gateways.
 
GuJack20
Trainer
Trainer
Posts: 322
Joined: Sat Jun 12, 2004 9:44 pm
Location: Tirana
Contact:

Re: multi wan load balancing and aggregating?

Thu Apr 23, 2009 12:18 am

The solution you need is called ECMP (Equal Cost Multipath). At the moment, the ECMP in MikroTik doesn't do any good. You can read some topics down in this forum. I'm waiting from some time now to have a fix from MikroTik about this, but until now ECMP is unusuable. :(:(:(
--Do you remember that guy who gave up? Neither does anybody else!

Who is online

Users browsing this forum: No registered users and 111 guests