Community discussions

MikroTik App
 
ilero
newbie
Topic Author
Posts: 49
Joined: Fri Jun 04, 2004 3:51 pm

HELP with setting up MT as AP and Station

Sun May 08, 2005 1:37 am

I have worked with MT as a router for a couple years, but I have never set it up as an AP or station....

When I am setting up a MT as an AP, do I create a Bridge interface that includes ether1 and wlan1? And what interface do I set up the "management" IP on (the Bridge, wlan, or ether1)?

Same goes for the station... Do I set up a bridge which includes ether1 and wlan1? Do I set up the IP on the bridge or on one of the separate interfaces?

Just let me know...Thanks
 
mp3turbo2
Member Candidate
Member Candidate
Posts: 196
Joined: Wed Jun 02, 2004 9:15 am

Sun May 08, 2005 8:36 am

bridging and AP are different things. To set up wireless AP and wireless clients connecting to it using routable network (which is far better than bridged), just do this:

machine1: {AP server}
/interface wireless
print
enable 0 {enable wireless interface}
set 0 name=readable-name-of-your-wireless-card ssid=your-wish band=2.4GHz-b {up to 5GHz-turbo according to what you have} freq=2442 {or whatever suits you} mode=ap-bridge {this is Access Point}
/ip address
add address=a.b.c.d/mask interface=readable-name-of-your-wireless-card
/ip route
... set up routing as usual, you know it from wired networks

machine2,3,4 etc {wireless clients}
/interface wireless
print
enable 0 {enable wireless interface}
set 0 name=whatever-readable-name ssid=your-wish band=2.4GHz-b {up to 5GHz-turbo according to what you have} freq=2442 {or whatever suits you} mode=station {this is client}
/ip address
add address=a.b.c.e/mask interface=readable-name-of-your-wireless-card
/ip route
... set up routing as usual, you know it from wired networks

{note that I typed a.b.c.D as address for AP and a.b.c.E as address for client meaning they have to be different, but from the same TCP/IP subnet}.

That's it. The only things that you set are wireless band used, SSID and frequency. Of course, one machine has to be SERVER (ap-bridge), all others have to be clients (STATION).

bye, mp3turbo.

Who is online

Users browsing this forum: almdandi, ariux, Google [Bot], maigonis, mukkelek, Zan and 114 guests