Community discussions

 
rxrxrx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 95
Joined: Fri Mar 13, 2009 4:45 pm

hotspot kills my LAN

Tue Mar 17, 2009 3:31 pm

hi, im using mikrotik 3.20 to create a hotspot point.
it worked OK for a couple of weeks,then i got a call from a LAN user (no wifi ,not connected to hotspot box) that, he got a message on his browser, that asks him a username/password. which is hotspot login page.

i guess,a user has a bridge between his wireless and LAN adapter that is probaby windows' sharing internet feature or something like that.

and since mikrotik hotspot is likely doing some arp poisoning (not sure,but i guess that also), the LAN users are spoofed immediately i turn on the mikrotik box. (i had to shut down it on the first call)

how can i fix that ?

thanks
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: hotspot kills my LAN

Tue Mar 17, 2009 4:38 pm

fix what? it's designed behaviour - users access hotspot independently of their network settings
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: hotspot kills my LAN

Wed Mar 18, 2009 9:13 am

if that user accidently connected to your wireless hotspot network, and got the login screen - that is what's supposed to happen. tell him not to connect to other unknown netoworks, and turn off the wifi card when not using it.
No answer to your question? How to write posts
 
rxrxrx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 95
Joined: Fri Mar 13, 2009 4:45 pm

Re: hotspot kills my LAN

Wed Mar 18, 2009 11:12 am

thanks for replies.

no the user is not accidently connected to hotspot.
and it is of course expected, for wifi users to get login pages.

|INTERNET|____|HOTSPOT|~~~~|hotspot user|_______{LAN}_______|LAN GATEWAY|______|INTERNET|

the problem is, LAN users are getting hotspot login page (not connected to hotspot directly)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: hotspot kills my LAN

Wed Mar 18, 2009 1:14 pm

if that user uses bridge - then LAN users ARE connected to hotspot directly, using bridge =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
rxrxrx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 95
Joined: Fri Mar 13, 2009 4:45 pm

Re: hotspot kills my LAN

Wed Mar 18, 2009 2:08 pm

if that user uses bridge - then LAN users ARE connected to hotspot directly, using bridge =)

yeah,cant i deny that ? (that is what i mean _to_fix_ in first post.)
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: hotspot kills my LAN

Wed Mar 18, 2009 2:09 pm

how can you deny your client's to use bridge? they can use whatever software they want, can't they? this is like running another DHCP server in the network - it will also cause major problems.
No answer to your question? How to write posts
 
rxrxrx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 95
Joined: Fri Mar 13, 2009 4:45 pm

Re: hotspot kills my LAN

Wed Mar 18, 2009 2:24 pm

so 1 solution left for me.
disable hotspot,and use a basic dhcp server, and mac filtering (instead of giving user/pass to users) via firewall.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: hotspot kills my LAN

Wed Mar 18, 2009 2:41 pm

do you think this can happen very often when somebody bridges their cards accidently? I've never heard such issues before
No answer to your question? How to write posts
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: hotspot kills my LAN

Wed Mar 18, 2009 11:36 pm

if someone from LAN complains, tell him that the reason is that user with bridge - it's not your trouble! why the hell should you answer the malicious actions of other users?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
rxrxrx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 95
Joined: Fri Mar 13, 2009 4:45 pm

Re: hotspot kills my LAN

Thu Mar 19, 2009 9:28 am

do you think this can happen very often when somebody bridges their cards accidently? I've never heard such issues before
i am not sure of the bridge, but imho, its the only possibility.

if someone from LAN complains, tell him that the reason is that user with bridge - it's not your trouble! why the hell should you answer the malicious actions of other users?
i cant control users to not to make bridges etc. that is right.
but the box that is doing arp spoofing is mine,anyways.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: hotspot kills my LAN

Thu Mar 19, 2009 12:04 pm

but the box that is doing arp spoofing is mine,anyways.
if somebody has stolen your car and knocked down somebody - it's not your problem again =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
wireless12
Member Candidate
Member Candidate
Posts: 295
Joined: Fri Aug 31, 2007 10:49 am

Re: hotspot kills my LAN

Thu Mar 19, 2009 12:17 pm

ooooooooops if its really an ARP poisoning (i wish is is not) only GOD can save you. if suffer a lot by this issue and my entire wisp network become a fish market. but i don't know how i came out with it, i remember i disallow all the wlan interface and allow them one by one only after formating the computer and installing a decent anti-virus in each computer.

then only i was able to was able to make my network stable agian

hope this helps
 
rxrxrx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 95
Joined: Fri Mar 13, 2009 4:45 pm

Re: hotspot kills my LAN

Thu Mar 19, 2009 12:20 pm

ooooooooops if its really an ARP poisoning (i wish is is not) only GOD can save you. if suffer a lot by this issue and my entire wisp network become a fish market. but i don't know how i came out with it, i remember i disallow all the wlan interface and allow them one by one only after formating the computer and installing a decent anti-virus in each computer.

then only i was able to was able to make my network stable agian

hope this helps
arp spoofing box is not an infected workstation, it is the design of hotspot.

Who is online

Users browsing this forum: MSN [Bot] and 81 guests