Community discussions

 
User avatar
kameelperdza
Member
Member
Topic Author
Posts: 469
Joined: Thu Nov 27, 2008 11:45 am
Location: Oudtshoorn, South Africa

Please help me with qeue rules

Sun Mar 29, 2009 5:55 pm

Hi im having trouble setting up qeue rules. I have clinets that connect to my AP. BUt the rules is not working. The rules that i have added is


/ queue simple
add name="main" target-addresses=192.168.8.0/24 max-limit=128000/128000
add name="http" parent=main packet-marks=http max-limit=128000/128000
add name="p2p" parent=main packet-marks=p2p max-limit=64000/64000
add name="other" parent=main packet-marks=other max-limit=128000/128000

I want to give each client that to connects to the AP to have 128kbs speed. The range of the network is 192.168.8.0/24. I have addes the qeue simple rules but is is not working.Any help please. thanx
Give me some karma
 
User avatar
taglio
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Wed Nov 12, 2008 4:55 pm
Location: 34T, Barcelona, Spain

Re: Please help me with qeue rules

Tue Mar 31, 2009 2:15 pm

You can do this in another way with queues tree pcq and HTB interfaces.
You can find more explicacion of this process at http://mum.mikrotik.com/presentations/C ... _Megis.pdf.

First at all mangle traffic from your local network:
/ip firewall mangle
add action=accept chain=forward comment="#####################################\
    #MANGLE x SHAPING#########################################################\
    " disabled=yes
add action=mark-connection chain=forward comment="" disabled=no \
    new-connection-mark=lan passthrough=yes src-address=192.168.8.0/24
add action=mark-packet chain=forward comment="" connection-mark=lan disabled=\
    no new-packet-mark=lan-packet passthrough=no
add action=log chain=forward comment="" disabled=no log-prefix=\
    "MANGLE: NOT MARKED:" src-address=192.168.8.0/24
After create PCQ queues to grep download and upload traffic [in this example i have got less then 20 users connected]
/queue type
add kind=pcq name=download pcq-classifier=dst-address [color=#FF0000]pcq-limit=50[/color] pcq-rate=128000 \
    [color=#FF0000]pcq-total-limit=200[/color]
add kind=pcq name=upload pcq-classifier=src-address [color=#FF0000]pcq-limit=50[/color] pcq-rate=128000 \
    [color=#FF0000]pcq-total-limit=200[/color]
Now we have to create parent queues that will depend by HTB interfaces [in this example i've got a pppoe-client interface for public and a bridge for internal interface]. After we will add pcq type queues with parent the twos that we've created
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no name=total_download packet-mark="" parent=bridge1 \
    priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no name=total_upload packet-mark="" parent=pppoe-out1 \
    priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=download packet-mark=lan-packet parent=total_download \
    priority=8 queue=download
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=upload packet-mark=lan-packet parent=total_upload \
    priority=8 queue=upload
To see more information in winbox remember to add PCQ Queues column to the Queues Tree window.
.mhavoc world
 
User avatar
kameelperdza
Member
Member
Topic Author
Posts: 469
Joined: Thu Nov 27, 2008 11:45 am
Location: Oudtshoorn, South Africa

Re: Please help me with qeue rules

Wed Apr 01, 2009 1:18 pm

thanx i will try that
Give me some karma

Who is online

Users browsing this forum: No registered users and 30 guests