Community discussions

 
bwm71
just joined
Topic Author
Posts: 6
Joined: Tue Mar 31, 2009 5:39 pm

Multiple public interfaces

Tue Mar 31, 2009 5:52 pm

Just wanted to be sure that RouterOS 3.3 can handle this. We want to multihome our internet connection with two ISPs and two interfaces on our MikroTik box. Our private side is a simple 192.168.1.0/24 network plugged into ether2. I'm assuming the best way to do this is to assign one public IP address to, say, ether5 and the other to ether4 and define the distance for the preferred route to be lower than the other. Correct?

Also, our current setup has our 192.168.1.0/24 gateway address assigned to bridge1 which spans ether1 - ether4. The connection is plugged into ether2, so I'm assuming the first thing I need to do is reassign 192.168.1.1 to ether2 rather than having it span bridge1.

Is RouterOS capable of what I want to do here and is this the best way?

Thanks,
Brandon
 
User avatar
taglio
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Wed Nov 12, 2008 4:55 pm
Location: 34T, Barcelona, Spain

Re: Multiple public interfaces

Tue Mar 31, 2009 7:01 pm

.mhavoc world
 
bwm71
just joined
Topic Author
Posts: 6
Joined: Tue Mar 31, 2009 5:39 pm

Re: Multiple public interfaces

Tue Mar 31, 2009 7:49 pm

Thanks for the info. What I want to do is a failover setup rather than loadbalancing. I would think that instead of adding a route like

add dst-address=0.0.0.0/0 gateway=10.111.0.1,10.112.0.1 check-gateway=ping

I would do something like

add dst-address=0.0.0.0/0 gateway=10.111.0.1 check-gateway=ping distance=1
add dst-address=0.0.0.0/0 gateway=10.112.0.1 check-gateway=ping distance=2

where 10.111.0.1 is the ISP gateway I want to use by default? Would everything else described at http://wiki.mikrotik.com/wiki/Load_Balancing_Persistent stay the same?

Brandon
 
bwm71
just joined
Topic Author
Posts: 6
Joined: Tue Mar 31, 2009 5:39 pm

Re: Multiple public interfaces

Tue Mar 31, 2009 8:08 pm

OK, I found the failover Wiki and it looks like I need to do something like

/ip route
add gateway=10.111.0.1 check-gateway=ping
add gateway=10.112.0.1 distance=2

I guess where I'm confused now is does routerOS automatically know what interface these gateways are to be associate with based on the address assigned each interface? Or is that something that doesn't matter with routes?

Do I need any /ip firewall mangle or /ip firewall nat rules as discussed in the load balancing Wiki?
 
User avatar
taglio
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Wed Nov 12, 2008 4:55 pm
Location: 34T, Barcelona, Spain

Re: Multiple public interfaces

Wed Apr 01, 2009 12:36 pm

I guess where I'm confused now is does routerOS automatically know what interface these gateways are to be associate with based on the address assigned each interface?
Yes it's automatic.
Do I need any /ip firewall mangle or /ip firewall nat rules as discussed in the load balancing Wiki?
I don't think so. Just try it!
.mhavoc world
 
bwm71
just joined
Topic Author
Posts: 6
Joined: Tue Mar 31, 2009 5:39 pm

Re: Multiple public interfaces

Wed Apr 01, 2009 3:36 pm

Actually, I ended up going with the load balancing setup described in the wiki. Is there a typo in the wiki? Shouldn't

/ ip firewall mangle
add chain=input in-interface=wlan1 action=mark-connection new-connection-mark=wlan1_conn
add chain=input in-interface=wlan2 action=mark-connection new-connection-mark=wlan2_conn
add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wla1
add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wla2

actually be/ ip firewall mangle
add chain=input in-interface=wlan1 action=mark-connection new-connection-mark=wlan1_conn
add chain=input in-interface=wlan2 action=mark-connection new-connection-mark=wlan2_conn
add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wla1
add chain=output connection-mark=wlan2_conn action=mark-routing new-routing-mark=to_wla2

The last rule should be wlan2_conn instead of wlan1_conn, correct?
 
User avatar
taglio
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Wed Nov 12, 2008 4:55 pm
Location: 34T, Barcelona, Spain

Re: Multiple public interfaces

Thu Apr 02, 2009 11:16 am

Yes i think so.
.mhavoc world
 
mehrzud
newbie
Posts: 47
Joined: Wed Aug 04, 2010 5:08 pm

Re: Multiple public interfaces

Fri Jun 17, 2011 9:28 pm

Does anyone have any idea about this post?
http://forum.mikrotik.com/viewtopic.php?f=2&t=52654
 
User avatar
Caci99
Forum Guru
Forum Guru
Posts: 1064
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: Multiple public interfaces

Fri Jun 17, 2011 10:53 pm

Does anyone have any idea about this post?
http://forum.mikrotik.com/viewtopic.php?f=2&t=52654
I do have one. Sit back and relax until someone will answer
-Toni-
Don't crash the ambulance, whatever you do
 
mehrzud
newbie
Posts: 47
Joined: Wed Aug 04, 2010 5:08 pm

Re: Multiple public interfaces

Sat Jun 18, 2011 12:37 am

I do have one. Sit back and relax until someone will answer
Blank face is fine. The computer works faster than the brain, don't forget. The art of acting is not to act. Once you show them more, what you show them, in fact, is bad acting. (Anthony Hopkins)

Who is online

Users browsing this forum: No registered users and 105 guests