Community discussions

MUM Europe 2020
 
theblop
just joined
Topic Author
Posts: 8
Joined: Thu Apr 23, 2009 12:45 am

ssh tunnel to internal socks proxy -> crash

Fri Apr 24, 2009 3:10 am

Hi,

I use a RB 450G as my main router at home with RouterOS 3.23 and I'd like to use its socks proxy server through the ssh management interface. The typical scenario is using my home network as a proxy for firefox when I'm away from home, without having to leave the socks proxy server open to the public internet.

- I enabled the socks server on port 1080 and denied all connections from everywhere except 127.0.0.1.
- I connect to the router with this command:
ssh -L5555:127.0.0.1:1080 admin@router
- and configure firefox to use localhost:5555 as a socks v4 proxy.

The proxy works briefly with google and a few other small pages but the ssh connection disconnects as soon as I load a more complicated page. Maybe the ssh server on RouterOS doesn't like to tunnel too much data? Is there any way to fix this?

Thanks

Arnaud
 
User avatar
che
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Fri Oct 07, 2005 1:04 pm

Re: ssh tunnel to internal socks proxy -> crash

Tue Jun 09, 2009 3:30 pm

Same problem here, but different board and newest ROS. Only difference is that router created autosupout file, which I sent to their support. Seems like router processor hangs to 100% after this connection. Will reply here if I get anything worth mentioning from support.
 
User avatar
che
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Fri Oct 07, 2005 1:04 pm

Re: ssh tunnel to internal socks proxy -> crash

Mon Jun 15, 2009 3:38 pm

We will have to continue using Linux for this purpose. At least we had some adventurer spirit. :)
tunnel mode will be fully disabled in next version of RouterOS as it should
have been. Try to use other tunnel type is you need secure connection (PPTP
for example)
 
theblop
just joined
Topic Author
Posts: 8
Joined: Thu Apr 23, 2009 12:45 am

Re: ssh tunnel to internal socks proxy -> crash

Mon Jun 15, 2009 4:24 pm

We will have to continue using Linux for this purpose. At least we had some adventurer spirit. :)
tunnel mode will be fully disabled in next version of RouterOS as it should
have been. Try to use other tunnel type is you need secure connection (PPTP
for example)
Well it's a shame, because ssh tunneling is very useful for a lot of things especially when pptp is blocked by a corporate firewall.
There is already a web-proxy package based on Squid available for RouterOS, so why not a fully-featured openssh package to replace or run along the limited ssh management daemon?

Who is online

Users browsing this forum: Google [Bot], paulct and 136 guests