Community discussions

MikroTik App
 
randallr
Member Candidate
Member Candidate
Topic Author
Posts: 104
Joined: Fri Oct 13, 2006 1:01 am
Location: Texas

Bug in 3.23

Fri May 15, 2009 6:55 pm

I have a scheduler event that runs at midnight that's always worked on previous versions, but it will not create the file since upgrade to 3.23.

/queue simple print stats file stats

It works fine from the command line. I've tried executing a script instead, that contains the line, and it will not create the file either.

Any ideas?
 
User avatar
JJCinAZ
Member
Member
Posts: 474
Joined: Fri Oct 22, 2004 8:03 am
Location: Tucson, AZ
Contact:

Re: Bug in 3.23

Fri May 15, 2009 7:04 pm

Though I don't think it's your problem, you should have the equal sign:
/queue simple print stats file=stats

You said you tried putting that in a script and then executing the script from the scheduler and it didn't work. Did you try running the script manually and did it work? I haven't had problems with the scheduler in 3.23 myself.
 
randallr
Member Candidate
Member Candidate
Topic Author
Posts: 104
Joined: Fri Oct 13, 2006 1:01 am
Location: Texas

Re: Bug in 3.23

Fri May 15, 2009 7:11 pm

Sorry for the confusion. The scheduler executes , but the file does not show under files.
I created a script which also shows to execute, but the file does not show under files.
If I run the line from command line, the file appears under files.

I don't think the problem is with the scheduler, I think it's with the command itself:
/queue simple print stats file stats

Ver 3.23 doesn't seem to want to create the file stats.txt while running except from the command line.

Again, it works fine in the background in older versions.
 
User avatar
JJCinAZ
Member
Member
Posts: 474
Joined: Fri Oct 22, 2004 8:03 am
Location: Tucson, AZ
Contact:

Re: Bug in 3.23

Fri May 15, 2009 7:14 pm

A script with the command above works on my 3.23 router. Try creating a new script from scratch?
 
randallr
Member Candidate
Member Candidate
Topic Author
Posts: 104
Joined: Fri Oct 13, 2006 1:01 am
Location: Texas

Re: Bug in 3.23

Fri May 15, 2009 7:45 pm

The problem was with policy.

I created from command line, and it added this and it created file okay:
policy=ftp,reboot,read,write,policy,test,winbox,password,sniff

I created scheduler event from the command line and it add this and didn't create file:
policy=read,write,test

I changed the scheduler policy to the one created in script, and the command creates the file just fine!

Thanks
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8393
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Bug in 3.23

Sat May 16, 2009 9:20 pm

yes, you need 'ftp' policy to work with files
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.

Who is online

Users browsing this forum: aboiles, cillininfo, Google [Bot], robsgax and 119 guests