Page 1 of 1

Possibile routing problem I cannot solve :(

Posted: Mon Jun 08, 2009 1:29 am
by titius
I have a interesting problem here :). At least for me it is interesting :).

I have small WLAN community and internet conenction with proxy.

Ill try to explain as best as I can.

I have 4 Mikrotik routers from my village to city 45 KM away, wireless link and in a city have wireless connection that is NAT-ed. i decided to use pptp from my home RouterBoard to Internet router, and then have routing mark for proxy so my default route gateway is IP of remote PPTP interface.

On the Internet NAT routerboard I have static route to proxy with gateway of home PPTP interface.

At first everything seems allright, I can use the web everyone else also can surf.

BUT then someone noticed that some pages simply cannot be opened. For example speedtest.net but there are som more pages that no one can open. tracerouting from proxy machine is successfull.

Then I disabled static route form Internet RB, now traffic is routed through all RB-s. And traffic from proxy to Internet RB is routed over PPTP interface.

NOW we can open those pages, but cannot login to any sites, eg. facebook, gmail etc. . .

Can someone help me with my problem, I guess it is routing problem.

Re: Possibile routing problem I cannot solve :(

Posted: Mon Jun 08, 2009 5:40 pm
by Egate
Sounds complicated to me. Run rip on each mikrotik board. This will automatically sort all routing, if ip structure is sound. Works very stable. If routing problem, this will sort it.

Re: Possibile routing problem I cannot solve :(

Posted: Tue Jun 16, 2009 4:26 pm
by titius
Hm I solved it with replacing server side to be client and client side to be server. ?