Community discussions

 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

How To Block youtube.com ???

Sat Jul 18, 2009 12:30 pm

Hello, Please Help Me To Block youtube.com as my users cannot surf the site http://www.youtube.com.
I am using MT ROS 3.20 I would like to block it by regexp, but I don't know how.
Help me please solve the problem.

Thanks
Regards Karapet Aznavuryan
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: How To Block youtube.com ???

Sat Jul 18, 2009 12:57 pm

do you use web-proxy?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Re: How To Block youtube.com ???

Sat Jul 18, 2009 1:41 pm

Yes I Use Proxy, MT Proxy,
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: How To Block youtube.com ???

Sat Jul 18, 2009 3:19 pm

/ip proxy access
add disabled=no dst-host=youtube.com action=deny
add disabled=no dst-host=*.youtube.com action=deny
http://www.mikrotik.com/testdocs/ros/3.0/pnp/proxy.php
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Re: How To Block youtube.com ???

Thu Jul 23, 2009 2:48 pm

Thanks for Reply
 
channelasian
newbie
Posts: 28
Joined: Thu Jun 11, 2009 8:55 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 4:09 am

not work for me.

i am using mikrotik RT v3.30

1 WAN share internet no web proxy

i want to block the those website like youtube, facebook...

last time it worked for me by just used this /ip firewall filter> add chain=forward action=drop content=youtube

but now it didnt work for me dont kno why. please help.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 5:05 am

The web proxy method is the best way to go.
 
channelasian
newbie
Posts: 28
Joined: Thu Jun 11, 2009 8:55 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 11:33 am

The web proxy method is the best way to go.
but when i followed the instruction all redirected to mikrotik page.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 7:22 pm

Well, yes. That's exactly how it works. If you want to redirect to something else use the 'redirect-to' parameter to the proxy access rule. Refer to the manual for details.
 
channelasian
newbie
Posts: 28
Joined: Thu Jun 11, 2009 8:55 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 10:19 pm

i followed this
http://wiki.mikrotik.com/wiki/How_to_Block_Websites_&_Stop_Downloading_Using_Proxy
but it block all... when i go to any websites it redirect me to local mikrotik.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 10:43 pm

Then post the output of "/ip proxy export". The rules in that manual do not block everything.
 
channelasian
newbie
Posts: 28
Joined: Thu Jun 11, 2009 8:55 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 11:38 pm

the output of /ip proxy export
always-from-cache=no 
cache-administrator=webmaster 
cache-hit-dscp=4 
cache-on-disk=no 
enabled=no 
max-cache-size=none \
max-client-connections=600 
max-fresh-time=3d 
max-server-connections=600 
parent-proxy=0.0.0.0 
parent-proxy-port=0 port=8080 \
serialize-connections=no src-address=0.0.0.0
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 11:53 pm

Uhm. That web proxy isn't even enabled. There are no access rules to block anything.
 
channelasian
newbie
Posts: 28
Joined: Thu Jun 11, 2009 8:55 am

Re: How To Block youtube.com ???

Sat Nov 28, 2009 11:55 pm

can u please give me the correct configuration?

well, before i just add firewall rule chain forward and content drop it worked well. but dont kno what happen now.

Thanks
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: How To Block youtube.com ???

Sun Nov 29, 2009 12:04 am

Straight from the link you posted yourself:

Enable the proxy:
/ip proxy
set enabled=yes
set port=8080
Make it transparent and make sure it isn't open:
/ip firewall nat
chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080
/ip firewall filter
chain=input in-interface=<Your WAN Port> src-address=0.0.0.0/0 protocol=tcp dst-port=8080 action=drop
Now deny Youtube:
/ip proxy access
dst-host=www.youtube.com action=deny 
 
channelasian
newbie
Posts: 28
Joined: Thu Jun 11, 2009 8:55 am

Re: How To Block youtube.com ???

Sun Nov 29, 2009 12:19 am

i have followed yours above, but it still keep bring me to mikrotik login page.
 
magicgate
just joined
Posts: 3
Joined: Sun Dec 06, 2009 12:20 pm

Re: How To Block youtube.com ???

Sun Dec 06, 2009 12:34 pm

what's parent-proxy?!

i have v2.9.27

This method is compatible with this version 2.9.27?!

waiting
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: How To Block youtube.com ???

Sun Dec 06, 2009 4:25 pm

Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
vigorlackadaisically
just joined
Posts: 1
Joined: Sun Dec 13, 2009 1:23 am

Re: How To Block youtube.com ???

Sun Dec 13, 2009 1:32 am

use any fast proxy setting from punchrocket.com or stayinvisible
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1501
Joined: Sun Aug 27, 2006 6:49 am
Location: Maryland, USA
Contact:

Re: How To Block youtube.com ???

Sun Dec 13, 2009 6:03 pm

i have v2.9.27
Yet another crook. Jeeze.

Who is online

Users browsing this forum: Google [Bot], MSN [Bot] and 67 guests