Community discussions

MikroTik App
 
ctech4285
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Sat Aug 15, 2009 8:49 pm

load balancing over multiple gateways not working?

Sun Aug 23, 2009 9:03 pm

i got a rb433 with wan1(uplink1) and wlan1(uplink2) and wlan2(local) for hotspot users, and i am trying to get load balancing working
this is strait from http://digg.com/d3Y19v

the hotspot interface wlan2 (local) has 10.5.50.1
uplink1, the ether1 interface hasv192.168.1.64
and uplink2, the wlan1 interface has 17.16.31.2

[admin@MikroTik] /ip address> print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 ;;; hotspot network
10.5.50.1/24 10.5.50.0 10.5.50.255 local
1 D 192.168.1.64/24 192.168.1.0 192.168.1.255 uplink1
2 D 172.16.31.2/24 172.16.31.0 172.16.31.255 uplink2


[admin@MikroTik] /ip firewall mangle> print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=prerouting action=mark-connection new-connection-mark=conn1 passthrough=yes connection-state=new in-interface=local nth=2,1

1 chain=prerouting action=mark-routing new-routing-mark=conn1 passthrough=no in-interface=local connection-mark=conn1

2 chain=prerouting action=mark-connection new-connection-mark=conn2 passthrough=yes connection-state=new in-interface=local

3 chain=prerouting action=mark-routing new-routing-mark=conn2 passthrough=no in-interface=local connection-mark=conn2


[admin@MikroTik] /ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic
0 X ;;; place hotspot rules here
chain=unused-hs-chain action=passthrough

1 X ;;; masquerade hotspot network
chain=srcnat action=masquerade src-address=192.168.30.0/24

2 X ;;; masquerade hotspot network
chain=srcnat action=masquerade src-address=10.5.50.0/24

3 chain=srcnat action=masquerade out-interface=uplink1 connection-mark=conn1

4 chain=srcnat action=masquerade out-interface=uplink2 connection-mark=conn2


[admin@MikroTik] /ip route> print detail
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
0 A S dst-address=0.0.0.0/0 gateway=uplink1 reachable distance=1 scope=255 target-scope=10 routing-mark=conn1

1 A S dst-address=0.0.0.0/0 gateway=uplink2 reachable distance=1 scope=255 target-scope=10 routing-mark=conn2

2 ADC dst-address=10.5.50.0/24 pref-src=10.5.50.1 gateway=local distance=0 scope=10

3 ADC dst-address=172.16.31.0/24 pref-src=172.16.31.2 gateway=uplink2 distance=0 scope=10

4 ADC dst-address=192.168.1.0/24 pref-src=192.168.1.64 gateway=uplink1 distance=0 scope=10




[admin@MikroTik] /tool> trace google.com
invalid value for argument address
[admin@MikroTik] /tool> trace 74.125.45.100
ADDRESS STATUS
1 0.0.0.0 timeout timeout timeout
2 0.0.0.0 timeout timeout timeout
3 0.0.0.0 timeout timeout timeout
4 0.0.0.0 timeout timeout timeout
5 0.0.0.0 timeout timeout timeout
6 (unknown) timeout timeout timeout
[admin@MikroTik] /tool> /
[admin@MikroTik] > ping 74.125.45.100
no route to host
no route to host
no route to host
3 packets transmitted, 0 packets received, 100% packet loss

any pointers apriciated
regards
 
valens
Trainer
Trainer
Posts: 246
Joined: Tue Jun 01, 2004 5:42 pm
Location: INDONESIA
Contact:

Re: load balancing over multiple gateways not working?

Mon Aug 24, 2009 7:30 am

You need to add default route for the router itself.

/ip route add dst-address=0.0.0.0/0 gateway=uplink1,uplink2

or just use any gateway.

Who is online

Users browsing this forum: anav, Baidu [Spider], gotsprings and 156 guests