Community discussions

MUM Europe 2020
 
kostil
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Wed Jun 18, 2008 6:01 pm
Location: Moscow region, Russia

OSPF for PPPoE users with NSSA

Wed Sep 16, 2009 10:42 am

hi.

I read this doc about Dialup Design with the Dynamic IP Assignment from a Central Address Pool. I use mikrotik routers for PPPoE NAS and ROS 4.0beta4 (because there is no NSSA in 3.x) and cisco 3560 as ABR.

there is a configuration
cisco:
router ospf 7
 router-id 10.176.18.1
 log-adjacency-changes
 area 0 authentication
 area 0.0.0.5 authentication
 area 0.0.0.5 nssa
 network 10.176.18.0 0.0.0.7 area 0.0.0.5
and mikrotik:
/routing ospf instance
set default comment="" disabled=no distribute-default=never in-filter=ospf-in metric-bgp=20 metric-connected=20 \
    metric-default=1 metric-other-ospf=auto metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=as-type-1 redistribute-other-ospf=no redistribute-rip=no \
    redistribute-static=no router-id=10.176.18.2
/routing ospf area
add area-id=0.0.0.5 default-cost=1 disabled=no inject-summary-lsas=no instance=default name=area5 translator-role=\
    translate-always type=nssa
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
/routing ospf interface
add authentication=simple authentication-key=xxx authentication-key-id=1 cost=10 dead-interval=40s disabled=no \
    hello-interval=10s instance-id=0 interface=uplink network-type=broadcast passive=no priority=10 \
    retransmit-interval=5s transmit-delay=1s
/routing ospf network
add area=area5 disabled=no network=10.176.18.0/29
then i connect from my test computer to NAS there is no route on cisco routing table to this computer ip :(
maybe error in my configuration?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5965
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF for PPPoE users with NSSA

Wed Sep 16, 2009 11:02 am

3.x has NSSA if you enable routing-test package.
v3.28 and 4.0beta4 had problems with nssa which will be fixed in next version.
 
kostil
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Wed Jun 18, 2008 6:01 pm
Location: Moscow region, Russia

Re: OSPF for PPPoE users with NSSA

Fri Sep 25, 2009 9:01 am

I looked changelog for 3.30 and 4.0rc1 - there is no fix for NSSA bug.
Will it fix? When?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5965
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF for PPPoE users with NSSA

Mon Sep 28, 2009 9:54 am

Its not in changelog but it is fixed.
 
kostil
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Wed Jun 18, 2008 6:01 pm
Location: Moscow region, Russia

Re: OSPF for PPPoE users with NSSA

Mon Sep 28, 2009 4:13 pm

Thanks! It's work!

Who is online

Users browsing this forum: BRMateus2 and 123 guests