Community discussions

MikroTik App
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

PPPoE - MSS Correction BUG in 3.30

Tue Sep 22, 2009 12:34 pm

We have problems with MT 3.30 and MSS correction on PPPoE...

generated rules seems like this:
38 D chain=forward action=change-mss new-mss=1440 tcp-flags=syn protocol=tcp
in-interface=<pppoe-elektra-elvis> tcp-mss=1441-65535

39 D chain=forward action=change-mss new-mss=1448 tcp-flags=syn protocol=tcp
out-interface=<pppoe-elektra-elvis> tcp-mss=1449-65535

but not doing anything ...

after downgrade to 3.28 everything again OK
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1735
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: PPPoE - MSS Correction BUG in 3.30

Tue Sep 22, 2009 4:39 pm

Are you sure it is not some kind of bugfix? Ehat problems did you had with 3.30?
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

Re: PPPoE - MSS Correction BUG in 3.30

Tue Sep 22, 2009 5:56 pm

Are you sure it is not some kind of bugfix? Ehat problems did you had with 3.30?
It seems like rule is not processed .... but counter in mangle is counting packets ... Basicly this works like if we have MSS correction disabled ... so no rewrite in header and users have problems with opening pages from servers using MTU 1500 ....
 
kabelfrei
just joined
Posts: 16
Joined: Mon Jun 11, 2007 9:35 pm

Re: PPPoE - MSS Correction BUG in 3.30

Wed Sep 23, 2009 5:02 pm

It seems like rule is not processed .... but counter in mangle is counting packets ... Basicly this works like if we have MSS correction disabled ... so no rewrite in header and users have problems with opening pages from servers using MTU 1500 ....
Can anybody confirm this problem?

thanks and with best regards,

kabelfrei
 
Muqatil
Trainer
Trainer
Posts: 574
Joined: Mon Mar 03, 2008 1:03 pm
Location: London - UK
Contact:

Re: PPPoE - MSS Correction BUG in 3.30

Thu Sep 24, 2009 3:56 pm

Any update on this? :o
Renato Bernardi

skype: medtech5
 
McCJay
just joined
Posts: 5
Joined: Sun Jan 03, 2010 7:52 pm

Re: PPPoE - MSS Correction BUG in 3.30

Wed Jun 30, 2010 1:10 am

We are expeiencing similar issues with mss correction on rb450g's.

this seems to help, but it's not very elegant:

1. disable auto mss correction on pppoe interfaces
2. add these to /firewall mangle:

chain=prerouting action=mark-routing new-routing-mark=to_pppoe-international passthrough=yes in-interface=LAN connection-mark=pppoe-out1_conn
chain=prerouting action=mark-routing new-routing-mark=to_pppoe-local passthrough=yes in-interface=LAN connection-mark=pppoe-out1_conn
 
Pada
Member Candidate
Member Candidate
Posts: 150
Joined: Tue Dec 08, 2009 11:37 pm
Location: South Africa, Stellenbosch

Re: PPPoE - MSS Correction BUG in 3.30

Wed Jun 30, 2010 2:25 am

I'm not 100% if its due to the same "bug"...
I had to change my PPTP Client interface's max MTU (from the default of 1460 to like 1400) that was connecting to a server via a PPPoE connection in ROS v3.30. I can't remember that I've had to do that when the router was running ROS v4.5. I had the change TCP MSS left on default (enabled) in both versions.

Who is online

Users browsing this forum: erlinden, Google [Bot], menakaurtbneha and 215 guests