Community discussions

MUM Europe 2020
 
kostil
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Wed Jun 18, 2008 6:01 pm
Location: Moscow region, Russia

PPPoE and dynamic queue for Internet traffic only

Tue Sep 29, 2009 12:16 pm

hi,

I'm use mikrotik on my PPPoE servers (PPPoE,NAT,queue,OSPF). Radius server authenticate clients and set them speed limits on internet with Mikrotik-Rate-Limit attribute. All was fine until we connect to another local network which is became our peering network. We don't want to limit speed to this network for our clients. Is it possible to remove speed limit for some peering networks? We need to do it by radius server, depending of what tariff plan client are choose.
 
marklodge
Member Candidate
Member Candidate
Posts: 211
Joined: Sun Jun 21, 2009 6:15 pm

Re: PPPoE and dynamic queue for Internet traffic only

Sun Sep 11, 2011 1:03 pm

This is exactly what i'm trying to achive too.
Did you find a way to limit internet traffic only?
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: PPPoE and dynamic queue for Internet traffic only

Sun Sep 11, 2011 8:20 pm

Those rate limits are implemented via simple queues so this link applies: http://wiki.mikrotik.com/wiki/PCQ_and_H ... rate_limit
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
marklodge
Member Candidate
Member Candidate
Posts: 211
Joined: Sun Jun 21, 2009 6:15 pm

Re: PPPoE and dynamic queue for Internet traffic only

Mon Sep 12, 2011 12:13 am

Those rate limits are implemented via simple queues so this link applies: http://wiki.mikrotik.com/wiki/PCQ_and_H ... rate_limit
Currently i have dynamic queues set from the Mikrotik Usermanager.
Should i clear all the Rate Limits set in the mikrotik usermanger, and set up a different per-user limiting method?
because i have tried doing exactly as the above link shows, but it still limits the LAN traffic (Lan for me is ether2 to ether1)
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: PPPoE and dynamic queue for Internet traffic only

Mon Sep 12, 2011 1:01 am

You could go to a PCQ queue tree configuration, but that's not really necessary. If you tried overriding simple queues with queue trees as described in the link I posted and it didn't work then something wasn't implemented right. Post the configuration you tried, together with all the info requested in my signature.
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
marklodge
Member Candidate
Member Candidate
Posts: 211
Joined: Sun Jun 21, 2009 6:15 pm

Re: PPPoE and dynamic queue for Internet traffic only

Thu Sep 15, 2011 12:13 am

You could go to a PCQ queue tree configuration, but that's not really necessary. If you tried overriding simple queues with queue trees as described in the link I posted and it didn't work then something wasn't implemented right. Post the configuration you tried, together with all the info requested in my signature.
Thanks for being so helpful!
OK for the past 2 days now i've tried this config, over and over, but it just does not seem to override the simple dynamic per-user queues.

Heres the config that i have implemented:

/ip firewall mangle
add chain=prerouting in-interface=ether2 \
  dst-address=10.0.0.0/24 action=mark-packet \
  new-packet-mark=exempt-up
add chain=postrouting out-interface=ether2 \
  src-address=10.0.0.0/24 action=mark-packet \
  new-packet-mark=exempt-down


/queue type
add name=exempt type=sfq


/queue tree
add name=hotspot-exempt-up parent=global-in \
  packet-mark=exempt-up queue=exempt max-limit=1000M
add name=hotspot-exempt-down parent=global-out \
  packet-mark=exempt-down queue=exempt max-limit=1000M

And here are the details requested in your signiture.
Note that i have some DSCP based QoS setup (from here: http://wiki.mikrotik.com/wiki/DSCP_based_QoS_with_HTB ) but i have disabled all of it in case it interferes with the queue overriding.


[admin@RB433] > /ip address print detail
Flags: X - disabled, I - invalid, D - dynamic 
 0   address=10.0.0.48/24 network=10.0.0.0 broadcast=10.0.0.255 
     interface=ether1 actual-interface=ether1 

 1   address=192.168.2.1/32 network=192.168.2.1 broadcast=192.168.2.1 
     interface=Night actual-interface=Night 

 2   address=192.168.3.1/32 network=192.168.3.1 broadcast=192.168.3.1 
     interface=Day actual-interface=Day 

 3 X address=192.168.1.8/24 network=192.168.1.0 broadcast=192.168.1.255 
     interface=ether3 actual-interface=ether3 

 4 D address=192.168.20.1/32 network=192.168.20.252 broadcast=0.0.0.0 
     interface=<pppoe-ashraf@ztel> actual-interface=<pppoe-ashraf@ztel> 

 5 D address=192.168.20.1/32 network=192.168.20.250 broadcast=0.0.0.0 
     interface=<pppoe-ihsaan@ztel> actual-interface=<pppoe-ihsaan@ztel> 

 6 D address=192.168.20.1/32 network=192.168.20.253 broadcast=0.0.0.0 
     interface=<pppoe-hassan@ztel> actual-interface=<pppoe-hassan@ztel> 

 7 D address=192.168.20.1/32 network=192.168.20.249 broadcast=0.0.0.0 
     interface=<pppoe-baydesign@ztel> actual-interface=<pppoe-baydesign@ztel> 

 8 D address=192.168.20.1/32 network=192.168.20.248 broadcast=0.0.0.0 
     interface=<pppoe-zak@hispeed> actual-interface=<pppoe-zak@hispeed> 

 9 D address=192.168.20.1/32 network=192.168.20.251 broadcast=0.0.0.0 
     interface=<pppoe-adam> actual-interface=<pppoe-adam> 

10 D address=192.168.20.1/32 network=192.168.20.254 broadcast=0.0.0.0 
     interface=<pppoe-owais1> actual-interface=<pppoe-owais1> 

[admin@RB433] > /ip route print detail
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 0 A S  dst-address=0.0.0.0/0 gateway=10.0.0.2 
        gateway-status=10.0.0.2 reachable ether1 distance=1 scope=30 
        target-scope=10 

 1 ADC  dst-address=10.0.0.0/24 pref-src=10.0.0.48 gateway=ether1 
        gateway-status=ether1 reachable distance=0 scope=10 

 2 ADC  dst-address=192.168.2.1/32 pref-src=192.168.2.1 gateway=Night 
        gateway-status=Night reachable distance=0 scope=10 

 3 ADC  dst-address=192.168.3.1/32 pref-src=192.168.3.1 gateway=Day 
        gateway-status=Day reachable distance=0 scope=10 

 4 ADC  dst-address=192.168.20.248/32 pref-src=192.168.20.1 
        gateway=<pppoe-zak@hispeed> 
        gateway-status=<pppoe-zak@hispeed> reachable distance=0 scope=10 

 5 ADC  dst-address=192.168.20.249/32 pref-src=192.168.20.1 
        gateway=<pppoe-baydesign@ztel> 
        gateway-status=<pppoe-baydesign@ztel> reachable distance=0 scope=10 

 6 ADC  dst-address=192.168.20.250/32 pref-src=192.168.20.1 
        gateway=<pppoe-ihsaan@ztel> 
        gateway-status=<pppoe-ihsaan@ztel> reachable distance=0 scope=10 

 7 ADC  dst-address=192.168.20.251/32 pref-src=192.168.20.1 
        gateway=<pppoe-adam> gateway-status=<pppoe-adam> reachable distance=0 
        scope=10 

 8 ADC  dst-address=192.168.20.252/32 pref-src=192.168.20.1 
        gateway=<pppoe-ashraf@ztel> 
        gateway-status=<pppoe-ashraf@ztel> reachable distance=0 scope=10 

 9 ADC  dst-address=192.168.20.253/32 pref-src=192.168.20.1 
        gateway=<pppoe-hassan@ztel> 
        gateway-status=<pppoe-hassan@ztel> reachable distance=0 scope=10 

10 ADC  dst-address=192.168.20.254/32 pref-src=192.168.20.1 
        gateway=<pppoe-owais1> gateway-status=<pppoe-owais1> reachable 
        distance=0 scope=10 

[admin@RB433] > /ip firewall export
# sep/14/2011 23:01:38 by RouterOS 4.5
# software id = 6S61-VQPK
#
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d \
    tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
    tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall mangle
add action=mark-packet chain=prerouting comment="" disabled=no dst-address=\
    10.0.0.0/24 in-interface=ether2 new-packet-mark="exempt-up\r\
    \n" passthrough=yes
add action=mark-packet chain=postrouting comment="" disabled=no \
    new-packet-mark=exempt-down out-interface=ether1 passthrough=yes \
    src-address=10.0.0.0/24
add action=mark-packet chain=forward comment="" connection-mark=yyyy \
    disabled=yes dst-address=74.125.0.0-74.125.254.254 new-packet-mark=\
    youtube passthrough=no
add action=mark-connection chain=forward comment="" disabled=yes dst-address=\
    74.125.0.1-74.125.254.254 new-connection-mark=yyyy passthrough=yes
add action=mark-packet chain=postrouting comment=dscp_63 disabled=yes dscp=63 \
    new-packet-mark=dscp_63 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_62 disabled=yes dscp=62 \
    new-packet-mark=dscp_62 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_61 disabled=yes dscp=61 \
    new-packet-mark=dscp_61 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_60 disabled=yes dscp=60 \
    new-packet-mark=dscp_60 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_59 disabled=yes dscp=59 \
    new-packet-mark=dscp_59 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_58 disabled=yes dscp=58 \
    new-packet-mark=dscp_58 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_57 disabled=yes dscp=57 \
    new-packet-mark=dscp_57 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_56 disabled=yes dscp=56 \
    new-packet-mark=dscp_56 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_55 disabled=yes dscp=55 \
    new-packet-mark=dscp_55 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_54 disabled=yes dscp=54 \
    new-packet-mark=dscp_54 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_53 disabled=yes dscp=53 \
    new-packet-mark=dscp_53 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_52 disabled=yes dscp=52 \
    new-packet-mark=dscp_52 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_51 disabled=yes dscp=51 \
    new-packet-mark=dscp_51 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_50 disabled=yes dscp=50 \
    new-packet-mark=dscp_50 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_49 disabled=yes dscp=49 \
    new-packet-mark=dscp_49 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_48 disabled=yes dscp=48 \
    new-packet-mark=dscp_48 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_47 disabled=yes dscp=47 \
    new-packet-mark=dscp_47 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_46 disabled=yes dscp=46 \
    new-packet-mark=dscp_46 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_45 disabled=yes dscp=45 \
    new-packet-mark=dscp_45 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_44 disabled=yes dscp=44 \
    new-packet-mark=dscp_44 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_43 disabled=yes dscp=43 \
    new-packet-mark=dscp_43 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_42 disabled=yes dscp=42 \
    new-packet-mark=dscp_42 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_41 disabled=yes dscp=41 \
    new-packet-mark=dscp_41 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_40 disabled=yes dscp=40 \
    new-packet-mark=dscp_40 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_39 disabled=yes dscp=39 \
    new-packet-mark=dscp_39 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_38 disabled=yes dscp=38 \
    new-packet-mark=dscp_38 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_37 disabled=yes dscp=37 \
    new-packet-mark=dscp_37 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_36 disabled=yes dscp=36 \
    new-packet-mark=dscp_36 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_35 disabled=yes dscp=35 \
    new-packet-mark=dscp_35 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_34 disabled=yes dscp=34 \
    new-packet-mark=dscp_34 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_33 disabled=yes dscp=33 \
    new-packet-mark=dscp_33 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_32 disabled=yes dscp=32 \
    new-packet-mark=dscp_32 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_31 disabled=yes dscp=31 \
    new-packet-mark=dscp_31 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_30 disabled=yes dscp=30 \
    new-packet-mark=dscp_30 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_29 disabled=yes dscp=29 \
    new-packet-mark=dscp_29 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_28 disabled=yes dscp=28 \
    new-packet-mark=dscp_28 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_27 disabled=yes dscp=27 \
    new-packet-mark=dscp_27 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_26 disabled=yes dscp=26 \
    new-packet-mark=dscp_26 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_25 disabled=yes dscp=25 \
    new-packet-mark=dscp_25 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_24 disabled=yes dscp=24 \
    new-packet-mark=dscp_24 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_23 disabled=yes dscp=23 \
    new-packet-mark=dscp_23 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_22 disabled=yes dscp=22 \
    new-packet-mark=dscp_22 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_21 disabled=yes dscp=21 \
    new-packet-mark=dscp_21 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_20 disabled=yes dscp=20 \
    new-packet-mark=dscp_20 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_19 disabled=yes dscp=19 \
    new-packet-mark=dscp_19 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_18 disabled=yes dscp=18 \
    new-packet-mark=dscp_18 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_17 disabled=yes dscp=17 \
    new-packet-mark=dscp_17 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_16 disabled=yes dscp=16 \
    new-packet-mark=dscp_16 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_15 disabled=yes dscp=15 \
    new-packet-mark=dscp_15 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_14 disabled=yes dscp=14 \
    new-packet-mark=dscp_14 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_13 disabled=yes dscp=13 \
    new-packet-mark=dscp_13 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_12 disabled=yes dscp=12 \
    new-packet-mark=dscp_12 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_11 disabled=yes dscp=11 \
    new-packet-mark=dscp_11 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_10 disabled=yes dscp=10 \
    new-packet-mark=dscp_10 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_9 disabled=yes dscp=9 \
    new-packet-mark=dscp_9 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_4 disabled=yes dscp=4 \
    new-packet-mark=dscp_4 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_8 disabled=yes dscp=8 \
    new-packet-mark=dscp_8 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_7 disabled=yes dscp=7 \
    new-packet-mark=dscp_7 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_6 disabled=yes dscp=6 \
    new-packet-mark=dscp_6 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_5 disabled=yes dscp=5 \
    new-packet-mark=dscp_5 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_3 disabled=yes dscp=3 \
    new-packet-mark=dscp_3 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_2 disabled=yes dscp=2 \
    new-packet-mark=dscp_2 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_1 disabled=yes dscp=1 \
    new-packet-mark=dscp_1 passthrough=no
add action=mark-packet chain=postrouting comment=dscp_0 disabled=yes dscp=0 \
    new-packet-mark=dscp_0 passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    ether1
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no
[admin@RB433] > 

Network Diagram:

see pic attached.
basically it is just a UBNT Rocket connected to ether2. PPPOE service running on ether2 authenticates and sends authenticated clients over to the gateway on ether1
You do not have the required permissions to view the files attached to this post.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: PPPoE and dynamic queue for Internet traffic only

Thu Sep 15, 2011 12:35 am

I think the issue is with copy/paste borking up your packet mark names.

Check out the packet marks you're applying:
/ip firewall mangle
add action=mark-packet chain=prerouting comment="" disabled=no dst-address=\
    10.0.0.0/24 in-interface=ether2 new-packet-mark="exempt-up\r\
    \n" passthrough=yes
add action=mark-packet chain=postrouting comment="" disabled=no \
    new-packet-mark=exempt-down out-interface=ether1 passthrough=yes \
    src-address=10.0.0.0/24
That is taken straight from your "/ip firewall export" output. I'll copy out the important part to highlight it:
new-packet-mark="exempt-up\r\
    \n"
It doesn't just say 'exempt-up', it snuck in "\r\n", which usually happens when you're copying/pasting files or clipboard content between operating systems.

I don't have proper export output from your queue tree, but check that the packet mark the queue trees check for matches literally and letter for letter what you're marking with. If you're unsure use the GUI or CLI to replace the new-packet-mark parameter in the mangle rules, and and then replace it with the exact same strings in the queue tree items. Maybe just type them out for both instances, and pick something easy to type and see if you got it wrong, like "up" and "down". It's irrelevant what the names actually are, they just have to match. Then test again.
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
marklodge
Member Candidate
Member Candidate
Posts: 211
Joined: Sun Jun 21, 2009 6:15 pm

Re: PPPoE and dynamic queue for Internet traffic only

Thu Sep 15, 2011 4:38 pm

Thanks for the help fewi!
I did as you said, matched the queue and mangle names, but although i could see traffic flowing over the mangle rules to the queues it did not override the limit.
But then i blanked out the in and out interface from the Queue Tree exempt rule and then it worked!
Now i need to know a few things
1. Do i have to set the in and out interface to something like ether1 or ether2? Or will it work fine without any interface specified?
This is how it looks:
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1G name=exempt-down packet-mark=down parent=global-out \
    priority=1 queue=exempt
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1G name=exempt-up packet-mark=up parent=global-in priority=8 \
    queue=exempt
2. i see continous traffic flowing over the exempt-up queue, even if i am not downloading from the local server, is that normal? (i am continously downloading from the internet though)

3. i re enabled the QoS that i had set, but then the overrides did not work, so i disabled them and enabled them 1 at a time until i found that the following queue is not permiting the exempt rules to work:
add action=mark-packet chain=postrouting comment=dscp_0 disabled=yes dscp=0 \
    new-packet-mark=dscp_0 passthrough=no
Should i just leave that rule out?
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: PPPoE and dynamic queue for Internet traffic only

Thu Sep 15, 2011 5:05 pm

1. Do i have to set the in and out interface to something like ether1 or ether2? Or will it work fine without any interface specified?
I don't understand. Queue trees don't have in- or out-interface properties.
2. i see continous traffic flowing over the exempt-up queue, even if i am not downloading from the local server, is that normal? (i am continously downloading from the internet though)
Is there other traffic to the network exempted by your mangle rules? DNS? Anything? Do you maybe have stray NAT rules that rewrite things to IPs on that network further upstream?
3. i re enabled the QoS that i had set, but then the overrides did not work, so i disabled them and enabled them 1 at a time until i found that the following queue is not permiting the exempt rules to work:
I don't understand the purpose of those DSCP rules at all, to be honest. Why are you marking them with packet marks?
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
marklodge
Member Candidate
Member Candidate
Posts: 211
Joined: Sun Jun 21, 2009 6:15 pm

Re: PPPoE and dynamic queue for Internet traffic only

Thu Sep 15, 2011 11:43 pm

ok thanks for the answers, the reason i did what i did was firstly i just followed the tutorial step by step and it called for the following:
/ip firewall mangle
add chain=prerouting in-interface=LAN \
  dst-address=10.0.0.0/24 action=mark-packet \
  new-packet-mark=exempt-up
add chain=postrouting out-interface=LAN \
  src-address=10.0.0.0/24 action=mark-packet \
  new-packet-mark=exempt-down
so to be honest, i thought LAN meant the local network that traffic is flowing in and out of.
Is there other traffic to the network exempted by your mangle rules? DNS? Anything? Do you maybe have stray NAT rules that rewrite things to IPs on that network further upstream?
no, i disabled all the other mangle and queue rules. But should this be something to be concerned about?

and the reason why i am marking the packets is because i am following this quide:
http://wiki.mikrotik.com/wiki/DSCP_based_QoS_with_HTB

Who is online

Users browsing this forum: Google [Bot], nemoforum, ttdd85 and 110 guests