Community discussions

MUM Europe 2020
 
haakon
just joined
Topic Author
Posts: 19
Joined: Sat May 02, 2009 6:02 pm

Problem with OpenVPN and ip address assignment

Fri Oct 16, 2009 5:16 pm

Hi,

I'm setting up OpenVPN server on one ROS, and OpenVPN client on another ROS.

On the server, the netmask is set to 30, so that should be nework, two ip's and broadcast.

In the PPP Secret, on the user I specify local address 10.47.0.5, and remote 10.47.0.6.

The connection is successfully set up. And on the client, it has received 10.47.0.6/30 with correct network and broadcast.
But the server sets up it's ip as: 10.47.0.5 network 10.47.0.6, no broadccast.

Why does it do that? It should have been 10.47.0.5/30 with correct network and broadcast?
Or am I missing something essential here?

Håkon

Server configuration:
/interface ovpn-server
  add comment="" disabled=no name=Brobekkveien user=brobekkveien
/interface ovpn-server server
  set auth=sha1,md5 certificate=Nydalen-ServerCert cipher=\
    blowfish128,aes128,aes256 default-profile=default-encryption enabled=yes \
    keepalive-timeout=60 mac-address=FE:F1:02:EC:4F:CF max-mtu=1500 mode=\
    ethernet netmask=30 port=1194 require-client-certificate=yes
/ppp secret
  add caller-id="" comment="" disabled=no limit-bytes-in=0 limit-bytes-out=0 \
    local-address=10.47.0.5 name=brobekkveien password=pwdhere profile=\
    default-encryption remote-address=10.47.0.6 routes="" service=ovpn
Client configuration:
/interface ovpn-client
  add add-default-route=no auth=sha1 certificate="Brobekkveien OVPN" cipher=\
    aes256 comment="" connect-to=192.168.88.4 disabled=yes mac-address=\
    00:00:00:00:00:00 max-mtu=1500 mode=ethernet name=ovpn-out1 password=\
    pwdhere port=1194 profile=default-encryption user=brobekkveien
--
Håkon Nessjøen
<haakon.nessjoen[a]gmail.com>
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8326
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Problem with OpenVPN and ip address assignment

Sat Oct 17, 2009 12:17 am

tunnel is point-to-point link, it always have /32 mask
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.

Who is online

Users browsing this forum: Bing [Bot], Filament, Google [Bot], mbovenka, mrtrca and 86 guests