Page 1 of 1

Sierra MC8775 on RouterOS > v3.25 (RB411U)

Posted: Mon Nov 30, 2009 12:16 am
by Dax
I have configured a few MC8775s on RouterOS v3.25 and those systems work OK (RB411U boards).

Recently I tried doing the same on RB411Us with RouterOS 4.2, then 4.3 then working backwards to 3.30. I can't get the MC8775s to work!

I see two main differences. In the newer releases the General settings have a place for L2 MTU and the "Command Channel" has disappeared leaving only "Data Channel" and "Info Channel".

The ppp session gets as far as "authenticated" but the IP level connection never comes up.

Does anybody have an MC8775 running on RouterOS > 3.25?

Re: Sierra MC8775 on RouterOS > v3.25 (RB411U)

Posted: Tue Dec 08, 2009 4:08 pm
by sergejs
MikroTik RouterOS 4.3 version should be fine for the card.
If you have any problem with the card, send support or better give us access to the router, where card is plugged in and does not work properly (
Thank you very much.

Re: Sierra MC8775 on RouterOS > v3.25 (RB411U)

Posted: Thu Dec 20, 2012 6:10 pm
by el berto
Hi, I'm a bit offtopic, but I wouldn't open another thread....

I had problems with MC8775 on RB411U (rOS ver. 5.21): modem wouldn't be able to communicate to routerboard; thinking it could be a RouterOS problem I updated it to 5.21.

Here similar log:
Feb/02/2012 11:07:52 async,debug usb2:4: sent +++
Feb/02/2012 11:07:54 async,debug usb2:4: sent ATH
Feb/02/2012 11:07:56 async,debug usb2:4: sent +++
Feb/02/2012 11:07:59 async,debug usb2:4: sent ATH
Feb/02/2012 11:08:01 async,debug usb2:4: sent +++
Feb/02/2012 11:08:03 async,debug usb2:4: sent ATH
Feb/02/2012 11:08:05 async,debug usb2:4: sent +++
Feb/02/2012 11:08:07 async,debug usb2:4: sent ATH

Now I've bought another MC8775.

I've let the same ppp-client configuration (using another 3G card it was working correctly), in this case the MC8775 was continously reseting and I have this log:
- sent ATDT*99***1#
- rcvd ERROR
- resetting modem 
I've tried changing ATD dial command instead ATDT, but same result.
I also changed Data Channel number: nothing changed.
So I left original parameters of last working 3G card: ATDT dial command, Data Channel and Info Channel on channel 0.

After a couple of hours, I've noticed the card was connected.
What could be wrong?
I'm very worried about stability of RB411U+MC8775..........

Re: Sierra MC8775 on RouterOS > v3.25 (RB411U)

Posted: Thu Dec 27, 2012 1:21 pm
by uldis
compare the firmware files for both cards.
check maybe one of the card is recognized as a LTE card and not the configuration should be done under interface lte section.

Re: Sierra MC8775 on RouterOS > v3.25 (RB411U)

Posted: Fri Dec 28, 2012 10:50 am
by el berto
Firmware on 3G card was the same.
Could it be problems with PIN?
I rebooted router (PPP was working correctly) and same trouble appears again: modem was always reseting.
I started async logging and I saw same log.
Looking in PPP-client info button, PIN status was something like "waiting for primary PIN".
But PIN was correctly set in PPP-client fields.
Then I disabled PIN through GSM phone.
Now it seems to work correctly.....

Maybe some bug?
I filled the PIN field with "1234" form instead the 1234 form. Maybe this?