Community discussions

MUM Europe 2020
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24323
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

RouterOS 4.4 released

Mon Dec 21, 2009 11:36 am

What's new in 4.4:

*) snmp - fixed snmp version three;
*) snmp - fixed vlan interface speed;
*) hotspot - fixed radius variables in hotspot html pages;
*) removed support for xen;
*) routing - added support for BFD protocol;
*) fixed problem - MetaROUTER sometimes froze on RB4xx;
*) fixed OSPFv3 on bridge interfac
and some other minor fixes.

http://www.mikrotik.com/download/router ... .4.torrent
No answer to your question? How to write posts
 
gbh
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Mon Dec 08, 2008 1:05 am

Re: RouterOS 4.4 released

Mon Dec 21, 2009 11:40 am

OK, I can't be a guinea pig this time.
Can some 433uah users post back here once they have upgraded..

8+)
 
User avatar
Eising
Member Candidate
Member Candidate
Posts: 272
Joined: Mon Oct 27, 2008 10:21 am
Location: Copenhagen, Denmark

Re: RouterOS 4.4 released

Mon Dec 21, 2009 12:06 pm

Do you have any documentation available regarding BFD?
Is your BFD implementation compatible with e.g. Cisco's?
The road to hell is paved with good intentions.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24323
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 4.4 released

Mon Dec 21, 2009 12:07 pm

No answer to your question? How to write posts
 
User avatar
asus
Member
Member
Posts: 403
Joined: Fri Mar 27, 2009 9:42 am
Location: Mumbai, India

Re: RouterOS 4.4 released

Mon Dec 21, 2009 1:51 pm

can you mail me TEST UM for 4.4OS Please??

Thanks
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: RouterOS 4.4 released

Mon Dec 21, 2009 3:17 pm

please send us a link to download test UM thanks for the support
If i dont No Ask someone That Does!
 
User avatar
asus
Member
Member
Posts: 403
Joined: Fri Mar 27, 2009 9:42 am
Location: Mumbai, India

Re: RouterOS 4.4 released

Mon Dec 21, 2009 3:20 pm

LoL may be they will respond you :lol:
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: RouterOS 4.4 released

Mon Dec 21, 2009 3:23 pm

normis posted this

user manager beta-test package is not yet released
If i dont No Ask someone That Does!
 
User avatar
asus
Member
Member
Posts: 403
Joined: Fri Mar 27, 2009 9:42 am
Location: Mumbai, India

Re: RouterOS 4.4 released

Mon Dec 21, 2009 3:30 pm

But without it we cannot upgrade our router to 4.4, I think they had fix all bugs & released it as a stable version in 4.4 download package.

:lol:
 
bdronka
just joined
Posts: 4
Joined: Mon Nov 30, 2009 12:37 pm
Location: Poland

Re: RouterOS 4.4 released

Mon Dec 21, 2009 4:57 pm

In 4.3 and 4.4 (!!!) Nstream work very unstable.
Link are lose connect when I did bandwidthtest every 60-70 seconds, when I choose 5GHz-turbo - every 20-30 seconds
Under 3.30 every works fine......but not 4.4......
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: RouterOS 4.4 released

Mon Dec 21, 2009 5:07 pm

maybe the UM will come out later
and it might be stable then
If i dont No Ask someone That Does!
 
od3m
just joined
Posts: 14
Joined: Sun Nov 15, 2009 11:11 am

Re: RouterOS 4.4 released

Mon Dec 21, 2009 5:31 pm

Hi all !

since upgrading from 4.3 to 4.4 my System Health seems wrong.
Just take a look ath the picture.

Image

itßs definatly not so hot, but not showing the right temperature anymore
 
flayzer
just joined
Posts: 5
Joined: Mon Dec 14, 2009 1:21 pm

Re: RouterOS 4.4 released

Mon Dec 21, 2009 6:25 pm

Has anyone noticed in 4.3 and 4.4 that if you run a scan using a r52n the signal strength is 8-10db better than the registration

yet in 4.2 and below if i run a scan and it states -60 it will register at -60

but in 4.3 and 4.4 if i scan at -60 it registers at -68 to -70.

however if you use an r52 in all versions the scan and registration are the same.

This problem also happens when using sr7 cards.

i have upgraded from 4.2-4.3-4.4 and back again serveral times via ethernet ,reseting config each time and the results are always the same.
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RouterOS 4.4 released

Tue Dec 22, 2009 1:57 am

It seems that since we've updated from 4.3 to 4.4 on a RB750G, we have lost Mac autodetection feature from Winbox.

But if we enter manually the MAC adress, we can connect.
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RouterOS 4.4 released

Tue Dec 22, 2009 2:45 am

Sorry, MAC discovery is working with 4.4. We've added a rule for MNDP and that's ok. I thought MNDP was level 2.
 
gbh
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Mon Dec 08, 2008 1:05 am

Re: RouterOS 4.4 released

Tue Dec 22, 2009 9:16 am

OK, I took the plunge.
Can confirm 4.4 is working nicely on a 433uah, 5 hours or so, no issues.

Also upgraded on an x86 platform and 3 x 450's.
All good at the moment.
Many thanks.
 
dingsingo
Member Candidate
Member Candidate
Posts: 100
Joined: Sun Jul 24, 2005 9:47 pm
Location: Germany

Re: RouterOS 4.4 released

Tue Dec 22, 2009 10:59 am

Hi,

we have update 6 RB/600 with MPLS/VPLS an OSPF. System works fine...


dingsingo
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24323
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 4.4 released

Tue Dec 22, 2009 3:27 pm

Do you have any documentation available regarding BFD?
Is your BFD implementation compatible with e.g. Cisco's?
yes, it has been tested with Cisco, but since this is just first preliminary release there are some limitations:

1) echo mode is not supported, so be sure to disable that on Cisco with "no bfd echo";
2) very small (e.g. millisecond timers) also are not supported at the moment
3) you are welcome to report any interoperability bugs you can find :)"
No answer to your question? How to write posts
 
User avatar
infowest
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Thu Jun 07, 2007 12:46 am

Re: RouterOS 4.4 released

Tue Dec 22, 2009 6:18 pm

Were there any wireless changes in 4.4? I have some test links with r52n's I can try.
 
jarapa
just joined
Posts: 8
Joined: Mon Feb 02, 2009 11:34 pm

Re: RouterOS 4.4 released

Wed Dec 23, 2009 12:38 am

I found one bug in V4.4. I have script for sending me emails with backup file. It stops working - in log I have this: "Error sending email: error handling file".

After downgrade it works fine. This script works in all versions - 3.x and 4.x except 4.4.

The script:
:local mserver
:local mkomu
:local msubject
:local bjmeno

:set mkomu "xxx@email.com"

:set msubject ("Backup " . [/system identity get name])
:set bjmeno ([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup" )

/system backup save name=$bjmeno

:delay 30

:put ($mserver."\n")

/tool e-mail send subject=$msubject file=$bjmeno to=$mkomu body=("Backup from " . [/system clock get date] . " mikrotik " . [/system identity get name] . ".")
:put ("Backup " . $bjmeno . "\n")

:delay 30

/file remove [/file find name=$bjmeno]
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RouterOS 4.4 released

Wed Dec 23, 2009 10:31 am

tried your script on 4.4 and received e-mail with backup file in it.

check your settings under /tool e-mail
 
User avatar
butche
Trainer
Trainer
Posts: 428
Joined: Fri May 28, 2004 6:14 pm
Location: Missouri, USA
Contact:

Re: RouterOS 4.4 released

Wed Dec 23, 2009 8:33 pm

Also may want to check system identity. Based on the script, using the system identity can sometimes cause problems if the name contains certain characters. Also, make sure your script permissions are adequate.
--
Butch Evans
Mikrotik Certified Trainer
Mikrotik Certified Consultant
BLOG: blog.butchevans.com
http://store.wispgear.net/
 
BobcatGuy
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: RouterOS 4.4 released

Thu Dec 24, 2009 2:02 pm

I found two Issues with Upgrade to 4.4, actually this might be board specific since I have seen this issue before.

Copy 4.4 Complete package file over to router via winbox, reboot. Does its thing, comes back online, router APPEARS to be working, well It is Everything on LAN side is accessible, and the three ports I have on a WAN side for VOIP and cable connection, ( eg ehters 2, 3 and 4 are on a bridge of their own) the VoIP phones work.

The problem is that there is NO NAT translation, and no internet accessibility from the LAN side, a Reboot does not fix the issue. Restoring the backup I just created before the upgrade will fix the issue after it restores and reboots.

This is where I found the second "bug" If you DOUBLE click on your backup file, a new window pops up, shwoing file name, TYPE Backup, Size 398.9KiB, Creation Date: Dec 24 2009.... If you click on restore in this new window you get: Do you want to restore config and reboot, you click YES, then you get Winbox error " Couldn't Restore configuration - no filename (5) "

BUT if you click your backup file ONE time in the file list, and restore at the top of the file list window, it will restore and reboot and work.

Not a big issue but caught my attention.

The real question I have is Why does my 493AH always have NAT issues after an upgrade, and on occasion at random times about every month or 1.5 months it will just stop NATTING, without being reboot, or without an upgrade. I have noticed though that on all the recent upgrades, 4.X it happens every time.
 
rmichael
Forum Veteran
Forum Veteran
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: RouterOS 4.4 released

Fri Dec 25, 2009 1:21 am


This is where I found the second "bug" If you DOUBLE click on your backup file, a new window pops up, shwoing file name, TYPE Backup, Size 398.9KiB, Creation Date: Dec 24 2009.... If you click on restore in this new window you get: Do you want to restore config and reboot, you click YES, then you get Winbox error " Couldn't Restore configuration - no filename (5) "
Happens under ROS 4.2 as well.
 
paranoid
just joined
Posts: 7
Joined: Fri Dec 25, 2009 8:59 pm
Contact:

Re: RouterOS 4.4 released

Fri Dec 25, 2009 9:20 pm

Hi

I've tested RouterOS 4.4 with an MPLS VPLS setup

I've found out that when you've got vlan interfaces tagging to bridge
the IP-Address is not set up correctly on boot up (not pingable ...)
I've simply disabled an reenabled the ip address config
then it's working till next reboot....

With RouterOS 4.3 there is no problem like this

I think this is an bug....
 
jarapa
just joined
Posts: 8
Joined: Mon Feb 02, 2009 11:34 pm

Re: RouterOS 4.4 released

Tue Dec 29, 2009 12:36 am

tried your script on 4.4 and received e-mail with backup file in it.

check your settings under /tool e-mail
Problem is not in email, problem is in $bjmeno . Backup of the system is OK. Then email tool and "deleting" does not recognize the file. If I print this variable it looks the same as the name of the file. In version 3.x it is working.

Another script - which is working. I DO NOT understand this....
:local mserver
:local mkomu
:local msubject
:local bjmeno

:set mkomu "xxxxx@email.com"

:set msubject ("Export" . [/system identity get name])
:set bjmeno ([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc" )


/export file=($bjmeno)
#/system backup save name=$bjmeno

:delay 30

:put ($mserver."\n")

/tool e-mail send subject=$msubject file=$bjmeno to=$mkomu body=("Backup " . [/system clock get date] . " mikrotiku " . [/system identity get name] . ".")
:put ("Backup udelan do souboru " . $bjmeno . "\n")

:delay 30

/file remove [/file find name=$bjmeno]
 
danielvc
just joined
Posts: 3
Joined: Tue Dec 29, 2009 9:24 pm

Re: RouterOS 4.4 released

Tue Dec 29, 2009 9:44 pm

My backup/email script just works for 4.4 after marking sensitive policy. It was ok for 4.3 without sensitive option.
 
druger
just joined
Posts: 18
Joined: Mon Mar 03, 2008 3:00 pm

Re: RouterOS 4.4 released

Wed Dec 30, 2009 12:31 pm

What's new in 4.4:

*) snmp - fixed snmp version three;
*) snmp - fixed vlan interface speed;
*) hotspot - fixed radius variables in hotspot html pages;
*) removed support for xen;
*) routing - added support for BFD protocol;
*) fixed problem - MetaROUTER sometimes froze on RB4xx;
*) fixed OSPFv3 on bridge interfac
and some other minor fixes.

http://www.mikrotik.com/download/router ... .4.torrent
hello

i have a problem when upgrading my routers to 4.4 which is after upgrading to 4.4 all interfaces names return to default .

my routers are RB 493 v 3.20 .

i have about 40 routers waiting to upgrade . i need to know if there is any fix to this problem and if there are another problems
 
jarapa
just joined
Posts: 8
Joined: Mon Feb 02, 2009 11:34 pm

Re: RouterOS 4.4 released

Wed Dec 30, 2009 1:29 pm

My backup/email script just works for 4.4 after marking sensitive policy. It was ok for 4.3 without sensitive option.
Thanx for hint. It was in these options. Now I hope it is working. The curious is - only the first script is sensitive to sensitive option, the second one for export RSC is working anyway.

So for the others - there is change in script policy in v4.4. :?
 
obolyz
just joined
Posts: 2
Joined: Sat Oct 31, 2009 10:37 am

Re: RouterOS 4.4 released

Sat Jan 02, 2010 7:05 pm

System health shows strange temperature: on v4.2 temp was 36C, after upgrade to v4.4 - 78C.
RB450G
 
od3m
just joined
Posts: 14
Joined: Sun Nov 15, 2009 11:11 am

Re: RouterOS 4.4 released

Sat Jan 02, 2010 8:25 pm

Hi all !

since upgrading from 4.3 to 4.4 my System Health seems wrong.
Just take a look ath the picture.

Image

itßs definatly not so hot, but not showing the right temperature anymore
like mine...
 
hengst
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Sun Jan 03, 2010 3:04 pm

Re: RouterOS 4.4 released

Sun Jan 03, 2010 3:52 pm

build a bridge with 2x 23db dualpol panel , distance 13Km.
both sides RB411AH with R52n and MPLS/LDP as per Wiki.

A--ether->wlan1.......MPLS/LDPtunnel...........wlan1<-ether--B

( layer2 bridging , RSTP/STP off )

with bandwitdhtest from RB411 to other side RB411,
on ROS4.4 single 5Ghz mode, 10 minutes continu test (10Mbps both send/receive) ok. ( ping little higher, but no problem )

same test, but in 5Ghz-N mode wil start as should, but throughput drops within short time till almost 0.

tried all kinds of settings but only 5Ghz will give me stable link.

My idea looks like something to do with input/output channel/chain getting confused when load increases on the radio.
also what happens in software/hardware when horizontal/vertical is mixed up between both side ?
for example, on first Dual pol antenna i connected "horizontal" to "ant-a/MAIN" and "vertical" to "ant-b/AUX" on the R52n.
but did i on the other antenna the same ? and if not, what would happen ?.

This setup is one of our backup links and if Mikrotik staff would like to play with it for testing we are happy to contribute.
Last edited by hengst on Mon Jan 04, 2010 8:14 pm, edited 1 time in total.
 
jarapa
just joined
Posts: 8
Joined: Mon Feb 02, 2009 11:34 pm

Re: RouterOS 4.4 released

Sun Jan 03, 2010 10:56 pm

System health shows strange temperature: on v4.2 temp was 36C, after upgrade to v4.4 - 78C.
RB450G
I have more... 110C (RB450G)
 
rainmaker
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Fri Jan 30, 2009 9:32 pm

Re: RouterOS 4.4 released

Mon Jan 04, 2010 10:34 pm

Dear Friends

All is well with 4.4 hotspot but the anyip is not working in 4.4 version.
 
aldis
just joined
Posts: 7
Joined: Mon Jan 04, 2010 10:33 pm

Re: RouterOS 4.4 released

Mon Jan 04, 2010 10:51 pm

System health shows strange temperature: on v4.2 temp was 36C, after upgrade to v4.4 - 78C.
RB450G
I have more... 110C (RB450G)
Same here: 110C (RB450G)
 
Myron
Member Candidate
Member Candidate
Posts: 253
Joined: Sat Sep 05, 2009 3:17 am
Location: Boracay, Philippines

Re: RouterOS 4.4 released

Tue Jan 05, 2010 6:33 am

mine in rb450g 4.4ROS:

Voltage: 22.1 V
88 C

is this normal????
 
Myron
Member Candidate
Member Candidate
Posts: 253
Joined: Sat Sep 05, 2009 3:17 am
Location: Boracay, Philippines

Re: RouterOS 4.4 released

Tue Jan 05, 2010 2:09 pm

mine in rb450g 4.4ROS:

Voltage: 22.1 V
88 C

is this normal????
i downgrade to 4.2 now the health is :

Volatge: 22.1
41 C

:shock: :shock: :shock:
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24323
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 4.4 released

Tue Jan 05, 2010 2:11 pm

v4.5 fixes the temperature issues in RB
No answer to your question? How to write posts
 
guille4
Frequent Visitor
Frequent Visitor
Posts: 93
Joined: Tue Sep 29, 2009 9:23 pm

Re: RouterOS 4.4 released

Wed Jan 06, 2010 3:50 am

I have several rb450g acting as firewall, others as bw management, others as routers.

All of them never has major issues until today... one day after install 4.4 :?

The issues has found in 3 rb acting as firewalls (over 8 total in production). The customers call us and said the service has become too unstable and slow, the ping are ok, but the navigation was bad (web pages never load). After our proofs, the solution was disabled all firewall filters rules, and then enabling again. :shock:

Really it seems a problem of the 4.4 version. For a while I setup a reboot scheduled script at 3 am every day in all the rb450g acting as firewall, to "clean" mistakes (or wathever else) and starting it again with a fresh start. I'm waiting for a new version to leave the 4.4

Any ideas?
 
roadracer96
Forum Veteran
Forum Veteran
Posts: 714
Joined: Tue Aug 25, 2009 12:01 am

Re: RouterOS 4.4 released

Wed Jan 06, 2010 7:40 am

4.1 seems to be the best for 450Gs/433s.. Have about 50 of em out in the field and they work like champs. Havent tried 4.4 on a 450 in production yet.
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

Re: RouterOS 4.4 released

Fri Jan 08, 2010 4:38 am

Upgraded 10 radios RB133 w/o issues, number 11 wireless connection erratic, it registers to the AP for a second or two then disconnects, downgrade to 3.28 working fine, upgrade it again to be sure same results, why? No idea, same RB133, same Wireless card as all previous 10 but this one not working. Any clue?

Also upgraded one RB532 with SR5, had issues: Connectivity from the ethernet port erratic two or three seconds connecteed, two or three seconds disconnected, turn the wireless card OFF then ethernet connectivity back to normal... downgrade it to 3.28 everything worked fine, upgraded again to version 4.1 , 4.2 , 4.3 and 4.4 all presented the same issues... Any ideas?

Greetings

Who is online

Users browsing this forum: No registered users and 73 guests