Community discussions

MikroTik App
 
pavelh
just joined
Topic Author
Posts: 18
Joined: Mon Jan 04, 2010 12:17 pm
Location: Varnsdorf, Czech Republic

RB 450G, IPv6 - problem & partial solution

Fri Jan 08, 2010 10:23 am

Problem description:

I have RB 450G with both IPv4 and IPv6 setup, ROS version 3.30. Two interfaces are directly connected to computers, which are most of the time off, thus interface is inactive. After starting such computer interface becomes running, IPv4 works great, but computer does not get IPv6 Router Advertisement and therefore does not setup its IPv6 connectivity. Every interface has its own subnet.

When I reboot RB 450G, everything starts to work as expected (IPv6 works), until switching the computer off - then IPv6 breaks again. Tried with Windows XP and Ubuntu 9.10, didn't try to listen to interface using Wireshark.

Partial solution:

Problem has been partially circumvented by setting up bridge, configuring IPv6 and IPv4 on bridge and attaching those interfaces to bridge - this works.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RB 450G, IPv6 - problem & partial solution

Fri Jan 08, 2010 11:50 am

can you try 4.4? To see if problem still exist in that version?
 
pavelh
just joined
Topic Author
Posts: 18
Joined: Mon Jan 04, 2010 12:17 pm
Location: Varnsdorf, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sat Jan 09, 2010 11:52 pm

Under 4.4 it is the same. In addition under 4.4 wrong temperature in System/Health (I know, many people already reported).
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution - BUG REPORT !!!

Fri Feb 05, 2010 1:07 am

I have a same problem at RB433AH running RouterOS 4.5 . Simply router doesn't send Router Advertisment ICMPv6 message. I have a 6to4 tunnel to HurricaneElectric Broker. When I reboot the router while PCs are running, everthing is ok. After the routers boot PCs get Advertisment message and set IPv6 address correctly. But when I reboot PCs, they never get Advertisment from router again.

I have spent lot of hours running Wireshark and logging IPv6 trafic. The Advertisment message from Mikrotik never arrived again, only after the routers reboot.

Any solution? It seems to be a bug in RouterOS? :?
 
netrat
Member
Member
Posts: 403
Joined: Thu Jun 07, 2007 1:16 pm
Location: Virginia

Re: RB 450G, IPv6 - problem & partial solution

Fri Feb 05, 2010 3:12 am

Yup I see the same thing.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Fri Feb 05, 2010 11:45 am

I have found that also interface disable/enable cause that ONE Router Advertisement message is send. But still no solution.
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Sun Feb 07, 2010 8:19 am

Interesting. I've been running IPv6 for a number of months without this issue. Can you please post your config?
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Mon Feb 08, 2010 12:51 am

Here is important part of my configuration:
/interface 6to4
  add comment="HE IPv6" disabled=no local-address=84.42.xxx.xxx mtu=1280 name=sit1 remote-address=216.66.84.46

/ipv6 address
  add address=2001:470:1xxx:xxxx::2/64 advertise=yes comment="6to4 tunnel endpoint" disabled=no eui-64=no interface=sit1
  add address=2001:470:1xxx:xxxx:20c:42ff:fe3d:2bf8/64 advertise=yes comment="" disabled=no eui-64=yes interface=br0

/ipv6 nd
  add advertise-dns=no advertise-mac-address=yes disabled=no hop-limit=unspecified interface=all managed-address-configuration=yes mtu=unspecified other-configuration=no ra-delay=3s ra-interval=3m20s-10m ra-lifetime=30m reachable-time=2m retransmit-interval=5s

/ipv6 nd prefix default set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d

/ipv6 route 
  add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:xxxx:xxxx::1 scope=30 target-scope=10
I tried to change advertise interface from br0 to eth1 (br0 = ath0 + eth1 + eth2) but still no more advertisement packets.
Last edited by marsark on Sun Apr 25, 2010 10:45 pm, edited 1 time in total.
 
changeip
Forum Guru
Forum Guru
Posts: 3806
Joined: Fri May 28, 2004 5:22 pm

Re: RB 450G, IPv6 - problem & partial solution

Mon Feb 08, 2010 4:17 am

set eui-64=no on the other subnet?
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Mon Feb 08, 2010 11:32 am

Ok, I'll try in the evening. But I'm afraid, that EUI64 is the key part of the IPv6 auto-configuration mechanism.
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Mon Feb 08, 2010 3:37 pm

I don't use EUI64 and everything works just fine.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Mon Feb 08, 2010 11:12 pm

So, I did some experiments with EUI64 enabled and disabled, but without any success. Still no sign of the Router advertisement packet. :( More ideas? Thanks.
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Mon Feb 08, 2010 11:36 pm

Try doing it through the physical interface. In other words, take that interface out of the bridge and attach the address to that interface.
It's a shot in the dark.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Tue Feb 09, 2010 12:02 am

So I have torn out eth1 from the bridge and disabled br0. Now it looks like Router Advertisement is being sent approx. every 250s. Now, it works. But I need eth1, eth2 and ath0 bridged.

UPDATE: I get it back to the previous state and now no more advertisement. Is this bug or a feature? :)
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Feb 09, 2010 1:16 am

So I have torn out eth1 from the bridge and disabled br0. Now it looks like Router Advertisement is being sent approx. every 250s. Now, it works. But I need eth1, eth2 and ath0 bridged.

UPDATE: I get it back to the previous state and now no more advertisement. Is this bug or a feature? :)
Both. Don't you know bugs are undocumented features? =)
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Tue Feb 09, 2010 1:34 am

Hope, will be fixed soon in the next RouterOS 8)
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Feb 09, 2010 2:02 am

When you create the bridge, does it get an fe80:: type address automatically?
Additionally, have you looked into the various neighbor discovery options? You may find your answer there.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Tue Feb 09, 2010 2:17 am

Yes. The br0 device get local link address automatically. It's same as eth2 IPv6 address. I played with ND setting but without any effect. I created new specific rule for br0 and set shorter time for Advertisement, but no effect. In case when "bridge was out" shorter time caused shorter period of Advertisement packet as expected. With bridge enabled... simply nothing.
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Feb 09, 2010 2:30 am

Yeah. Sounds like an undocumented feature.
Gonna have to ask support about that one.
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Feb 09, 2010 2:49 am

Here's another stab in the dark:
Assign a manual MAC address to the bridge.

I thought of this whilst reading this article:
http://wiki.mikrotik.com/wiki/Creating_ ... s_for_IPv6

I'm hopeful it will fix it.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution - WORKAROUND

Wed Feb 10, 2010 12:51 am

Yes, I don't want to be hasty, but it seems to work. Manualy set MAC address of the bridge interface do this.
Last edited by marsark on Wed Feb 10, 2010 12:33 pm, edited 1 time in total.
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Wed Feb 10, 2010 5:37 am

WIN!
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Wed Feb 10, 2010 12:32 pm

So, I can really confirm, that manually set MAC address of the bridge is a functional workaround for missing Advertisement packet issue. BUG IN ROUTEROS REMAINS.
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Wed Feb 10, 2010 8:54 pm

Now that I think about it, I wouldn't call it a bug, per se. I think my assertion of it as an undocumented feature would be more accurate, though it was only in jest when I initially brought it up.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Thu Feb 11, 2010 2:17 am

I celebrated too early. It suddenly stop to work. No advertisement packets anymore. I have to restart br0 interface to get packets again.
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Thu Feb 11, 2010 5:19 am

That's a bug. You need to email mikrotik with a supout.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Mon Mar 01, 2010 10:26 pm

So bug still exists in ROS 4.6. No response from support for more than three weeks. :(
 
brotherdust
Member Candidate
Member Candidate
Posts: 113
Joined: Tue Jun 05, 2007 1:31 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Mar 02, 2010 5:50 am

I am experiencing the same issues with support on another, somewhat related, ticket. Where'd you go mikrotik?
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Tue Mar 02, 2010 2:38 pm

Yes, this is a big problem. Thus I am unable to use IPv6 in my networks for months. IPv6 implementation in ROS seems to be buggy.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Fri Apr 23, 2010 2:07 am

So, I have tried to get IPv6 work with ROS 4.7, but still without any success. Still no RA packets in my network, still no IPv6 :( In ROS 4.7 is my advertised prefix marked as invalid in Neighbor Discovery window ( has flags Dynamic, Invalid). I don't know why?
0 ID prefix=2001:470:1f15:692::/64 interface=br0 on-link=yes autonomous=yes valid-lifetime=4w2d preferred-lifetime=1w
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sun Apr 25, 2010 11:32 am

I did some more test. But I have to confirm that Router Advertisement at bridge is still broken. I managed to get it work, but it works only for certain time. It looks like there are no RA packets after the midnight :-) Than I have to restart the router.
 
Sob
Forum Guru
Forum Guru
Posts: 5416
Joined: Mon Apr 20, 2009 9:11 pm

Re: RB 450G, IPv6 - problem & partial solution

Sun Apr 25, 2010 6:34 pm

Did you try to enable radvd logging? It shows if ROS is trying to send something or not.

Few times I had similar problem as you describe in your first post. It happened only when I tested other things and unplugged ethernet cable from RB. Then sometines after plugging it back, RAs didn't come any more. And with radvd logging enabled it wrote some errors, but I don't remember what exactly it was. RB reboot fixed that.
As for bridge, I have one for OpenVPN clients to give IPv6 addresses to them and it works fine, no missing RAs yet.
Few times I also expirienced situation when RAs were coming, reached client computer, but OS (Win7) ignored them.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply. Not intended as incentive for masochists.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sun Apr 25, 2010 10:39 pm

So I let ROS to send logs to my syslog and discovered this:
Apr 25 21:33:42 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Apr 25 21:33:42 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=01:00:00:00:01:00
Apr 25 21:33:42 r4bu110 radvd,debug: radvd: adding prefix=2001:470:1f15:692::/64
Apr 25 21:33:42 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
So radvd failed to send RA message on br0 interface, but why? Where is invalid argument?
Is this bug or my configuration error?

Later appeared this without any following error:
Apr 25 21:48:28 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0 
but no RA packed arrived. Wireshark confirmed this to me.

Any ideas? Thanks.
 
NSSR
just joined
Posts: 17
Joined: Fri Apr 30, 2010 12:11 am

Re: RB 450G, IPv6 - problem & partial solution

Fri Apr 30, 2010 12:35 am

:shock:
This isn´t just a RB450G related problem. I´ve got the same issues on all RB433AH and RB450G, too.

My work around is, to export the /ipv6/address stuff, delete all entries and reimport them. This works for me until I do some mandatory changes.

Yesterday my ROS6.4 drove me crazy:
It filtered IPv6 traffic on a bridged interface. I removed the bridge, done all configuration absolutely right, but it doesn´t route IPv6 traffic anymore. The router it self can ping global destinations but any host behind the router can´t. A traceroute goes to the router but then ends without success. The firewall has got a rule which allows all packets to be forwarded on any interface.

Any ideas?

Best regards
Stefan
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sat May 01, 2010 1:02 am

I have got RB433AH and the behavior is same as in case of RB450G. So this seems to be a general problem of all RBs.
The must be a bug in the RADVD daemon, because it claims that RA packet has been sent but no packet appears in Wireshark.

Devs, please provide some fix. RA is key feature of IPv6. I can't use IPv6 without RA.
 
Lev
just joined
Posts: 10
Joined: Fri Apr 30, 2010 6:04 am

Re: RB 450G, IPv6 - problem & partial solution

Sat May 01, 2010 7:48 am

I have got RB433AH and the behavior is same as in case of RB450G. So this seems to be a general problem of all RBs.
The must be a bug in the RADVD daemon, because it claims that RA packet has been sent but no packet appears in Wireshark.

Devs, please provide some fix. RA is key feature of IPv6. I can't use IPv6 without RA.
+1
I can set up discrete tunnels to US for Hulu and such for individual or WISP. PM or ICQ me
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Sat May 01, 2010 8:45 pm

We had this problem with version 4.6. Upgrading to version 5.0 beta solved it.

Another important problem we had with version 4.6 is that ARP was not working with vrrp like mac address on the network. We had no connectivity at all with the main routers, who have vrrp interfaces. Eth1 was not working if i remember well, we had to use eth2. We downgraded to version 4.4 as well to solve the problem. We loosed three hours at night in the datacenter because of this, and we loosed some trust with Mikrotik RouterOs. So we are now extending the testing period to 6 monthes before to enter production.

I think that Ros has become to much complicated compared to the Mikrotik staff programming and testing power.

It's time to make the software opensource Mikrotik guys.... And concentrate about hardware sellings. Or pay new master programmers.

Every new versions of it introduce new problems. See the latest 4.7 and 4.8 versions.

I'm afraid by futur versions with full IPv6 support, if we still have many basic problems with IPv4.

But Mikrotik RouterOS is the best for the price. No problem here :=)
 
NSSR
just joined
Posts: 17
Joined: Fri Apr 30, 2010 12:11 am

Re: RB 450G, IPv6 - problem & partial solution

Sat May 01, 2010 10:44 pm

Hi,

disabling the address and reenable it, fixes this problem for a while. But after some time, the problem reappears.

Best regards
Stefan

PS: My IPv6 trouble is solved now, thanks Lev.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sun May 02, 2010 1:36 am

I tried to disable/enable interface and export/import settings. It works, but only until midnight :) After the midnight there are no more RA packets.

I know that 5.0 beta solve this bug, but I don't dare to install 5.0 beta at production routers. Hope that fix will be back ported to the 4.xx branch. Until that - no IPv6. :(

Martin
 
NSSR
just joined
Posts: 17
Joined: Fri Apr 30, 2010 12:11 am

Re: RB 450G, IPv6 - problem & partial solution

Sun May 02, 2010 1:40 am

For me it doesn't work until midnight. I had to do this action more than once today. This is really annoying, as i promoted and highly recommended the Mikrotik-Stuff on Microsoft Server Summit 2009 reloaded in an IPv6 session.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Thu May 06, 2010 1:03 am

Yes, same situation here. I have set up a few RBs by my customers and reason was IPv6. Than shows that IPv6 sucks on RB and I looks like a stupid sod.
 
Lev
just joined
Posts: 10
Joined: Fri Apr 30, 2010 6:04 am

Re: RB 450G, IPv6 - problem & partial solution

Thu May 06, 2010 8:04 am

Yes, had to learn other software, Vyatta, to run IPv6 as it should be. Would prefer to just use RouterOS but even release seem like beta at moment. As mentioned I can not talk up Mikrotik and then have little things cause issues and look foolish.
I can set up discrete tunnels to US for Hulu and such for individual or WISP. PM or ICQ me
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Mon May 10, 2010 10:35 pm

I'am giving up. Still no solution and too many hours spent with no success. I have to look for another hardware than Mikrotik, because there is no presumption when will be RA in ROS fixed. :( :( :(
 
NSSR
just joined
Posts: 17
Joined: Fri Apr 30, 2010 12:11 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 01, 2010 9:17 pm

Hi,

hoped that 4.10 will solve the problem - but it isn't. I've got loads of RB493AH running, where all ports are bridged.

As long this issue persists, I'm not willing to invest in ROS and RBs.

I've done a workaround now:
/system scheduler
add comment="" disabled=no interval=1h name=schedule1 on-event=\
    "/ipv6 address print\r\
    \n/ipv6 address disable 1\r\
    \n/ipv6 address enable 1\r\
    \n" start-date=jan/01/1970 start-time=21:15:00
Best regards

Stefan
 
NSSR
just joined
Posts: 17
Joined: Fri Apr 30, 2010 12:11 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 01, 2010 9:41 pm

Hi programmers,

may anyone write a script for us doing the following:

1st: read all ipv6 addresses from "/ipv6 address" where param advertise is set to yes
2nd: disable all this addresses
3rd: enable all this addresses

Then we put this in the scheduler to run this script in a smaller interval than the ra is valid.

This would be a nice workaround.

Best regards

Stefan
 
changeip
Forum Guru
Forum Guru
Posts: 3806
Joined: Fri May 28, 2004 5:22 pm

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 01, 2010 9:49 pm

/ipv6 address set [/ipv6 address find global] disabled=yes
/ipv6 address set [/ipv6 address find global] disabled=no
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
changeip
Forum Guru
Forum Guru
Posts: 3806
Joined: Fri May 28, 2004 5:22 pm

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 01, 2010 9:51 pm

if you have some disabled and dont want them reenabled you can store them into a variable, ie:

{
:local ipv6addresses [/ipv6 address find global disabled=no]
/ipv6 address set $ipv6addresses disabled=yes
/ipv6 address set $ipv6addresses disabled=no
}
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
NSSR
just joined
Posts: 17
Joined: Fri Apr 30, 2010 12:11 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 01, 2010 9:51 pm

Great, thanks. This works.

I've done like this now:
/ipv6 address set [/ipv6 address find advertise=yes disabled=no] disabled=yes
/ipv6 address set [/ipv6 address find advertise=yes disabled=yes] disabled=no

Is there a logical operator needed between this two conditions?

Stefan
 
NSSR
just joined
Posts: 17
Joined: Fri Apr 30, 2010 12:11 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 01, 2010 10:01 pm

I think, this is the best solution to be run as a scheduled task:
{
:local ipv6addresses [/ipv6 address find global disabled=no advertise=yes]
/ipv6 address set $ipv6addresses disabled=yes
/ipv6 address set $ipv6addresses disabled=no
}
Thanks to pavel and changeip for their help while building up this script. ;)

BR
Stefan
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 01, 2010 10:45 pm

I have discovered some new thing about not working RA. I have updated ROS to 4.10 on Monday at night. Than RA worked correctly until the morning when scheduler script enables ath0 device which is bridged with eth0 and eth1 to br0. I'm disabling WiFi for night. I have found following in logs:
Jun  1 08:22:06 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0   <<< Here OK, RA captured by Wireshark
Jun  1 08:26:44 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jun  1 08:30:00 r4bu110 system,info: device changed by admin                             <<< Here scheduler enables ath0
Jun  1 08:30:02 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jun  1 08:30:02 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jun  1 08:30:02 r4bu110 radvd,debug: radvd: adding prefix=2001:470:1f0b:127d::/64
Jun  1 08:30:02 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument <<< After this no more RA
Jun  1 08:33:45 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0   <<< No packets captured by Wireshark
Jun  1 08:37:51 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
and later
Jun  1 20:54:45 r4bu110 radvd,debug: radvd: received Router Solicitation on  interface=br0   <<< request for RA sent by Nokia E52
Jun  1 20:54:45 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0  <<< but no packet captured by Wireshark in (no response from ROS)
Jun  1 20:54:45 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jun  1 20:54:45 r4bu110 radvd,debug: radvd: adding prefix=2001:470:1f0b:127d::/64
Jun  1 20:54:45 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Now, I don't know if the problem is caused by script it self (enabling/disabling device which is part of the bridge) or by presence of the ath0 in the bridge. ath0 is Wistron CM9 WiFi card.

Any ideas?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RB 450G, IPv6 - problem & partial solution

Wed Jun 02, 2010 3:42 pm

you are getting address only on that port whose mac address is on bridge when router boots up. (LL address is the same as on the port) hence the results.

We are testing possible solutions. Some first results will be available in 5.0beta3 when it is released, cannot say about 4.x version.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Wed Jun 02, 2010 3:54 pm

OK, I understand now. The bridge configuration or its interfaces state can't be change after the boot.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Thu Jun 03, 2010 10:23 pm

So, my troubles was caused by scheduler scripts which enables/disables wifi. For a workaround I added rows:
interface bridge disable br0
interface wireless disable ath0
interface bridge enable br0
And similarly for enabling script. Now, problems with broken RA are gone.
 
NSSR
just joined
Posts: 17
Joined: Fri Apr 30, 2010 12:11 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 15, 2010 8:49 pm

So, let's put this issue to the top of the open issues.
19:39:23 radvd,debug sending Router Advertisement on bridge01_NSSR-LAN
19:39:23 radvd,debug adding link-layer address option, mac-address=00:0C:42:3E:92:11
19:39:23 radvd,debug adding prefix=2a01:138:9003:18::/64
19:39:23 radvd,debug sendmsg failed on bridge01_NSSR-LAN (fe80::20c:42ff:fe3e:9211): Invalid argument
And this is the bridge-config:
/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes comment="" disabled=no forward-delay=15s l2mtu=1524 max-message-age=20s mtu=1500 name=bridge01_NSSR-LAN priority=0x8000 \
    protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=bridge01_NSSR-LAN comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=eth04 path-cost=10 point-to-point=auto priority=0x80
add bridge=bridge01_NSSR-LAN comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=eth02 path-cost=10 point-to-point=auto priority=0x80
/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no
I think this might also be the reason for the buggy router advertisement. I also don't know, why MikroTik doesn't take care about this issue.

BR
Stefan
 
ricky011
newbie
Posts: 35
Joined: Tue Jul 15, 2008 1:33 pm
Location: Serbia

Re: RB 450G, IPv6 - problem & partial solution

Sun Jun 20, 2010 8:59 pm

Some first results will be available in 5.0beta3 when it is released, cannot say about 4.x version.
hi all,

right now I'm running ROS 5.0beta3, and still having the same problem...
"19:53:46 radvd,debug skip Router Advertisement sending on ether2-LAN-NAT: no link local address"?
but there is a link local adress???

of course, disabling/enabling the interface solves the problem for a limited and unknown amount of time... sooner or later (few hours, or few days) i t stops advertising again...

msg to the mikrotik people: solve it, or implement DHCPv6!!?? either way is just fine with me, as long as it's working :D
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Mon Jun 21, 2010 2:09 am

version 5.03 has some weird problems.

Winbox server refuse connections after about one day. Need a reboot.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Mon Jun 21, 2010 1:53 pm

Hm, the real pain is that RA issue time dependent. Sometimes it works for hours than only for minutes. I can understand that there is a problem in the software. But I do not understand that Mikrotik stuff ignores it.I need some statement to this. I have equipped my customers with RBs, and now I am looking like a sod.
 
ricky011
newbie
Posts: 35
Joined: Tue Jul 15, 2008 1:33 pm
Location: Serbia

Re: RB 450G, IPv6 - problem & partial solution

Mon Jun 21, 2010 9:52 pm

I must agree, although my situation is not that drastic... we were in the process of purchasing couple of hundreds RB750's, but everything has come to a halt, because of this big problem... and unfortunately there is no other IPv6 CPE equipment on the market that I know of, is there?

please Mikrotik, make IPv6 RA work, or give us any kind of DHCPv6??? (pretty please?) :(
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Jun 22, 2010 2:24 am

DHCPv6 ?? You will install a DHCPv6 on each client machine ?

Radvd is simpler and enough for most LANs. On another side, DNS is important with IPv6, as you can't remember EUI64 addresses like you can with IPv4 adresses. I hope to see a better DNS server inside Router OS.

Problems will really come in front next year, when the first final clients will have only IPv6 addresses alocated.

If you need a better IPv6 support now, the best is perhaps to use a real Linux Small Form Factor PC machine. They are becoming less and less expensive and are faster than the fastest routerboard. You can even push a linux machine to 10 Gbps routing, with advanced Intel multiqueue drivers. But you will not have the power of the Mikrotik very nice GUI.

Mikrotik has very good products, but unfortunately OS router is closed source, so developpement is quite slow. They have to develope or debug everything themselves : wifi, advanced routing, IPv6, MPLS, BGP....

The power of linux is that there are many more developpers and testers working on it, so debugging is generaly quite fast, even faster than BSD (see PFsense project with very long development period and still buggy for some advanced features).
Pfsense is always waiting for corrections from the BSD teams.

In the meantime if you need an embeded platforme for cost reasons, you could use Openwrt. It has IPv6 support. I've tested this a couple years ago and it was working without glitches. I have some Openwrt router at client sites IPv6 enabled since 3 years now (IPv6 delivered with PPPoE). But still manual setup for IPv6 and a basic Gui for IPv4...

So the best would be a Mikrotik Router Os with full IPv6 support (tunnels, Winbox...) in the next monthes.

We are still waiting before to take big decisions for hardware choice regarding IPv6, because there will be certainly new products on the market in the coming year.

Do not forget that IPv6 will be a formidable engine for VAR and manufacturers to sell hardware.
 
ricky011
newbie
Posts: 35
Joined: Tue Jul 15, 2008 1:33 pm
Location: Serbia

Re: RB 450G, IPv6 - problem & partial solution

Thu Jun 24, 2010 7:18 pm

DHCPv6 ?? You will install a DHCPv6 on each client machine ?
what other choice do I have? RADVD is not working!
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Thu Jun 24, 2010 8:55 pm

You can use manual IPv6 setup. Will be simpler than DHCPv6... If the network is small.
 
ricky011
newbie
Posts: 35
Joined: Tue Jul 15, 2008 1:33 pm
Location: Serbia

Re: RB 450G, IPv6 - problem & partial solution

Fri Jun 25, 2010 8:29 pm

that is the problem... the network is already big, several thousand customers... with a good DHCP server it would work like a charm, it's working as is, but I have to disable/enable the interfaces on the router every 12 hours, just in case... :(
 
crean
just joined
Posts: 5
Joined: Tue Feb 23, 2010 11:26 am

Re: RB 450G, IPv6 - problem & partial solution

Fri Jun 25, 2010 9:26 pm

It is not really more complicated to setup an DHCPv6 server than DHCPv4. Especially not, when you've
to setup e.g. classless routing using the DHCPv4 server provided on the routeros that is also not able to
use the hostname in dns... dnsmasq can do this, ISC dhcp server too ('send-hostname' option in the ISC
dhclient or dhcpcd -h option).

It would be nice when Mikrotik would ship a DHCPv6 server... fix this RA problem, enable UDP support
in openvpn, solve the instability / VM freezing problems in Metarouter (so I can run a DHCPv6 server in
a openwrt VM instead on a separate hw) and with vanishing micro-sd :-(

Well, as you can see, in the meantime I start to think it was a mistake to buy this closed source RB450G...

But... to be not completely off-topic: the persons requesting DHCPv6 server in previous comments seem
to forget, that they need RAs also when they're using DHCPv6 (managed-address-configuration=yes,
other-configuration=yes).
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Sat Jun 26, 2010 1:58 am

If the network is so big, you could use a small OpenWRT box in the meantime. The DHCPv6 server package is available on this platform if i remember well.
 
ricky011
newbie
Posts: 35
Joined: Tue Jul 15, 2008 1:33 pm
Location: Serbia

Re: RB 450G, IPv6 - problem & partial solution

Sat Jun 26, 2010 10:33 am

that's not the only issue... I have to give a /48 to each of my customers, so they can use the addresses in their network... RB750 seemed like the perfect solution, at the time...
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sat Jun 26, 2010 5:29 pm

IMHO, DHCPv6 can't provide router address to the clients. Router must advertise itself.
 
crean
just joined
Posts: 5
Joined: Tue Feb 23, 2010 11:26 am

Re: RB 450G, IPv6 - problem & partial solution

Mon Jun 28, 2010 12:16 pm

IMHO, DHCPv6 can't provide router address to the clients. Router must advertise itself.
Exactly. The radvd / Router Advertisement Daemon advertises the router address [other routes, rdnss], the prefixes
for a network and the information whether the host/node configuration in the network stateless or stateful =DHCPv6.

For DHCPv6 you have to set managed-address-configuration=yes, other-configuration=yes on the routeros router
(the AdvManagedFlag on; AdvOtherConfigFlag on; options in radvd, see also RFC 2462).

It is also possible to use a combination, that is let the hosts assign the address via radvd and provide further
settings via dhcpv6 (e.g. dhcp6.name-servers, dhcp6.domain-search).

That is, the radvd is required for DHCPv6 as well.
 
ricky011
newbie
Posts: 35
Joined: Tue Jul 15, 2008 1:33 pm
Location: Serbia

Re: RB 450G, IPv6 - problem & partial solution

Sun Jul 04, 2010 5:14 pm

well, that's even bigger problem then... i admit, i assumed that DHCPv6 has a similar functionality as the old DHCP(v4)...

last few days, I was doing extensive testing with different ROS versions (3.30, 4.10, 5.0b3), and the problem remains... after some time, the router just stops advertising... and I have to disable/enable the interface to "restart" the advertising process... it happened no matter what version I've used... sometimes after only a few hours, other times it took a few days (no pattern), but it eventually stops...
on the same network, but different VLAN, I have a cisco 7206-npe-g1, and it's working without problems... :)
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sun Jul 04, 2010 10:46 pm

I also didn't find any pattern or reason why radvd daemon stops to work. I did last week some test with RB750G. I has only one port in use. It act as a 6to4 tunnel endpoint and announces router and prefix to the native IPv6 network (our customers) via VLAN. There is no problem, it seems that radvd is running for a week without any issue.

There is another situation with my RB433AH (br1 = eth1 + eth2 + ath0, eth0 = WAN). I need to advertise router on the br0 device. In this case radvd fails in 6 hours.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Fri Jul 09, 2010 11:43 pm

It seems that there is no progress in fixing this nasty bug. I encountered with this bug again these days. Now I have the RB750G as an end point of the 6to4 tunnel. The eth1 interface has four tagged VLANs - vlan2, 3, 4, 5, 6. There is one /64 prefix which is advertised at vlan4 interface and the second /64 prefix at vlan5. Also there is another /64 prefix which is advertised at eth0 itself. This works for a few hours (maybe 10 to 18). Than vlans prefixes stops to work and only eth0 prefix is advertised but at all vlans.

So there must be something really bad in the radvd implementation in the ROS.

Could some one from MT say afew word to this? Any ETA or partial progress? normis, sergejs, mrz ... anyone? I can provide access to my units for you.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sun Jul 18, 2010 11:57 pm

Time to move the thread up.
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Mon Jul 19, 2010 1:22 am

Perhaps a multicast hardware problem with Broadcom chips ?

This bug is an old one. Hardware bugs are often difficult or impossible to solve.

Apple and Eizo took one year to solve a USB Mouse jerking problem when connecting a DisplayPort monitor...

I think that serial processing is not the way to go for fast tasks. Perhaps high end Routerboards should add an FPGA chip instead of fully relying on Broadcom chips and Linux. It should be easier to debug and fully programmable.

I can't understand why only biggest router manufacters are using FPGAs in their high end product.

Small FPGAs are not expensive (5 $) and are very powerfull for wire speed and parallel tasks like routing, filtering, Queuing...
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Mon Jul 19, 2010 1:35 am

Hm, let me guess. It's lack of the skilled HW designers a necessity of do all from scratch or buy an IP core. Use linux kernel is much more easier. I think, that there is some problem in the ROSs implementation of the radvd. May be MAC address handling in case of bridge, VLANs and so on. I can accept, that there is an bug or HW problem, but I am fed up with the zero reaction from MikroTik.
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Mon Jul 19, 2010 1:58 am

Zero reaction often mean that there is a difficult underlying problem.

Yes Linux is simpler, but you get only unefficient serial processing.

On the opposite, you can use ready made small Asics like Broadcom ones, solution used inside routerboards.

But using those asics means that you can't change anything in their functions. As an example, all switch functions like rules inside RB750G are not modifiable. Another example : the MTU is fixed and you cannot change it.


Using an FPGA chip to accelerate critical functions, (SSL / IPSEC encoding, routing, filtering, queuing...) is more difficult because you need to fully understand the Linux code, extract it and and design new VHDL or Verilog code from it to implement those functions inside the FPGA.

But in the end you got a really faster product with a real and protected added value, eventually working at wire speed for 1 or 10 Gbps links. Programming logic circuits today is really easier than 15 years ago. I can't understand why we see few products with them.
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Jul 20, 2010 1:10 pm

The strange thing is that a couple of users have problems with PIM and multicast not working, or stop working after some time.

Perhaps there is a hardware problem with multicast, this could explain why radvd stop working after some time.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Tue Jul 20, 2010 1:42 pm

Yes, the strange thing is that temporal interval until failure. It varying from minutes to hours and when failure occurs, than I have log full of the following messages:
Jul 19 16:06:02 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:06:02 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:06:02 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Jul 19 16:10:42 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:14:31 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:14:31 r4bu110 radvd,debug: radvd: adding DNS server option, address=2001:470:20::2
Jul 19 16:14:31 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:14:31 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: adding DNS server option, address=2001:470:20::2
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: adding DNS server option, address=2001:470:20::2
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Jul 19 16:24:26 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: adding DNS server option, address=2001:470:20::2
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sat Aug 14, 2010 12:26 am

Nothing changed in ROS 4.11, radvd log is still full of Invalid argument messages.
 
netrat
Member
Member
Posts: 403
Joined: Thu Jun 07, 2007 1:16 pm
Location: Virginia

Re: RB 450G, IPv6 - problem & partial solution

Mon Oct 04, 2010 9:35 pm

I'm seeing the same with ROS v4.11. I tried using v5.0rc1, but the router locks up with a kernel failure when doing IPv6 advertisements. Once the IPv6 stuff is turned off no more lockups.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: RB 450G, IPv6 - problem & partial solution

Fri Oct 22, 2010 2:16 am

Still getting radvd failures due to missing link local addresses, even through link local addresses are present.

Will also open a ticket with support...
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sat Oct 23, 2010 3:28 pm

I have opened a support ticket months ago, but MTs they never respond.
 
User avatar
vegard
newbie
Posts: 25
Joined: Sat Feb 12, 2005 6:55 pm

Re: RB 450G, IPv6 - problem & partial solution

Tue Oct 26, 2010 12:22 pm

Any updates?
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Tue Oct 26, 2010 2:06 pm

Nope, no info, no progress, no changes.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Oct 26, 2010 7:33 pm

A new build of RC2 is supposed to fix radvd bugs (at least according to support they weren't able to reproduce them on that release).
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Tue Oct 26, 2010 7:51 pm

Where can I get 5.0rc2 ?
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Oct 26, 2010 7:53 pm

Not sure what the proper procedure is - I got a link from support in response to a ticket I filed. Maybe email them.
 
nunesvn
just joined
Posts: 4
Joined: Sat Apr 04, 2009 4:21 pm

Re: RB 450G, IPv6 - problem & partial solution

Tue Oct 26, 2010 8:41 pm

Good news from support!
Hello,

please wait till 4.12 release there this problem should be resolved.

Regards,
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Wed Oct 27, 2010 12:42 am

Hm, this sounds good. If it will be so. I will open a bottle. :D
 
Sob
Forum Guru
Forum Guru
Posts: 5416
Joined: Mon Apr 20, 2009 9:11 pm

Re: RB 450G, IPv6 - problem & partial solution

Wed Oct 27, 2010 6:29 pm

I would leave the bottle sitting in the cellar for just a little bit longer. ;)

Something may be fixed, but I belive not everything. Simple test (clean install of ROS 4.12 x86 in VirtualBox):
/system logging add action=memory topics=radvd
/ipv6 firewall filter add action=log chain=output protocol=icmpv6
/interface bridge add name=bridge1
/ipv6 nd add interface=bridge1 ra-interval=10s-15s
/ipv6 address add address=2001:db8::1/64 advertise=yes interface=bridge1
It (as expected) leads to this:
skip Router Advertisement sending on bridge1: no link local address
To get link-local address, MAC address is needed:
/interface bridge set 0 auto-mac=no admin-mac=fe:00:00:00:00:01
At this point it starts to work. And firewall log shows that RAs (ICMPv6 type 134) are sent to bridge1 interface with source address fe80::fc00:ff:fe00:1.

And now a little challenge:
/interface eoip add mac-address=02:D4:2D:05:59:B5 name=eoip-tunnel1 remote-address=192.168.44.44
/interface bridge port add bridge=bridge1 interface=eoip-tunnel1
Oops:
sendmsg failed on bridge1 (fe80::d4:2dff:fe05:59b5): Invalid argument
See the link-local address? It's not bridge1's address, it belongs to eoip-tunnel1. No wonder it's invalid for bridge1.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply. Not intended as incentive for masochists.
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Thu Oct 28, 2010 10:07 pm

I upgraded my RB433AH to ROS 4.12. But problem with "Invalid argument" persist. It is related to the wifi interface and bridge above it.
wireless,info 00:1B:77:B8:2E:EA@ath0: connected
radvd: received Router Solicitation on  interface=br0
radvd: sending Router Advertisement on br0
radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
radvd: adding DNS server option, address=2001:470:20::2
radvd: adding prefix=2001:470:1f0b:127d::/64
radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
radvd: received Router Solicitation on  interface=br0
radvd: sending Router Advertisement on br0
radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
radvd: adding DNS server option, address=2001:470:20::2
radvd: adding prefix=2001:470:1f0b:127d::/64
radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
dhcp,info dhcp1 assigned 10.0.10.7 to 00:1B:77:B8:2E:EA
radvd: received Router Solicitation on  interface=br0                                                           
radvd: sending Router Advertisement on br0                                                                      
radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9                                          
radvd: adding DNS server option, address=2001:470:20::2                                                         
radvd: adding prefix=2001:470:1f0b:127d::/64                                                                    
radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
LocalLink address
fe80::20b:6bff:fedd:3463
is address of the wifi adapter.
 
User avatar
webasdf
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Mon Jan 26, 2009 6:37 pm

Re: RB 450G, IPv6 - problem & partial solution

Mon Nov 08, 2010 8:46 pm

Not sure if I'm experiencing the same bug, but seems similar to what you're describing.

We have a 450G running 4.4 firmware supplying internet to internal VLAN 100, 200 and 500 with ipv6 connection via a tunnel from Hurricane Electric. This is very strange.

The weirdness
  • Try to ping a statically assigned ipv6 address residing on VLAN100 from REMOTE. If not in ipv6 neighbor list, no ping success
  • The static IP address doesn't show up in VLAN100, but instead in VLAN200 hence ping does not succeed.
  • Ping outgoing FROM the desired host on vlan100, after a few seconds neighbor list shows the ipv6 address as properly coming from VLAN100 as expected.
  • Is fine as long as something keeps talking ipv6. As soon as the address disappears from the neighbor list, it all has to be done again.
The Config
/ipv6 address
add address=2001:470:1f10:9c1::2/64 advertise=yes comment="" disabled=no eui-64=no interface=sit1
add address=2001:470:1f11:9c1::200/64 advertise=yes comment="" disabled=no eui-64=no interface="Workstations VLAN200"
add address=2001:470:1f11:9c1::100/64 advertise=yes comment="" disabled=no eui-64=no interface="DMZ VLAN100"
add address=2001:470:1f11:9c1::500/64 advertise=yes comment="" disabled=no eui-64=no interface="Anonymous VLAN500"
/ipv6 nd
add advertise-dns=no advertise-mac-address=yes disabled=no hop-limit=64 interface=all managed-address-configuration=no mtu=unspecified other-configuration=\
    no ra-delay=3s ra-interval=3m20s-10m ra-lifetime=1h reachable-time=1h retransmit-interval=unspecified
/ipv6 nd prefix default
set autoconfig=yes on-link=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:1f10:9c1::1 scope=30 target-scope=10
 
User avatar
webasdf
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Mon Jan 26, 2009 6:37 pm

Re: RB 450G, IPv6 - problem & partial solution

Mon Nov 08, 2010 9:21 pm

Boy do I feel silly. After making the last post, I did some subnet arithmetic and determined that the router advertisement on all VLANs was broadcasting the same subnet. I got a /48 subnet from Hurricane Electric and subnetted a /64 for each vlan and it works now :) Just needed to write out my problem so I could solve it I guess.
 
hex
just joined
Posts: 4
Joined: Wed Nov 10, 2010 4:32 am

Re: RB 450G, IPv6 - problem & partial solution

Wed Nov 10, 2010 4:41 am

Jel noralno da router advertajzuje svoju local-link adresu iako mu nije receno da je advertajzuje i da se onda detektuje duplicirani prefix sa sobom samim ?
Is it normal for router do advertize its local-link address
Is this normal ?
Looks like router is advertising its local-link address, I don't know why.
Even worse is that that local-link advertisement then collide with the needed one.

Clients get good global IP address but local-link default gateway.

Image
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5997
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: RB 450G, IPv6 - problem & partial solution

Mon Nov 15, 2010 9:15 am

Router is not advertising link-local addresses. Log message means that you have the same prefix configured on two routers and both of them are advertising it.
 
hex
just joined
Posts: 4
Joined: Wed Nov 10, 2010 4:32 am

Re: RB 450G, IPv6 - problem & partial solution

Mon Nov 15, 2010 1:32 pm

But I have only one router on network.

I underlined with red IP address fe80:...:173 and that is IP address of that router.
 
Beccara
Long time Member
Long time Member
Posts: 606
Joined: Fri Apr 08, 2005 3:13 am

Re: RB 450G, IPv6 - problem & partial solution

Tue Dec 07, 2010 11:13 am

We had a RB750G running 4.10 doing the invalid argument thing with ether2-5 were slaved. 4.13 fixed it right up for us
 
crean
just joined
Posts: 5
Joined: Tue Feb 23, 2010 11:26 am

Re: RB 450G, IPv6 - problem & partial solution

Wed Jan 12, 2011 1:50 am

We had a RB750G running 4.10 doing the invalid argument thing with ether2-5 were slaved. 4.13 fixed it right up for us
Unfortunatelly, the problem still exists in 4.16 :( Hmm... perhaps I've to go back to 4.13?

AFAIS it is also not related to use of a bridge interface as sometimes guessed in this thread -- I'm not using any.
My RB450G is sending the RA using the link-local address of the enslaved port nr 4 (eth5) instead with the link
local address of port nr 1 / lan1:

# NAME MAC MASTER
0 lan0 ...:26:50
1 lan1 ...:26:51 none
2 lan2 ...:26:52 none
3 eth4 ...:26:53 none
4 eth5 ...:26:54 lan1

Jan 11 23:37:38 radvd,debug sending Router Advertisement on lan1
Jan 11 23:37:38 radvd,debug adding link-layer address option, mac-address=...:26:51
Jan 11 23:37:38 radvd,debug adding prefix=2001:...:1000::/64
Jan 11 23:37:38 radvd,debug sendmsg failed on lan1 (fe80::...:2654): Invalid argument

I *guess*, it has something to do with the link state / cable connection of the slave interface and the
switch logic / interface change calculations. When I enslave also port 3, it prefers it (always 1st one).

Funny is, that the RAs work fine all the time on both vlan interfaces that are on top of the lan1 interace,
while lan1 itself sometimes works, sometimes not. Even more strange is, that I didn't observed it on lan2.

To fix it, it does not work for me to disable+reenable RAs or to set port 4 to master-port=none and back.
The best working "workaround" for me is to 'switch set 0 switch-all-ports=yes' and then back to 'switch-all-ports=no'.

Ugly is, that Mikrotik seems to be not interessted in fixing it already for a long time (>= 1 Year?) ... :-(
 
crean
just joined
Posts: 5
Joined: Tue Feb 23, 2010 11:26 am

Re: RB 450G, IPv6 - problem & partial solution

Wed Jan 12, 2011 1:54 am

BTW: 5.0rc7 has the RA problem as well.
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RB 450G, IPv6 - problem & partial solution

Wed Jan 12, 2011 2:10 am

Does this bug exhibit on X86 hardware ?
 
Roman4604
just joined
Posts: 7
Joined: Wed Jan 27, 2010 4:55 pm

Re: RB 450G, IPv6 - problem & partial solution

Wed Jan 12, 2011 1:16 pm

BTW: 5.0rc7 has the RA problem as well.
MT have indicated fix will be in RC8 ... http://forum.mikrotik.com/viewtopic.php?f=1&t=47846
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RB 450G, IPv6 - problem & partial solution

Sun Feb 06, 2011 4:13 pm

I have checked this according to the note in the changelog:
*) radv - fixed problem when wrong link local address was used to send advertisements on bridge interface;
I installed ROS v5rc8 at my RB450G and RB433AH and RAs works for me now. So it is fixed - finally. I will open a bottle. :D

Who is online

Users browsing this forum: Google [Bot], ikashem, jvanhambelgium, lucapsg, vikinggeek, Zacharias and 187 guests