Community discussions

MikroTik App
just joined
Topic Author
Posts: 22
Joined: Sat Feb 20, 2010 9:02 pm

100% CPU & high temp

Sun Mar 14, 2010 1:38 pm


I am having problems with permanent 100% CPU usage and quite high temperature on my new RB450G router (router behind cable at home).

Some information:

[admin@RB450G] > /system check-installation
checking dhcp package...
checking ntp package...
checking security package...
checking user-manager package...
checking multicast package...
checking advanced-tools package...
checking routerboard package...
checking ups package...
checking ipv6 package...
checking system package...
checking mpls package...
checking dude package...
checking gps package...
checking calea package...
checking hotspot package...
checking ppp package...
checking routing package...

[admin@RB450G] > /system health print
voltage: 16.7V
temperature: 54C

[admin@RB450G] > /system resource print
uptime: 3d16h31m7s
version: "4.6"
free-memory: 230452kB
total-memory: 257360kB
cpu: "MIPS 24K V7.4"
cpu-count: 1
cpu-frequency: 680MHz
cpu-load: 100
free-hdd-space: 436852kB
total-hdd-space: 520192kB
write-sect-since-reboot: 36026
write-sect-total: 191906
bad-blocks: 4
architecture-name: "mipsbe"
board-name: "RB450G"

[admin@RB450G] > /interface print
Flags: D - dynamic, X - disabled, R - running, S - slave
0 R ether1 ether 1500 1524
1 R ether2 ether 1500 1524
2 R ether3 ether 1500 1524
3 ether4 ether 1500 1524
4 ether5 ether 1500 1524

[admin@RB450G] > /ip address print
Flags: X - disabled, I - invalid, D - dynamic
0 ether1
1 ether2
2 ether3
3 ether4
4 D 62.***.***.***/21 62.***.***.0 62.***.***.255 ether1

[admin@RB450G] /ip dns print
servers: 80.***.***.***,80.***.***.***
allow-remote-requests: yes
max-udp-packet-size: 512
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 198KiB

[admin@RB450G] > /ip firewall filter print
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; Allow established connections
chain=input action=accept connection-state=established in-interface=ether1

1 ;;; Allow related connections
chain=input action=accept connection-state=related in-interface=ether1

2 ;;; Allow limited pings
chain=input action=accept protocol=icmp in-interface=ether1 limit=50/5s,2

3 ;;; Allow incoming UDP
chain=input action=accept protocol=udp in-interface=ether1

4 ;;; Allow PPTP tunnel maintenance traffic
chain=input action=accept protocol=tcp in-interface=ether1 dst-port=1723

5 ;;; Allow PPTP tunneled data to pass through router
chain=input action=accept protocol=gre in-interface=ether1

6 ;;; Allow everything from our private LAN
chain=input action=accept src-address=

7 ;;; Log everything else
chain=input action=log in-interface=ether1 log-prefix="DROP INPUT"

8 ;;; Drop everything else
chain=input action=drop in-interface=ether1

[admin@RB450G] > /ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; Port fw TCP 8888/8889
chain=dstnat action=netmap to-addresses= to-ports=8888-8889 protocol=tcp in-interface=ether1 dst-port=8888-8889

1 ;;; Port fw UDP 8888/8889
chain=dstnat action=netmap to-addresses= to-ports=8888-8889 protocol=udp in-interface=ether1 dst-port=8888-8889

2 ;;; NAT
chain=srcnat action=masquerade src-address= dst-address= out-interface=ether1

[admin@RB450G] > /system ntp client print
enabled: yes
mode: unicast
status: reached

[admin@RB450G] > /system scheduler print
Flags: X - disabled
0 X dyndns-update jan/01/1970 00:00:00 1h1m dyndns-update 87
1 X dyndns-force jan/01/1970 02:00:00 1d2m dyndns-force 4

Any help would be appreciated. I tried to disable as much as possible without any result in CPU load yet.

Posts: 26
Joined: Sun Aug 17, 2008 6:10 pm

Re: 100% CPU & high temp

Mon Mar 15, 2010 10:58 am

your configuration should not lead to high cpu usage and high temperature
its either the equipment is damaged or there is a mistake somewhere else
try to system reset your board and check the cpu usage before reconfiguring
just joined
Topic Author
Posts: 22
Joined: Sat Feb 20, 2010 9:02 pm

Re: 100% CPU & high temp  [SOLVED]

Mon Mar 15, 2010 8:57 pm

Thanks for reply.

Winbox reset failed with timeout. I did a hard reset (contact on the R450G board).
CPU load still 100%.

I am preparing for RMA now.
just joined
Posts: 8
Joined: Mon Oct 11, 2010 2:00 am

Re: 100% CPU & high temp

Fri Nov 04, 2011 8:37 pm

I had similar problems with rb750
disabling ntp client seems to have resolved the problem. could it be that there is a bug in ntp client causing high cpu usage and consequent reboots?

br Arijan

Who is online

Users browsing this forum: Baidu [Spider], cohortcw, pnam2kx and 169 guests