Community discussions

MUM Europe 2020
 
magnavox
Member
Member
Topic Author
Posts: 340
Joined: Thu Jun 14, 2007 1:03 pm

Log to file clarification.

Sat Mar 27, 2010 3:30 pm

Enabling log to file (action=disk) the ROS show log also in log viewer.. this is correct?
It's possible to log to file without fill log memory?

Tnx in advance.
Best Regards...
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: Log to file clarification.

Sat Mar 27, 2010 6:00 pm

I'm not 100% sure on this, but are you certain that you don't have to memory actions that trigger on the same logs? I think to file should just log to file.
 
magnavox
Member
Member
Topic Author
Posts: 340
Joined: Thu Jun 14, 2007 1:03 pm

Re: Log to file clarification.

Sun Mar 28, 2010 1:19 am

I'm not 100% sure on this, but are you certain that you don't have to memory actions that trigger on the same logs? I think to file should just log to file.
I agree with you.
But setting action to file, I show either file logging and memory logging :(
Try using a firewall rule action log...
Best Regards...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24361
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Log to file clarification.

Mon Mar 29, 2010 10:42 am

like he said, disable your "memory" rules first, then see if it happens
No answer to your question? How to write posts
 
magnavox
Member
Member
Topic Author
Posts: 340
Joined: Thu Jun 14, 2007 1:03 pm

Re: Log to file clarification.

Mon Mar 29, 2010 12:00 pm

like he said, disable your "memory" rules first, then see if it happens
Normis, I not have any memory rules...

My loggin export:
[admin@hotspot] /system logging> export
...
/system logging action
set memory memory-lines=100 memory-stop-on-full=no name=memory target=memory
set disk disk-file-count=2 disk-file-name=log disk-lines-per-file=100 \
    disk-stop-on-full=no name=disk target=disk
set echo name=echo remember=yes target=echo
set remote bsd-syslog=no name=remote remote=10.20.20.1:514 src-address=\
    0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
add disk-file-count=1000 disk-file-name=log1 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action1 target=disk
add disk-file-count=1000 disk-file-name=log2 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action2 target=disk
add disk-file-count=1000 disk-file-name=log3 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action3 target=disk
/system logging
add action=action2 disabled=no prefix=HOTSPOT topics=firewall
And mangle export:
[admin@hotspot] /ip firewall mangle> export
...
/ip firewall mangle
add action=log chain=forward comment="" connection-state=new disabled=no \
    log-prefix=HOTSPOT
The logs are redirected eother on file and on memory.

Where I m wrong?
ROS V4.6
Best Regards...
 
magnavox
Member
Member
Topic Author
Posts: 340
Joined: Thu Jun 14, 2007 1:03 pm

Re: Log to file clarification.

Wed Apr 07, 2010 12:42 am

Hi, anyone can test it?
Best Regards...
 
ManUtd
newbie
Posts: 30
Joined: Sun Sep 16, 2007 10:24 pm

Re: Log to file clarification.

Tue Apr 13, 2010 12:43 am

like he said, disable your "memory" rules first, then see if it happens
Normis, I not have any memory rules...

My loggin export:
[admin@hotspot] /system logging> export
...
/system logging action
set memory memory-lines=100 memory-stop-on-full=no name=memory target=memory
set disk disk-file-count=2 disk-file-name=log disk-lines-per-file=100 \
    disk-stop-on-full=no name=disk target=disk
set echo name=echo remember=yes target=echo
set remote bsd-syslog=no name=remote remote=10.20.20.1:514 src-address=\
    0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
add disk-file-count=1000 disk-file-name=log1 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action1 target=disk
add disk-file-count=1000 disk-file-name=log2 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action2 target=disk
add disk-file-count=1000 disk-file-name=log3 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action3 target=disk
/system logging
add action=action2 disabled=no prefix=HOTSPOT topics=firewall
And mangle export:
[admin@hotspot] /ip firewall mangle> export
...
/ip firewall mangle
add action=log chain=forward comment="" connection-state=new disabled=no \
    log-prefix=HOTSPOT
The logs are redirected eother on file and on memory.

Where I m wrong?
ROS V4.6
Same thing on my RB1000@ROS 4.6...any solution ?

Who is online

Users browsing this forum: mauricioisp, sid5632 and 94 guests