Page 1 of 1

Log to file clarification.

Posted: Sat Mar 27, 2010 3:30 pm
by magnavox
Enabling log to file (action=disk) the ROS show log also in log viewer.. this is correct?
It's possible to log to file without fill log memory?

Tnx in advance.

Re: Log to file clarification.

Posted: Sat Mar 27, 2010 6:00 pm
by fewi
I'm not 100% sure on this, but are you certain that you don't have to memory actions that trigger on the same logs? I think to file should just log to file.

Re: Log to file clarification.

Posted: Sun Mar 28, 2010 1:19 am
by magnavox
I'm not 100% sure on this, but are you certain that you don't have to memory actions that trigger on the same logs? I think to file should just log to file.
I agree with you.
But setting action to file, I show either file logging and memory logging :(
Try using a firewall rule action log...

Re: Log to file clarification.

Posted: Mon Mar 29, 2010 10:42 am
by normis
like he said, disable your "memory" rules first, then see if it happens

Re: Log to file clarification.

Posted: Mon Mar 29, 2010 12:00 pm
by magnavox
like he said, disable your "memory" rules first, then see if it happens
Normis, I not have any memory rules...

My loggin export:
[admin@hotspot] /system logging> export
...
/system logging action
set memory memory-lines=100 memory-stop-on-full=no name=memory target=memory
set disk disk-file-count=2 disk-file-name=log disk-lines-per-file=100 \
    disk-stop-on-full=no name=disk target=disk
set echo name=echo remember=yes target=echo
set remote bsd-syslog=no name=remote remote=10.20.20.1:514 src-address=\
    0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
add disk-file-count=1000 disk-file-name=log1 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action1 target=disk
add disk-file-count=1000 disk-file-name=log2 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action2 target=disk
add disk-file-count=1000 disk-file-name=log3 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action3 target=disk
/system logging
add action=action2 disabled=no prefix=HOTSPOT topics=firewall
And mangle export:
[admin@hotspot] /ip firewall mangle> export
...
/ip firewall mangle
add action=log chain=forward comment="" connection-state=new disabled=no \
    log-prefix=HOTSPOT
The logs are redirected eother on file and on memory.

Where I m wrong?
ROS V4.6

Re: Log to file clarification.

Posted: Wed Apr 07, 2010 12:42 am
by magnavox
Hi, anyone can test it?

Re: Log to file clarification.

Posted: Tue Apr 13, 2010 12:43 am
by ManUtd
like he said, disable your "memory" rules first, then see if it happens
Normis, I not have any memory rules...

My loggin export:
[admin@hotspot] /system logging> export
...
/system logging action
set memory memory-lines=100 memory-stop-on-full=no name=memory target=memory
set disk disk-file-count=2 disk-file-name=log disk-lines-per-file=100 \
    disk-stop-on-full=no name=disk target=disk
set echo name=echo remember=yes target=echo
set remote bsd-syslog=no name=remote remote=10.20.20.1:514 src-address=\
    0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
add disk-file-count=1000 disk-file-name=log1 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action1 target=disk
add disk-file-count=1000 disk-file-name=log2 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action2 target=disk
add disk-file-count=1000 disk-file-name=log3 disk-lines-per-file=1000 \
    disk-stop-on-full=yes name=action3 target=disk
/system logging
add action=action2 disabled=no prefix=HOTSPOT topics=firewall
And mangle export:
[admin@hotspot] /ip firewall mangle> export
...
/ip firewall mangle
add action=log chain=forward comment="" connection-state=new disabled=no \
    log-prefix=HOTSPOT
The logs are redirected eother on file and on memory.

Where I m wrong?
ROS V4.6
Same thing on my RB1000@ROS 4.6...any solution ?