Community discussions

MUM Europe 2020
 
pkelly1603
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 78
Joined: Mon Jun 15, 2009 11:13 pm

RouterOS file server slow

Tue Apr 20, 2010 6:50 am

Recently I setup an x86 routerOS machine as a file server. This unit downloads routerOS backup files from other routers automatically and stores them. Currently I have 20GB of space available on this machine for storage.

I am currently using about 500MB of this space and the system's CPU rails whenever I click "files" in winbox. After a minute or two the router will start responding again and CPU will go to normal and allow me to view files. We did not have problems with this unit until there were quite a few backup files in it. The system also will lock up sometimes and takes a long time to boot.

Also, the system reports there is plenty of unused memory to spare. I am using ROS v. 4.2. Any idea if there are issues with file storage? Does anyone have any experience with this type of situation? Any help or suggestions would be appreciated.

Thanks!
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS file server slow

Tue Apr 20, 2010 11:28 am

I've been having the exact same problem since I can remember using RouterOS. Also, after some time (random?), scripts that use /file... operations freeze. After reboot this problem sometimes goes away.

I've tried to test the total size, total files, etc... but I haven't found the threshold that causes freezing, or very long retrieval times.
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Re: RouterOS file server slow

Tue Apr 20, 2010 7:46 pm

bad flash. Come on MT, add a disk logging topic please! if a read times out on the media it would be nice to know about it - isn't that already in the kernel?
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS file server slow

Tue Apr 20, 2010 10:37 pm

Disk logging topic would be very handy.

I'm only using x86 with an IDE hard disk. I'm finding really odd behavior though. When I experience the freezing, if I ftp into the router and delete some files, the freezing stops without the need to reboot. Also, there are times when all my disk stores will stop showing any active stores. I'm not sure if this is related though.

I've written some scripts to test file freezes and disk store disappearance. So far, I can't pinpoint anything consistent.

Mikrotik, any help?

Who is online

Users browsing this forum: eworm, Kampfwurst and 126 guests