Community discussions

MikroTik App
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

RouterOS v4.7 released

Thu Apr 22, 2010 8:14 am

What's new in 4.7:

*) fixed problem - wireless packet bridging with nstreme enabled
sometimes was very slow on RB1xx, RB5xx and RB4xx;
*) fixed problem - ipv6 traffic was not bridged if ipv6 package was not enabled;
*) '/user active' now lists type of api connections as 'api'
*) fixed getting interface stats in dude
*) fixed metarouter stability problem on RB400s & RB750s;
*) fixed metarouter - it didn't work on RB1000 with 2Gb;
*) fixed metarouter - it locked up on RB800;
*) fixed problem - SFQ queues did not work on interfaces (wireless) if none
of simple or tree queues were added;
*) fixed RB800 temperature;
*) silentboot feature updated;
*) multicast - fixed possible crash during PIM startup;
*) ospf - changed "/routing ospf route" to show type 2 metric instead of
internal metric for type 2 external routes;
*) report platform name in "/sysrem resource";
*) fixed problem - vlans were not working on RB750 ether1;
*) fixed mac address handling on RB750, some specific arp requests did not work;
*) more than two dns servers allowed in /ip dns;
*) sniffer and torch could process packet from other interfaces;
*) dns cache rotates order of records in reply messages;
*) ospf - fixed DR and BDR election;
http://www.mikrotik.com/download/router ... .7.torrent
No answer to your question? How to write posts
 
User avatar
MCT
Member Candidate
Member Candidate
Posts: 157
Joined: Wed Mar 03, 2010 5:53 pm

Re: RouterOS v4.7 released

Thu Apr 22, 2010 8:30 am

Nice

Has the Router Advertisement bug in the IPv6 package been addressed? I'd love to use routerboards in an IPv6 deployment but I can't until that works reliably.
 
User avatar
omidkosari
Trainer
Trainer
Posts: 634
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: RouterOS v4.7 released

Thu Apr 22, 2010 9:56 am

Any news about
Router crashes when MNDP enabled on EOIP
and
KVM tap interface Packets always drops
?
They were confirmed bugs .
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS v4.7 released

Thu Apr 22, 2010 10:28 am

Any news about
Router crashes when MNDP enabled on EOIP
I too have this problem, however I was unaware the it was a confirmed bug. We need a better way of sharing confirmed bugs with other RouterOS users.
 
AndreaN
just joined
Posts: 17
Joined: Sat Mar 13, 2010 11:55 pm

Re: RouterOS v4.7 released

Thu Apr 22, 2010 12:07 pm

Problem to upgrade to 4.7 version.
I put file-4.7.npk whit winbox or ftp in the routerboard and reboot, but routerboard not upgrade .
I see that in the files list the icon of npk file is not as package, but as a text file ... uhmm... there is a bug?

tnku
 
2jarek
Member Candidate
Member Candidate
Posts: 146
Joined: Thu May 17, 2007 3:28 pm
Location: Poland

Re: RouterOS v4.7 released

Thu Apr 22, 2010 12:33 pm

warning RB433, RB433AH sometimes freezes after software restart need power off/on.
I install only routerboard, system, seciurity, wireless packages.
 
User avatar
Caci99
Forum Guru
Forum Guru
Posts: 1072
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: RouterOS v4.7 released

Thu Apr 22, 2010 1:38 pm

In change log:
"dns cache rotates order of records in reply messages"

What does this mean?
-Toni-
Don't crash the ambulance, whatever you do
 
Ozelo
Member
Member
Posts: 338
Joined: Fri Jun 02, 2006 3:56 am

Re: RouterOS v4.7 released

Thu Apr 22, 2010 1:54 pm

*) fixed problem - SFQ queues did not work on interfaces (wireless) if none
of simple or tree queues were added;
:shock:
MTCRE - 1104RE006
MTCINE - 1104INE001
 
User avatar
mandrade
Member Candidate
Member Candidate
Posts: 106
Joined: Fri Sep 08, 2006 12:35 pm
Location: Brazil
Contact:

Re: RouterOS v4.7 released

Thu Apr 22, 2010 3:49 pm

*) fixed problem - wireless packet bridging with nstreme enabled
sometimes was very slow on RB1xx, RB5xx and RB4xx;
:shock: Anyone has tested this?????????? :shock:

BR
 
User avatar
bysard
Member Candidate
Member Candidate
Posts: 295
Joined: Thu Apr 22, 2010 2:53 pm

Re: RouterOS v4.7 released

Thu Apr 22, 2010 4:35 pm

*) fixed problem - wireless packet bridging with nstreme enabled
sometimes was very slow on RB1xx, RB5xx and RB4xx;
:shock: Anyone has tested this?????????? :shock:

BR
Upgraded to 4.7 today. Still the same problem with nstreme for me. As soon as i turn it on client connects then after i start any data transfer it immediatelly disconnects saying: "Extensive data loss". When i turn nstreme off it works perfectly and when i use bandwidth test it says my connection has 43mbit/s tcp/ip full duplex throughput.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8394
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: RouterOS v4.7 released

Thu Apr 22, 2010 4:42 pm

In change log:
"dns cache rotates order of records in reply messages"

What does this mean?
Round-Robin =) if cached request has multiple A records, they are rotated for each response

p.s. what is 'silentboot'?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
xins
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Tue Jun 16, 2009 9:36 pm
Location: Poland, Rzeszów

Re: RouterOS v4.7 released

Thu Apr 22, 2010 9:10 pm

In change log:
"dns cache rotates order of records in reply messages"

What does this mean?
Round-Robin =) if cached request has multiple A records, they are rotated for each response

p.s. what is 'silentboot'?..
no bip bip on booting :D
Im so small
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8394
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: RouterOS v4.7 released

Thu Apr 22, 2010 11:50 pm

:D

how do I manage it? ))
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Fri Apr 23, 2010 11:55 am

that no "bip bip" could be removed for quite some time now.

here is the wiki description of what is Silent boot on RouterBOARD
http://wiki.mikrotik.com/wiki/Silent_boot

in short - you can turn off any output that RouterBOARD made when it booted up, no bios output, no booting messages no sounds, of course, if configured.
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Fri Apr 23, 2010 12:27 pm

*) fixed problem - SFQ queues did not work on interfaces (wireless
How did you allow this bug to happen?

What do I tell all the people that upgraded to 4.6?

What do I tell all their customers?

I will tell them "well these guys from Latvia sqrewed the Wireless packet queues up and so the service was worse, but now it's OK its fixed now"

And what do I tell all the people that tell me to use an older version because it is a "known stable" ? I don't want to use old versions. They are missing stuff.

Life is cruel.
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Fri Apr 23, 2010 12:31 pm

this bug was present in all v4 versions, it's now identified and fixed, and should solve many wireless issues.
No answer to your question? How to write posts
 
vmp
just joined
Posts: 3
Joined: Fri Apr 23, 2010 12:50 pm
Location: Finland

Re: RouterOS v4.7 released

Fri Apr 23, 2010 12:54 pm

FYI: the package http://download.mikrotik.com/routeros-mipsbe-4.7.npk is corrupted, however a copy from Sweden http://www.mikrotik.se/download/routeros-mipsbe-4.7.npk is all good.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Fri Apr 23, 2010 12:55 pm

What I posted above is the SHA/MD5 checksums from inside the download.mikrotik.com server, and as you can see, the files are completely normal.
No answer to your question? How to write posts
 
vmp
just joined
Posts: 3
Joined: Fri Apr 23, 2010 12:50 pm
Location: Finland

Re: RouterOS v4.7 released

Fri Apr 23, 2010 12:59 pm

$ md5 rou*
MD5 (routeros-mipsbe-4.7.npk-SE) = deee0b3e510e64d243be4804eea18122
MD5 (routeros-mipsbe-4.7.npk-US) = 3ca3a781721afe853c91e014da353ae9
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Fri Apr 23, 2010 1:18 pm

This is taken from the serverside (download.mikrotik.com)
[***@download.mikrotik.com html]$ sha1sum -b routeros-powerpc-4.7.npk
cd3eeb14db2ef5d2f101fd7e851cd7ab6d9e3bee *routeros-powerpc-4.7.npk

[***@download.mikrotik.com html]$ md5sum routeros-powerpc-4.7.npk
35607f4c9622b1d5aba494d73e8aeca5 routeros-powerpc-4.7.npk
So your download is broken, or you have a broken package in one of your proxy servers
No answer to your question? How to write posts
 
vmp
just joined
Posts: 3
Joined: Fri Apr 23, 2010 12:50 pm
Location: Finland

Re: RouterOS v4.7 released

Fri Apr 23, 2010 1:24 pm

Direct download with wget (tried also web browser), no proxies, multiple attempts. The file size is exactly the same but md5 gives mismatch.

Hey but I got valid stuff from Sweden so I'm a happy camper. Thanks for a great release! :)
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Fri Apr 23, 2010 1:25 pm

very very strange. we can try to remove them and re-upload, although on the servers, the files are identical on all mirrors based on checksum. No idea what's going on.

Always use Torrents :)
No answer to your question? How to write posts
 
User avatar
mandrade
Member Candidate
Member Candidate
Posts: 106
Joined: Fri Sep 08, 2006 12:35 pm
Location: Brazil
Contact:

Re: RouterOS v4.7 released

Fri Apr 23, 2010 3:58 pm

*) fixed problem - wireless packet bridging with nstreme enabled
sometimes was very slow on RB1xx, RB5xx and RB4xx;
:shock: Anyone has tested this?????????? :shock:

BR
Upgraded to 4.7 today. Still the same problem with nstreme for me. As soon as i turn it on client connects then after i start any data transfer it immediatelly disconnects saying: "Extensive data loss". When i turn nstreme off it works perfectly and when i use bandwidth test it says my connection has 43mbit/s tcp/ip full duplex throughput.

Are you in bridge mode?????

BR
 
User avatar
guilhermeramires
Trainer
Trainer
Posts: 56
Joined: Fri Jan 22, 2010 9:06 pm

Re: RouterOS v4.7 released

Fri Apr 23, 2010 4:08 pm

I have 2 problems with the new version. The first one is the DHCP-SERVER. It becomes "inactive" after some minutes and the only way to fix this is rebooting the router. The second is the DNS. Static entries and cache just gone and after some minutes the cpu reachs 100%. Once again the only way to fix this is rebooting the router. I just downgraded to 4.6 version and now is working fine.
Mikrotik Training Partner
MPLS for the Masses
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Fri Apr 23, 2010 4:09 pm

this bug was present in all v4 versions, it's now identified and fixed, and should solve many wireless issues.
I want the head developer to come to the MUM and say to everyone "I take full responsibility for all past present and future bugs and I and my team will fix them".

P.S. And the devs' employer(s) should come out and state "I take full responsibility for running the biz the way it is and for not letting the bugs be discovered sooner or prevented. And I will put systems in place to address these issues."
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
uldis
MikroTik Support
MikroTik Support
Posts: 3439
Joined: Mon May 31, 2004 2:55 pm

Re: RouterOS v4.7 released

Fri Apr 23, 2010 6:21 pm

Note! The recently released RouterOS v4.7 contained an uncommon DHCP server problem in some non standard installations, until a fix can be provided, you can use RouterOS v4.6
 
mindragon
newbie
Posts: 28
Joined: Tue Apr 20, 2010 5:50 pm

Re: RouterOS v4.7 released

Fri Apr 23, 2010 8:36 pm

4.7 on an RB1000 with a 300 node IPSEC / OSPF VPN also causes an immediate 100% CPU pegging and ultimately crashes.

I see it has been pulled from the main site already.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8394
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: RouterOS v4.7 released

Fri Apr 23, 2010 10:32 pm

uncommon DHCP server problem in some non standard installations
any details please?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
horizn
just joined
Posts: 15
Joined: Fri Mar 19, 2010 1:16 pm
Location: Poland

Re: RouterOS v4.7 released

Fri Apr 23, 2010 11:59 pm

is that
*) updated drivers and kernel (to linux-2.6.32.5);
taken from changelog of v5.0beta1 is included in 4.7?
 
void
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Fri Nov 07, 2008 5:28 pm

Re: RouterOS v4.7 released

Sat Apr 24, 2010 12:09 am

4.7 is removed from the site it seems ?
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS v4.7 released

Sat Apr 24, 2010 5:53 am

Darn, I just upgraded. Should I downgrade? Is my ISO corrupted?
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Sat Apr 24, 2010 11:40 pm

Was it because this DHCP problem? All v4.7 that I upgraded are working. No complaints so far :) Whats so special about that DHCP condition ? :)
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS v4.7 released

Sat Apr 24, 2010 11:49 pm

Was it because this DHCP problem? All v4.7 that I upgraded are working. No complaints so far :) Whats so special about that DHCP condition ? :)
Wondering the same myself. I'm not seeing any dhcp problems on v4.7 at all.
 
axiang
newbie
Posts: 36
Joined: Sun Apr 25, 2010 7:38 am

Re: RouterOS v4.7 released

Sun Apr 25, 2010 7:48 am

Found V4.7 DNS needs to be improved
winbox dns cache show incomplete
terminal modification / ip dns additional IP DNS service will be lost
Forgive me for using the translation in the hope that someone can read google
我是中国人
 
rodneal
Member Candidate
Member Candidate
Posts: 223
Joined: Mon Mar 12, 2007 7:49 pm

Re: RouterOS v4.7 released

Mon Apr 26, 2010 6:39 am

Hey All,
Been awhile since I last put my observations but here goes:
1. Interfaces crash when editing still
2. My Nics (Ethernet ports) died - DIED - when upgraded to v4.7 - could be brought back to life if logged in via wireless and disabled and re-enabled - luckily I could get to most systems and do this remotely. Here is the weird part: it only had to be done on one side of the ethernet connection. Go figure.
3. The 2.4ghz cpe to AP connections were the fastest I have ever seen - it WAS great - past tense being I just finished downgrading the entire network to v3.30 which is not the fastest but definitely the most stable.
4. It Definitely runs better on the lessor legacy boards then any previous v4.+ version and some v3.+ too - although v3.30 seems to do an all around good job on all boards. I had it on an old RB112 and it kicked ass once we reset the eth ports. What a damn tease. If this where a woman - I throw her in the river and drive away to teach her a lesson!

We tried v5.0beta. It seemed stable but we didn't test it extensively.
Would love to have that speed though - v4.7 rocks when it works right.

Good luck All,
Rod

PS - Still have had no luck with 900mhz in any version but 3.28 and 3.30
Last edited by rodneal on Mon Apr 26, 2010 9:01 am, edited 1 time in total.
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Mon Apr 26, 2010 7:42 am

rodneal, what platform was that?

I had problems only with v5b1 x86 Intel NIC

and v4.7 x86 and mipsbe I had no problems so far..
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Mon Apr 26, 2010 8:05 am

Found V4.7 DNS needs to be improved
winbox dns cache show incomplete
terminal modification / ip dns additional IP DNS service will be lost
Forgive me for using the translation in the hope that someone can read google
Maybe you can export a supout.rif and send to support@mikrotik.com ? And maybe you could be so kind as to give us here in the forum a screenshot?

THanks.

P.S. Good Morning Latvia :) Where are my MikroTik-ians ? :) Help is needed here. Clarity is needed! :)


P.S. 2 I found a little clarity here : OS 4.7 DHCP topic http://forum.mikrotik.com/viewtopic.php?f=2&t=41129
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS v4.7 released

Mon Apr 26, 2010 8:30 am

Found V4.7 DNS needs to be improved
winbox dns cache show incomplete
terminal modification / ip dns additional IP DNS service will be lost
Forgive me for using the translation in the hope that someone can read google
RouterOS v4.7 x86:

Winbox /ip dns cache is blank, but terminal print works ok.
You do not have the required permissions to view the files attached to this post.
 
rodneal
Member Candidate
Member Candidate
Posts: 223
Joined: Mon Mar 12, 2007 7:49 pm

Re: RouterOS v4.7 released

Mon Apr 26, 2010 8:44 am

Hey Pro

The primary problems were RB433's - you'd think that would be last board I'd have the problem with. But all the RB's had to be reset before powering down.

Rod
 
User avatar
omidkosari
Trainer
Trainer
Posts: 634
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: RouterOS v4.7 released

Mon Apr 26, 2010 9:15 am

What's new in 4.7:
*) '/user active' now lists type of api connections as 'api'
Incorrect . it shows 'unknown'
User List.PNG
You do not have the required permissions to view the files attached to this post.
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS v4.7 released

Mon Apr 26, 2010 9:18 am

What's new in 4.7:
*) '/user active' now lists type of api connections as 'api'
Incorrect . it shows 'unknown'[/attachment]
Darn. I requested this fix too.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Mon Apr 26, 2010 9:19 am

yes, in winbox they appear as unknown. It is working in CLI. Winbox will display correct type in future releases.
 
Steve0
newbie
Posts: 37
Joined: Mon Feb 08, 2010 8:34 pm
Location: Somewhere between the Bit and the Byte

Re: RouterOS v4.7 released

Mon Apr 26, 2010 12:19 pm

RouterOS 4.7 working on my RB450G with no problems. As matter of fact my only problem (ROS 4.6) with the "Torch bug" is fixed. For all of you with problems/complaints, here is a quote from another forum:
I haven't found any piece of IP equipment without it's problems in all the years I worked with it. Even $500k Cisco routers had bugs with stuff as simple as DHCP or ARP.
Note: $500k ?
I don't think Half-a-Million is what poster meant. :)
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Mon Apr 26, 2010 12:20 pm

it's quite easy to get mentioned brand routers for that price. depends on what you need.

one of the reasons why RouterOS is still the best :)
No answer to your question? How to write posts
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Mon Apr 26, 2010 12:21 pm

Im not paying half a mil for little metal. Maybe if it can teleport packets to China. And it could then teleport Packages back :P :lol:
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
Steve0
newbie
Posts: 37
Joined: Mon Feb 08, 2010 8:34 pm
Location: Somewhere between the Bit and the Byte

Re: RouterOS v4.7 released

Mon Apr 26, 2010 12:33 pm

it's quite easy to get mentioned brand routers for that price. depends on what you need.

one of the reasons why RouterOS is still the best :)

Exactly, ~$100 routers with the support that goes on here, Well worth the occasional bug... :)

But... bashing will... and, does happen. :(
 
ste
Forum Guru
Forum Guru
Posts: 1837
Joined: Sun Feb 13, 2005 11:21 pm

Re: RouterOS v4.7 released

Mon Apr 26, 2010 2:23 pm

it's quite easy to get mentioned brand routers for that price. depends on what you need.

one of the reasons why RouterOS is still the best :)

Exactly, ~$100 routers with the support that goes on here, Well worth the occasional bug... :)

But... bashing will... and, does happen. :(
Ok shit happens. But there are Bugs which look like there is not enough
effort put into Quality control. And with bugs as the SFQ not working
until 4.7 you can drive admins crazy. Following the 11n thread you see
there is no one at MT who cares enough to make it work flawless.
It needs Users like exe to do the work for MT to get it running at a
basic level (usable for ptp now with some tweaks).

So there is a difference between bashing and asking for careful work.

I have to update 200 Clients as they are running 4.5. So it's not about
100$, its a lot of my time I have to invest. I have waited until 4.5 to
upgrade some of my clients from 3.30. The time was not enough.

My wish is that there are less versions with more testing. Who needs a
V5 Beta before V4 is nearly bugfree and 11n is running fine.
 
void
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Fri Nov 07, 2008 5:28 pm

Re: RouterOS v4.7 released

Mon Apr 26, 2010 2:33 pm

MT should be more open concerning changes/fixes they do in every version and put a list of known issues on their website.

It's not a shame to have bugs in your software, everyone has them. But it's frustrating that everyone needs to hit a bug and waste a lot of time troubleshooting while it's most of the time a known issue.

There is nothing in the release notes about DHCP but something has changed since it's doesn't work anymore in 'non-standard installations'. MT doesn't even bother to tell us what they mean with 'non-standard'. That's a shame.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Mon Apr 26, 2010 2:35 pm

did you not see that we took off the v4.7 download as soon as we discovered a minor known bug? we don't have any other known bugs, except those that are reported after version build.
No answer to your question? How to write posts
 
duvi
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Fri Jun 05, 2009 12:32 pm
Contact:

Re: RouterOS v4.7 released

Mon Apr 26, 2010 2:41 pm

did you not see that we took off the v4.7 download as soon as we discovered a minor known bug? we don't have any other known bugs, except those that are reported after version build.
Not quite true, you still released v4.7 with winbox vap bug still in it, which was known for two months now.
 
User avatar
congo
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Jul 30, 2008 12:40 am
Location: Hungary

Re: RouterOS v4.7 released

Mon Apr 26, 2010 3:07 pm

This SFQ bug is veeery interesting. Could be the cause of our several months torture with our office access point. I hope v4.8 will be out soon.
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Mon Apr 26, 2010 8:20 pm

You could try 3.30 pal.
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
rodneal
Member Candidate
Member Candidate
Posts: 223
Joined: Mon Mar 12, 2007 7:49 pm

Re: RouterOS v4.7 released

Mon Apr 26, 2010 9:52 pm

Still the best system around - hell even Motorola has a buggy mesh and that's been a problem for 2 years - of course there are work a rounds to that too but it is still there.

MT rocks and is still the best out there for my money!

As long as I keep every known version on archive and the strengths and weaknesses on file then I know what to use. Used to have the same problem with Cisco until I dumped every router in our network to go to Siemens GUI driven Systems. Had problems there too but had direct line to their R&D and could talk to them 24/7. This would be the only problem that I would have with MT but being that I have all the Previous versions - I'm not stuck and downgrade is simple and easy.

Right now v3.30 is the most stable except for 900mhz and that is v3.28. Have no clue why but it works.

Good luck,
Rod
 
ste
Forum Guru
Forum Guru
Posts: 1837
Joined: Sun Feb 13, 2005 11:21 pm

Re: RouterOS v4.7 released

Mon Apr 26, 2010 10:21 pm

Still the best system around - hell even Motorola has a buggy mesh and that's been a problem for 2 years - of course there are work a rounds to that too but it is still there.

MT rocks and is still the best out there for my money!

As long as I keep every known version on archive and the strengths and weaknesses on file then I know what to use. Used to have the same problem with Cisco until I dumped every router in our network to go to Siemens GUI driven Systems. Had problems there too but had direct line to their R&D and could talk to them 24/7. This would be the only problem that I would have with MT but being that I have all the Previous versions - I'm not stuck and downgrade is simple and easy.

Right now v3.30 is the most stable except for 900mhz and that is v3.28. Have no clue why but it works.

Good luck,
Rod
Full ack. With MT I get a lot for my money. But as a typical user I want to get more :D
We use 3.30 on all Backbone systems. This works perfect.
But as I want to move to 11n I cant stay with 3.30. Actually we decided to use R52n in all
new clients. These run normal 11a at the moment until APs are upgraded. We dont want
to install clients which we have to upgrade soon.
 
void
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Fri Nov 07, 2008 5:28 pm

Re: RouterOS v4.7 released

Mon Apr 26, 2010 11:22 pm

did you not see that we took off the v4.7 download as soon as we discovered a minor known bug? we don't have any other known bugs, except those that are reported after version build.
Normis, that's exactly what I'm trying to explain. If you are going to take every release off-line due to a minor bug you will never release a new version again I guess ;)

If you would communicate more clearly under which circumstances the problem occurs the end users (we) can decide if this problem affects our network and if we think upgrading is appropriate or not.

The fact that there is a bug in DHCP and the changelog doesn't mention anything about DHCP only indicates your are not honest about the changes made.

Don't get me wrong, I like ROS/RB a lot (just ordered some more today :) ) but I would like to see some more open comunication around bugs etc.
 
User avatar
congo
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Jul 30, 2008 12:40 am
Location: Hungary

Re: RouterOS v4.7 released

Tue Apr 27, 2010 12:57 am

You could try 3.30 pal.
I also agree on v3.30 being the best (real) stable version (we have some routers still on 3.19 which was our former standard), but in this particular case we want to use 11n :)

I had some serious headaches because of this RB411AH/4.x/R52n office AP not working properly and now I'm hoping for the best... Testing starts on the day v4.8 is available!
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Tue Apr 27, 2010 1:10 am

I put 10 $ on - it will not be any better. :)
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
congo
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Jul 30, 2008 12:40 am
Location: Hungary

Re: RouterOS v4.7 released

Tue Apr 27, 2010 1:12 am

Oh, and why do you think so? :D
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Tue Apr 27, 2010 1:19 am

Just a general logic from following tendencies. And maybe a bit intuition :)
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
marsark
Member Candidate
Member Candidate
Posts: 138
Joined: Mon Jul 20, 2009 4:02 pm
Location: Prague, Czech Republic

Re: RouterOS v4.7 released

Tue Apr 27, 2010 2:39 am

NO, IPv6 RA bug has been not fixed in ROS 4.7 yet. More can be found here http://forum.mikrotik.com/viewtopic.php?f=2&t=38166
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS v4.7 released

Tue Apr 27, 2010 5:20 am

There's another problem with taking down v4.7.

If you noticed, a lot of features went into 4.7. This means, way more potential for things to break, and maybe harder to find the fix.

Now that v4.8 is on it's way, with very few people testing 4.7 (because it was taken down), there's going to be even more changes. This leaves the potential for bugs very high, which means fixes in 4.7 may be bugs in 4.8.

Just my thoughts. I really hope upgrade to 4.8 is flawless.
Doug
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v4.7 released

Tue Apr 27, 2010 8:38 am

can anyone try if the PPC package still is broken if you download it from download.mikrotik.com? we turned off DNS based load balancing and it seems to have helped most users. The packages were fine, but maybe the download programs got confused :?
No answer to your question? How to write posts
 
Muzaki
newbie
Posts: 43
Joined: Wed May 13, 2009 3:12 pm
Contact:

Re: RouterOS v4.7 released

Tue Apr 27, 2010 3:04 pm

ether1 stops working after about 30sek with 4.7 on RB433 , RB 532 and RB 133.

OK after enable / disable or phisical unplug / replug :?
 
andreacoppini
Trainer
Trainer
Posts: 489
Joined: Wed Apr 13, 2005 11:51 pm
Location: Malta, Europe

Re: RouterOS v4.7 released

Tue Apr 27, 2010 5:26 pm

Having massive problems with hotspot and DNS on 4.7... DNS server stops responding after a while for no apparent reason, DNS client works fine.

No response from MT support as yet.

Downgrading to 4.6.. will see.

I agree 3.30 is the best version so far, but I'm running 750G so cannot downgrade that far, and MT is stubborn enough not to put 3.31 (the one supplied with the 750) on their website and insist users must upgrade to 4.x, despite all the bugs.
- No strings attached -

<< Please give good Karma if this post helped you. Press the + button above the Location entry
 
rodneal
Member Candidate
Member Candidate
Posts: 223
Joined: Mon Mar 12, 2007 7:49 pm

Re: RouterOS v4.7 released

Tue Apr 27, 2010 8:44 pm

REEAAALLLLYYY! v3.31 not listed is interesting. Didn't know there was was such a critter.
 
User avatar
congo
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Jul 30, 2008 12:40 am
Location: Hungary

Re: RouterOS v4.7 released

Tue Apr 27, 2010 8:58 pm

It seems versions created only for support of a given platform only come with the hardware.
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS v4.7 released

Tue Apr 27, 2010 10:06 pm

Having massive problems with hotspot and DNS on 4.7... DNS server stops responding after a while for no apparent reason, DNS client works fine.

No response from MT support as yet.

Downgrading to 4.6.. will see.
I noticed this also after doing some traffic analysis.

Hotspot users just drop off (still active, no idle or session timeout). When I enable, disable the hotspot interface, it was fine again for some time. What I found was that the client could still get to HTTP using IP address of web sites, but DNS resolution wouldn't work at all. Even telling the client to use an external DNS server didn't work. Torch reported sending DNS traffic out, but no received traffic. When I disable/enable hotspot interface, DNS traffic was both send and received, meaning no firewall rules, or anything interfering in my configuration.
Doug
 
changeip
Forum Guru
Forum Guru
Posts: 3819
Joined: Fri May 28, 2004 5:22 pm

Re: RouterOS v4.7 released

Tue Apr 27, 2010 10:19 pm

My buddy has the same issue... DNS just stops working. He was sick and tired of disabling and reenabling the hotspot so we scheduled this to run every few mins and it seems to have fixed things:

/ip firewall nat remove [/ip firewall nat find chain="hotspot" dst-port="53" ]

Basically just removing the DNS redirect and letting DNS pass. Any reason thats a bad idea?
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v4.7 released

Tue Apr 27, 2010 10:21 pm

I just did this one a router v4.7. I let DNS pass. It was probably brought down by a memory leak or the DNS process has crashed or something. That was a routerboard. I even got a supout this time :)
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
andreacoppini
Trainer
Trainer
Posts: 489
Joined: Wed Apr 13, 2005 11:51 pm
Location: Malta, Europe

Re: RouterOS v4.7 released

Tue Apr 27, 2010 10:21 pm

Doug,

I had the exact same experience. Good to see I'm not going crazy (yet).
REEAAALLLLYYY! v3.31 not listed is interesting. Didn't know there was was such a critter.
Apparently 3.31 is exactly the same as 3.30 but with support for the RB750 (probably just additional drivers)
- No strings attached -

<< Please give good Karma if this post helped you. Press the + button above the Location entry
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: RouterOS v4.7 released

Tue Apr 27, 2010 10:48 pm

My buddy has the same issue... DNS just stops working. He was sick and tired of disabling and reenabling the hotspot so we scheduled this to run every few mins and it seems to have fixed things:

/ip firewall nat remove [/ip firewall nat find chain="hotspot" dst-port="53" ]

Basically just removing the DNS redirect and letting DNS pass. Any reason thats a bad idea?
Not necessarily a bad idea, but hackish. I think it'd be nicer to just make use of the bypass rule just above that:
chain=hotspot action=jump jump-target=pre-hotspot
So just add an accept in that chain so that traffic never gets redirected:
/ip firewall nat add chain=pre-hotspot dst-port=53 action=accept protocol=53
Same effect, no reason to delete dynamically created rules and no need for a scheduled script.

Edit: whoops. Line to add didn't have a protocol and would have bombed.
Last edited by fewi on Tue Apr 27, 2010 11:25 pm, edited 2 times in total.
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: RouterOS v4.7 released

Tue Apr 27, 2010 11:12 pm

So I think it's making more sense now.

I have a wired connection and don't notice any DNS problems at all, (only on Hotspot).
So it looks like a specific issue with the Hotspot DNS service (udp port 64872).

I added this rule:
/ip firewall nat add chain=pre-hotspot action=accept protocol=udp dst-port=53
I should know by tonight if this has an effect.

BTW, thank you to everyone who posted, I will be happy to see this resolved.
Doug
 
eltopia
just joined
Posts: 13
Joined: Mon Jul 21, 2008 11:16 pm

Re: RouterOS v4.7 released

Tue Apr 27, 2010 11:22 pm

did you not see that we took off the v4.7 download as soon as we discovered a minor known bug? we don't have any other known bugs, except those that are reported after version build.
http://forum.mikrotik.com/viewtopic.php?f=2&t=38515 has been around for at least a few months, no updates on the 4.7 changelog either. When do you anticipate this bug being fixed?

Who is online

Users browsing this forum: arkos, sebus, sindy, xvo, ZacharyMak and 177 guests