Community discussions

MikroTik App
 
cata02
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Fri Mar 05, 2010 8:58 am

Upnp

Tue Apr 27, 2010 9:53 pm

Is Upnp supposed to work on 4.6?

i've enabled it, added internal interface, added firewall rules. the mikrotik is discovered ok as an igd but any upnp call to it fail.

running netmon tracing reveals some http not found responses.

running any upnp port forwarding tool fails.
this tool seems mature: http://www.wiseorbit.com/, it fails (emule config fails, vista network check tool fails -- microsoft tool, etc.).

what's going on?
 
cata02
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Fri Mar 05, 2010 8:58 am

Re: Upnp

Tue May 18, 2010 7:59 am

anyone?

i've tested it with 4.6 and 5 beta 2 with no luck.
 
duvi
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Fri Jun 05, 2009 12:32 pm
Contact:

Re: Upnp

Tue May 18, 2010 10:04 am

You should also add external interface.
 
cata02
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Fri Mar 05, 2010 8:58 am

Re: Upnp

Tue May 18, 2010 10:56 am

ok.
wouldn't that be required only for disabling the internet connection?
 
duvi
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Fri Jun 05, 2009 12:32 pm
Contact:

Re: Upnp

Tue May 18, 2010 12:54 pm

Don't know, I never enable "Allow to disable internet connection".
[admin@MikroTik] > /ip upnp export
/ip upnp
set allow-disable-external-interface=no enabled=yes show-dummy-rule=yes
/ip upnp interfaces
add disabled=no interface=ADSL type=external
add disabled=no interface=bridge-private type=internal
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6045
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Upnp

Tue May 18, 2010 1:00 pm

Yes, you have to add also external interface otherwise UPNP will not work.
 
cata02
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Fri Mar 05, 2010 8:58 am

Re: Upnp

Tue May 18, 2010 10:40 pm

seems to work now.

i've added the external interface.

will test more.

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], HakanE, msatter, Onigma and 133 guests