Community discussions

MUM Europe 2020
 
havaltech
newbie
Topic Author
Posts: 29
Joined: Thu May 28, 2009 8:04 pm

Packet Loss when users taking full bandwidth

Thu May 13, 2010 4:01 pm

Hi Guys,

I have Mikrotik Routerboard1000 we are connected 10 computers with it, each user have limited bandwidth with 256Kbit down and 128Kbit up using simple queues. everything is working fine user have internet and taking their limited bandwidth. the problem when users taking full bandwidth i mean 256Kbit ping to outside even to mikrotik router become worse many packet loss. is there anyway when can make users do not have packet loss even if they used full bandwidth?

P.S.: we have this problem if only one user connected also i mean it is not related to international bandwidth.

Best Regards,

haval
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Packet Loss when users taking full bandwidth

Thu May 13, 2010 4:21 pm

make your queues longer ))) then ping will be higher, but drop should decrease
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
havaltech
newbie
Topic Author
Posts: 29
Joined: Thu May 28, 2009 8:04 pm

Re: Packet Loss when users taking full bandwidth

Thu May 13, 2010 4:32 pm

Dear Chupaka,

what you mean by make your queue longer shall increase the limitation?


Regards,

haval
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Packet Loss when users taking full bandwidth

Thu May 13, 2010 6:20 pm

increase queue length in queue type
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
havaltech
newbie
Topic Author
Posts: 29
Joined: Thu May 28, 2009 8:04 pm

Re: Packet Loss when users taking full bandwidth

Thu May 13, 2010 10:14 pm

Dear Chupaka,

After i increased queue size now ping going higher but there is no packet loss as you said. thank you very much.


Best Regards,

Haval
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Packet Loss when users taking full bandwidth

Fri May 14, 2010 12:11 am

you may also create additional queue for icmp, so that ping be always good and not shaped =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
havaltech
newbie
Topic Author
Posts: 29
Joined: Thu May 28, 2009 8:04 pm

Re: Packet Loss when users taking full bandwidth

Fri May 14, 2010 2:49 am

Dear Chupaka,

How i can creat an additional queue for ICMP?

Regards,

haval
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Packet Loss when users taking full bandwidth

Fri May 14, 2010 3:54 pm

create additional queue, set some routing mark and set this mark to all icmp packets in Mangle...
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
havaltech
newbie
Topic Author
Posts: 29
Joined: Thu May 28, 2009 8:04 pm

Re: Packet Loss when users taking full bandwidth

Fri May 14, 2010 5:52 pm

Dear Chupaka,

After i did below config as you said now when users using their full bandwidth the ping even not going higher will stay at it is normal value. just wanted to share my confing. let me know if something wrong but it is working fine for me.

Mangle
-------

ip firewall mangle add protocol=icmp action=mark-connection new-connection-mark=ICMP-Traffic chain=forward
ip firewall mangle add connection-mark=ICMP-Traffic action=mark-packet new-packet-mark=ICMP chain=forward



Queue Tree
----------

queue tree add name=Download parent=Local-Interface
queue tree add name=Upload parent=global-out

queue tree add name=ICMP-RX parent=Download packet-mark=ICMP max-limit=512K priority=1
queue tree add name=ICMP-TX parent=Upload packet-mark=ICMP max-limit=512k priority=1


Chupaka thanks for your great answers.

Best Regards,

Haval
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Packet Loss when users taking full bandwidth

Fri May 14, 2010 6:20 pm

actually,
/ip firewall mangle add protocol=icmp action=mark-packet new-packet-mark=ICMP chain=forward 
is quite enough

p.s. don't forget about Karma =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
THG
Member
Member
Posts: 472
Joined: Thu Oct 15, 2009 1:05 am

Re: Packet Loss when users taking full bandwidth

Fri May 14, 2010 8:31 pm

Don't forget to do the same thing with ACK packets.
 
User avatar
Equis
Forum Veteran
Forum Veteran
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Re: Packet Loss when users taking full bandwidth

Fri May 14, 2010 9:58 pm

Hello

How do you do a queue with ack packets?

Thanks :-)
 
User avatar
THG
Member
Member
Posts: 472
Joined: Thu Oct 15, 2009 1:05 am

Re: Packet Loss when users taking full bandwidth

Sat May 15, 2010 4:47 pm

I'm lazy, so I've made it simple. I mangle small packets and give it high priority. It's not the best solution, because every small packets will get high priority, e.g. ACK/NACK, ICMP, VOIP etc. Maybe someone else has a better suggestion. :)
 
User avatar
Equis
Forum Veteran
Forum Veteran
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Re: Packet Loss when users taking full bandwidth

Mon May 17, 2010 1:11 am

Hello

Thanks for that

Can you paste fw rule?

Thanks :)
 
User avatar
THG
Member
Member
Posts: 472
Joined: Thu Oct 15, 2009 1:05 am

Re: Packet Loss when users taking full bandwidth

Mon May 17, 2010 2:49 am

Something like these rules.
add chain=forward packet-size=0-128 \
    action=mark-connection new-connection-mark=small-packets passthrough=yes \
    comment="" disabled=no
add chain=forward packet-size=0-128 \
    action=mark-packet new-packet-mark=small-packets passthrough=yes comment="" \
    disabled=no
 
User avatar
Equis
Forum Veteran
Forum Veteran
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Re: Packet Loss when users taking full bandwidth

Mon May 17, 2010 3:20 am

Thanks heap for that

I'll give it a go

:-)
 
soamz
Member
Member
Posts: 429
Joined: Thu Mar 19, 2015 7:19 am

Re: Packet Loss when users taking full bandwidth

Fri Jun 10, 2016 1:51 pm

I have the same issue. Customers PPPoE disconnects when full bandwidth is being used.
or they are experiencing ping cut, means ICMP drop.

So, simply add those 3 rules in terminal ???
add chain=forward packet-size=0-128 \
    action=mark-connection new-connection-mark=small-packets passthrough=yes \
    comment="" disabled=no
add chain=forward packet-size=0-128 \
    action=mark-packet new-packet-mark=small-packets passthrough=yes comment="" \
    disabled=no
/ip firewall mangle add protocol=icmp action=mark-packet new-packet-mark=ICMP chain=forward

Who is online

Users browsing this forum: No registered users and 28 guests