Community discussions

MUM Europe 2020
 
rmichael
Forum Veteran
Forum Veteran
Topic Author
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

NTP package bug (ROS 4.9)

Mon May 24, 2010 3:59 am

ROS 4.9 with ntp package will not sync with windows ntp server (windows 7 pro's w32time; announceflags=5)

After removing ntp package (i.e. ntp client only) routerboard will sync with windows ntp server.

PS.: same deal with v4.5...
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6618
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: NTP package bug (ROS 4.9)

Wed May 26, 2010 1:23 pm

I do not have Windows 7 here to make the same test.
But are you able to sync any other Linux or other OS NTP client to your server?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: NTP package bug (ROS 4.9)

Wed May 26, 2010 3:15 pm

not familiar with windows services too, but you could try to play around with settings on RouterOS NTP client and on your NTP server. As far as i can tell, all NTP client modes (client from ntp package) are working correctly.
 
rmichael
Forum Veteran
Forum Veteran
Topic Author
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: NTP package bug (ROS 4.9)

Wed May 26, 2010 7:26 pm

I do not have Windows 7 here to make the same test.
But are you able to sync any other Linux or other OS NTP client to your server?
The situation is that the Windows 7 server is running unchanged and ntp package will not sync with it but regular ntp client will.

thanks.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6618
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: NTP package bug (ROS 4.9)

Thu May 27, 2010 9:36 am

Yes, I understand that.
Are you able to sync any other device, Linux/Windows to your NTP server?
 
rmichael
Forum Veteran
Forum Veteran
Topic Author
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: NTP package bug (ROS 4.9)

Thu May 27, 2010 10:36 am

Sure, ubuntu 10.4, Nanostation5M 5.1.2 and 5.2, pfsense 1.2.3.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: NTP package bug (ROS 4.9)

Thu May 27, 2010 1:16 pm

and what configuration you have set on NTP client in RouterOS? do you have any RouterOS device that takes time from that server that works with other versions but 4.9?
 
rmichael
Forum Veteran
Forum Veteran
Topic Author
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: NTP package bug (ROS 4.9)

Thu May 27, 2010 9:58 pm

and what configuration you have set on NTP client in RouterOS? do you have any RouterOS device that takes time from that server that works with other versions but 4.9?
As I said all routerboards running 4.5 and 4.9 can connect using default ntp client. ntp package client will not sync. There is not much to configure on ntp package client, just IP of the server and mode (all tested).

There's also nothing in debug log for NTP. This is a new setup and I don't have any other ROS versions on my network currently.
 
bigguns
Member Candidate
Member Candidate
Posts: 238
Joined: Thu Apr 01, 2010 9:03 am

Re: NTP package bug (ROS 4.9)

Fri May 28, 2010 8:37 am

Actually I am having issues where my RB800(v4.9) isn't syncing it's timeclock to the required address. Again nothing in the logs.

Who is online

Users browsing this forum: No registered users and 64 guests