Community discussions

MikroTik App
 
trevorlc1234
just joined
Topic Author
Posts: 19
Joined: Tue May 25, 2010 8:46 am

HELP plz Mikrotik Hotspot bridging issues?

Sun Jun 13, 2010 6:01 am

I have a Mikrotik RB433AH doing the gateway and hotspot service. I have a ubiquity NanostationM2 briding to the hotspot. Off this NSM2 I have a local BulletM2 omni spreading the sig. Example. RB433 (HotSpot) = 10.5.50.1 ---> NSM2 (Station/Bridge) = 10.5.50.10 ------> BulletM2 Omni (AP mode) = 10.5.50.11. When I connect to the BulletM2's SSID and associate to it, I get DHCP of example 10.5.50.234. I can open a webpage and get the hotpsot login, then login and get the internet fine. So I checked in the RB433AH, under hotspot, I can see that it added a active session for a MAC address and also a cookie for a MAC address. Well the MAC is not my laptops MAC address, its the MAC address of Brdige at 10.5.50.10, the NSM2 bridge device. So that the Router is seeing the bridge as the transmitting device and adding a session/cookie for that device and not my laptops MAC. Thinking the bridge is the device to which needs to authenticate to the hotspot. Obviously this will cause problems when a second user connects via this bridge/omni setup and I haven't figured out a way around it. If I connect a second user to the AP, the first user gets logged out and then if both users are trying to surf the net it keeps asking for logins on each users laaptop. If I add a IP bindings, won't that let everyone that connects through that bridge past the login and bypass the hotspot login? Somehow I have to tell the RB433 hotspot to fully allow the bridge and AP to pass traffic to the hotspot, but ensure that the packets still arrive looking like they came from the laptop connecting client, and ignore the MACS of the bridge and AP, thus adding the correct session and cookie for each user connected to that IP and information? Any ideaS? Any help or ideas would be great.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: HELP plz Mikrotik Hotspot bridging issues?

Sun Jun 13, 2010 1:44 pm

I'm not a Nanostation expert, but you should be able to allow more users to login while you figure out the rest.
/ip hotspot
print detail
set X addresses-per-mac=256

Not a fix, just a patch.
 
avolve
just joined
Posts: 10
Joined: Sat Jun 09, 2007 5:26 am

Re: HELP plz Mikrotik Hotspot bridging issues?

Sun Jun 13, 2010 6:04 pm

If you can , put the AP in WDS mode.
 
trevorlc1234
just joined
Topic Author
Posts: 19
Joined: Tue May 25, 2010 8:46 am

Re: HELP plz Mikrotik Hotspot bridging issues?

Thu Jun 17, 2010 6:22 am

Hi,

Should the AP be in WDS or the bridge into WDS mode? I would think the bridge, but again I am confused as to what the hotspot will see and auth as per MAC. It goes, Laptop Clients <--wireless--> BulletM2 Omni (AP mode) = 10.5.50.11 <--wired--> NSM2 (Station/Bridge) = 10.5.50.10 <--wireless--> RB433 (HotSpot) = 10.5.50.1 <--wired--> Internet.

Anyone work with Nanostation WDS to a Mikrotik hotspot? I tried it but could not get it to work. I'll have to keep looking for a howto.

Who is online

Users browsing this forum: hanzel619, m86895, rioven and 126 guests