Community discussions

 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24276
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

RouterOS v5 beta4 released

Wed Jun 30, 2010 9:12 am


What's new in 5.0beta4 (2010-Jun-29 15:48):

*) console - /ping command again returns number of ping responses received,
didn't work in 5.0beta3;
*) added ability to monitor each cpu core usage;
*) added support for SATA,SCSI & USB CD-ROMs in CD installer;
*) fixed problem - IRQ balancer did not use correct CPU core
on non auto MSI irqs after reboot;
*) fixed memory leak;
*) route - new property 'vrf-interface' (for static and dhcp routes),
automatically updates 'routing-mark' of the route to keep it in the same
VRF as the specified interface;
Torrent: http://www.mikrotik.com/download/router ... a4.torrent
HTTP download: http://www.mikrotik.com/download.html
No answer to your question? How to write posts
 
avantwireless
Member Candidate
Member Candidate
Posts: 137
Joined: Mon Nov 07, 2005 3:04 am

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 9:27 am

snmp voltage still broken... :(
 
PietRetief
newbie
Posts: 34
Joined: Thu Mar 19, 2009 10:58 am

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 9:33 am

*) console - /ping command again returns number of ping responses received,
didn't work in 5.0beta3;
Thank you very much :D
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 10:18 am

*) added ability to monitor each cpu core usage;
*) fixed problem - IRQ balancer did not use correct CPU core
on non auto MSI irqs after reboot;
Thanks - boosted my 4core core routers throughput 2.5x, by manually assign interfaces to cores
And now with "/system resources cpu" menu, "/system resources irq" menu makes much more sense.

I also noticed that number of interrupts goes to 0 as soon as interface reaches some certain speed.
It looks like Linux Kernel enable NAPI: http://en.wikipedia.org/wiki/New_API. So on high speed routers i suggest to assign IRQs manually
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
benwheway
just joined
Posts: 13
Joined: Mon Jun 07, 2010 3:53 pm

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 3:09 pm

Hi, Just some feedback

We have a Dell R610 with SAS, but unfortunatly RouterOs doesnt have drivers for this server as yet.
We can work around using flash memory as the hard drive.

Thanks
 
User avatar
leoktv
Trainer
Trainer
Posts: 140
Joined: Thu Dec 01, 2005 1:39 pm
Location: sweden
Contact:

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 5:34 pm

HI all
works 100% on my new quad core router with 10eth running.
Nice with the cpu and irq meny thanks MikroTik
_________________
Leo De Geer, Mikrotik Certified Consultant/Trainer #TR0003, MTCNA, MTCRE, MTCWE, MTCTCE, MTCINE, MTCUME, MTCIPv6E MTCSE MTCASE & MikroTik Distributor
http://www.mikrotik.se
support[at]mikrotik.se
Office: +46 325 660 650
 
roadracer96
Forum Veteran
Forum Veteran
Posts: 714
Joined: Tue Aug 25, 2009 12:01 am

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 6:02 pm

Upgraded about 30 RB450g/RB433AH/RB493AH and my RB1000 to b4 today. So far, memory leak seems to be plugged.
 
rpress
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu May 07, 2009 5:13 am

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 7:14 pm

Opening up an IPv6 route closes my WinBox. This was on a clean install, rb750. I can add/edit routes using terminal just fine.

Memory leak looks fixed so far. I noticed weirdness where an aborted PPTP client session would not delete the IP address and then it couldn't reconnect because the old address was still there.

Making good progress though! :) I will be very happy to see more services available via IPv6.
 
roadracer96
Forum Veteran
Forum Veteran
Posts: 714
Joined: Tue Aug 25, 2009 12:01 am

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 7:35 pm


Memory leak looks fixed so far. I noticed weirdness where an aborted PPTP client session would not delete the IP address and then it couldn't reconnect because the old address was still there.
Thats been there for a long time with any PPP connection, even on PPPOE from time to time.

I run this script every minute to combat it.

/ip address remove [/ip address find where invalid]
 
axiang
newbie
Posts: 36
Joined: Sun Apr 25, 2010 7:38 am

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 7:55 pm

Boot hard drive slow boot about 1 minute and 20 seconds after the card to Newsletter
Also went on the Intel Gigabit NIC do not know whether the drive to improve. .
Before 4.x-5.x has been packet loss network communication failure I can not modify the network card auto-negotiation state or disabled may be able to return to work after the opening of hope to solve
01:58:05 system,info router rebooted
01:59:24 system,info,account user admin logged in via winbox
You do not have the required permissions to view the files attached to this post.
我是中国人
 
vacarosie200
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sun Jun 15, 2008 11:49 am
Location: Romania

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 10:54 pm

on x86 wireless wan por,t winbox disconect ... no more then 60 second conection ... on ethernet all ok , that was also an isue on beta 3 ...
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: RouterOS v5 beta4 released

Wed Jun 30, 2010 11:23 pm

all ok on x86 but tourch dont chow port just dst and src address
If i dont No Ask someone That Does!
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5 beta4 released

Thu Jul 01, 2010 10:51 am

So far working good on RB450G with User Manager and RB750 in bridge mode. Thanks MikroTik Guys for the better WinBox ! Keep up the good work :)
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
gbh
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Mon Dec 08, 2008 1:05 am

Re: RouterOS v5 beta4 released

Thu Jul 01, 2010 11:04 am

no issues here yet on my 433uah, too afraid to try it on my 450's after the last beta...
will see how it goes.
 
mars
Member Candidate
Member Candidate
Posts: 228
Joined: Sun Mar 14, 2010 1:43 pm

Re: RouterOS v5 beta4 released

Thu Jul 01, 2010 5:54 pm

HI all
works 100% on my new quad core router with 10eth running.
Nice with the cpu and irq meny thanks MikroTik
are you using a pc as a router if so
which pci cards are you using in the computer and how many wireless cards are on it
i am trying to work out if 1 pci slot has enough power for 4 R52hn cards
thanks
 
roadracer96
Forum Veteran
Forum Veteran
Posts: 714
Joined: Tue Aug 25, 2009 12:01 am

Re: RouterOS v5 beta4 released

Thu Jul 01, 2010 7:04 pm

Got about 50 400 series units upgraded and running SSTP to my RB1000 on 5.0b4. So far so good. For my purposes at least.
 
User avatar
leoktv
Trainer
Trainer
Posts: 140
Joined: Thu Dec 01, 2005 1:39 pm
Location: sweden
Contact:

Re: RouterOS v5 beta4 released

Thu Jul 01, 2010 7:48 pm

HI all
works 100% on my new quad core router with 10eth running.
Nice with the cpu and irq meny thanks MikroTik
are you using a pc as a router if so
which pci cards are you using in the computer and how many wireless cards are on it
i am trying to work out if 1 pci slot has enough power for 4 R52hn cards
thanks
I'm using a x86 berabone 1U router HW that are having 10 ethernet direct on the motherboard.
_________________
Leo De Geer, Mikrotik Certified Consultant/Trainer #TR0003, MTCNA, MTCRE, MTCWE, MTCTCE, MTCINE, MTCUME, MTCIPv6E MTCSE MTCASE & MikroTik Distributor
http://www.mikrotik.se
support[at]mikrotik.se
Office: +46 325 660 650
 
wwalcher
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Tue Jun 01, 2004 9:08 am
Contact:

Re: RouterOS v5 beta4 released

Fri Jul 02, 2010 6:05 pm

Has anyone tested N in 10mhz and 5mhz channel sizes? I am interested in deploying it in a PTMP AP scenario.
 
roadracer96
Forum Veteran
Forum Veteran
Posts: 714
Joined: Tue Aug 25, 2009 12:01 am

Re: RouterOS v5 beta4 released

Mon Jul 05, 2010 8:55 am

110 SSTP connections to a RB1000 on 5.0b4 w/ client/server certificate verification, 5 connections local, CHAP authentication, 105 connections RADIUS CHAP authentication, 2048 bit certs w/ the following remote HW:

2x RB433
9x RB433AH
91x RB450G
8x RB493AH

30ish running hotspot, 106 running w/ non-caching proxy.

So far, so good. Disabled OpenVPN now. Hoping to NOT have random crashes on the 1000 that I was having before.

Still looking to find out what level/cipher of encryption SSTP uses. Anyone?
 
mangust
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Jun 14, 2007 11:14 am

Re: RouterOS v5 beta4 released

Tue Jul 06, 2010 12:35 pm

Then I Try to make ssh from router (5B4) - I see next "debug" :

client version: SSH-2.0-OpenSSH_4.3p2 Debian-9etch2
transport state: 0 --> 1
kex algo: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-he
llman-group1-sha1
host key algo: ssh-rsa,ssh-dss
enc algo CS: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,ar
cfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes2
56-ctr
enc algo SC: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,ar
cfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes2
56-ctr
mac algo CS: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha
1-96,hmac-md5-96
mac algo SC: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha
1-96,hmac-md5-96
comp algo CS: none,zlib@openssh.com
comp algo SC: none,zlib@openssh.com
lang CS:
lang SC:
packet follows: 0
agreed on: diffie-hellman-group-exchange-sha1
agreed on: aes192-cbc
agreed on: aes192-cbc
agreed on: hmac-sha1
agreed on: hmac-sha1
agreed on: none
agreed on: none
died with signal 11 on Tue Jul 6 09:29:08 2010

With ROS 4.10 - all OK.

Any Ideas?
 
roadracer96
Forum Veteran
Forum Veteran
Posts: 714
Joined: Tue Aug 25, 2009 12:01 am

Re: RouterOS v5 beta4 released

Tue Jul 06, 2010 2:58 pm

Had an autosupout this morning. All SSTP connections were reset. CPU is pegged at 100% on my RB1000 after the crash and until reboot.. Memory usage is quite a bit higher than I remember it. Maybe memory leak isnt totally fixed yet? Either that or SSTP takes substantially (~50-60mb) more RAM to operate?
 
Muqatil
Trainer
Trainer
Posts: 574
Joined: Mon Mar 03, 2008 1:03 pm
Location: London - UK
Contact:

Re: RouterOS v5 beta4 released

Tue Jul 06, 2010 9:13 pm

What The Function!!
We started to deploy VoIP appliances on our network, with an Asterisk Server and voip phones / ATAs at client side..
Everything works fine (Thanks nstreme).
We needed to make Fax over IP work too..
Beta tests made in our office after some head bashing were successfull.
We found a Customer tester that needed a Fax..
We took the ATA and the Fax and went to the customer and it didn't work...
Client had RB411 ROS3.30 with masquerade.
Back to the office.. it works again..
We reproduced the enviorment of the client and didn't work (With a RB112 :lol: )
The only difference was the ROS version...
The office had 5.0beta3 (for testing)
We put 5.beta4 with the standard CPE configuration to the RB112 (that was working smoother than 3.x and 4.x) and everything works..
I didn't see any change at changelog though..
Upgrading to ROS 5.0beta4 we fixed problems with masquerade and Faxing over IP
It should be mentioned...
Renato Bernardi

skype: medtech5
 
rmichael
Forum Veteran
Forum Veteran
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: RouterOS v5 beta4 released

Tue Jul 06, 2010 9:27 pm

Upgrading to ROS 5.0beta4 we fixed problems with masquerade and Faxing over IP
It should be mentioned...
[/quote]

Improved connection tracking or sip helper is not in the change log either.... :D
 
roadracer96
Forum Veteran
Forum Veteran
Posts: 714
Joined: Tue Aug 25, 2009 12:01 am

Re: RouterOS v5 beta4 released

Wed Jul 07, 2010 3:21 am


Improved connection tracking or sip helper is not in the change log either.... :D

Changelog says that the kernel version was upgraded. Probably has more to do with that specifically.

On-topic, had another RB1000/SSTP lockup today. It just dropped all SSTP connections and none of the remotes could reconnect until i restarted the 1000.
 
dominicbatty
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Wed Jul 07, 2010 12:26 pm

RouterOS v5 beta4 released

Wed Jul 07, 2010 12:35 pm

I've run into a problem with the SSTP server in the new v5.

The SSTP server runs on port 443 and it has to run on this port as Windows clients can only connect on port 443 as there is no configuration option in Windows to connect to any other port as this is considered the default for HTTP SSL.

The SSTP server binds itself to every IP on the router on this port so there is no way to use port 443 for anything else.

There are many people, I'm sure who run a web server requiring SSL on their internal network and DSTNAT external IP:443 to their internal servers.

So now I am stuck.

If I want to use SSTP for Windows clients I must use port 443 on the SSTP server settings page.
If I want to run my web server using SSL I must forward port 443 from my router to my internal LAN

So it's one or the other, either I can run SSTP or I can have an SSL web server. Really SSTP needs to bind itself to a specific IP address as SSL is not specifically required for just that purpose, there are many other systems enforced to run on port 443 that this stops working.
 
dominicbatty
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Wed Jul 07, 2010 12:26 pm

RouterOS v5 beta4 released

Wed Jul 07, 2010 12:44 pm

Is it possible to bind the SSTP server to a specific IP address.

The problem is that it has ro run on port 443 as this is the only acceptable port that a windows client can connect into as there is no way to change this in windows.

It is also the port that HTTP SSL must run on for secure web sites.

What this means is that as soon as you enable to SSTP server on port 443 the DSTNAT rules for my SSL web server on my LAN stop working.

It basically means you can either use SSTP or use SSL web servers, you cannot use both as they both HAVE to be tied down to port 443.

If we were able to bind SSTP to a single IP address then we would not have this problem.

Thanks, Dom.
 
gajda
just joined
Posts: 12
Joined: Wed Apr 18, 2007 3:02 pm

Re: RouterOS v5 beta4 released

Wed Jul 07, 2010 2:57 pm

Windows server configured as sstp server has way how to determine if request is HTTP over SSL or SSTP. So it's possible to have SSTP server and webserver with SSL on same IP and port. More on RRAS blog in part where sra_{BA195980-CD49-458b-9E23-C84EE0ADCD75}/ is mentioned.
 
dominicbatty
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Wed Jul 07, 2010 12:26 pm

RouterOS v5 beta4 released

Wed Jul 07, 2010 6:41 pm

Found a workaround for the Mikrotik ... with thanks to <Chaos> for his input.

Run the SSTP server on port 4430 (not 443) which will bind it to both IP addresses on the router 1.1.1.1 and 1.1.1.2.

Use dstnat to forward traffic for 1.1.1.1:443 to the internal web server at 192.168.1.1:443
Use dstnat to forward traffic for 1.1.1.2:443 to the SSTP server at either 1.1.1.1:4430

A bit ugly, I admit but this does seem to work once the relevant firewall rules all added. Still would be nice to bind SSTP to one or more IP addresses but hey this is a good start.

Cheers, Dominic.
 
changeip
Forum Guru
Forum Guru
Posts: 3803
Joined: Fri May 28, 2004 5:22 pm

Re: RouterOS v5 beta4 released

Wed Jul 07, 2010 6:49 pm

I keep asking Mikrotik to allow binding services to ports. NTP, SNMP, PPP tunnels, they all need a way to tell them not to listen on every single IP address the router has. It fixes two things, it allows you to save resources (not listening on *.*.*.*) and it also allows the service to reply on the same IP address no matter which interface it came in on. UDP replies are especially hard because they don't seem to be able to be mangled (not part of the initial connection it seems?)
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
User avatar
gustkiller
Member
Member
Posts: 418
Joined: Sat Jan 07, 2006 5:15 am
Location: Brazil
Contact:

Re: RouterOS v5 beta4 released

Wed Jul 07, 2010 8:44 pm

Working great, no more RX drops with the new irq balancer!
Mikrotik Certified Consultant
 
rpress
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu May 07, 2009 5:13 am

Re: RouterOS v5 beta4 released

Thu Jul 08, 2010 5:03 am

The SSTP server binds itself to every IP on the router on this port so there is no way to use port 443 for anything else.
You can just block the port in the firewall 'input' chain, or really just allow 443 to only the desired IP and then block everything else. I tested this and it does work, I was able to connect to the SSTP server and have HTTPS dstnat on another IP.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: RouterOS v5 beta4 released

Fri Jul 09, 2010 7:36 pm

Upgraded v5 beta2 to beta4 on my rb1000, some defects found:

- Winbox doesn't remind settings any more. Every time after close the winbox and open again have to set my specific settings again. (Columns, column size)

- Winbox tool: Traceroute. After finishing traceroute to IP address the winbox doesn't show any more the end destination is reached. Status bar stays empty. Does user has no clue if test is still running of finished if the end IP address is unknown (url input)


- Request for winbox upgrade: Ability to open new winbox in pull down menu option after selecting registered client or neighbour. It works for telnet session, why not some code embedded that opens a new winbox session with the selected IP? Would save winbox users the need to copy and save the IP address of a registered client fist, manually open a new winbox session and paste the IP to open a new session.
This request made before and supported by several forum users. Please!

rgds
 
rpress
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Thu May 07, 2009 5:13 am

Re: RouterOS v5 beta4 released

Sat Jul 10, 2010 12:37 am

About every two days my SIP VoIP cannot register with the server. It's probably related to the possible change in the connection tracking as it's been working fine before.

Asterisk shows the registration request has been sent but it never completes.

A reboot of the router solves the problem instantly. Before I have had the SIP service port enabled - just now I disabled it, we will see if it has any effect.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24276
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 8:25 am

WirelessRudy
1. Can't repeat, my winbox remembers them correctly no matter how I close it
2. Yes, can repeat, will fix.
3. Winbox.exe should be opened, that could bring problems as Winbox the program, and Winbox the loader are different things. There is no predefined Winbox.exe location.
No answer to your question? How to write posts
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 11:37 am

WirelessRudy
1. Can't repeat, my winbox remembers them correctly no matter how I close it
2. Yes, can repeat, will fix.
3. Winbox.exe should be opened, that could bring problems as Winbox the program, and Winbox the loader are different things. There is no predefined Winbox.exe location.
OK,
1. True, it does remember last setting of which windows were open. But, in older version, even if a window disappeared because other session (other PC) had other windows open and was closed last, when winbox was opened in first PC again and sub menu windows were opened again most of the columns were the same as when that PC sessions had is set before.
Now they are just back to default setting.

2. thanks

3. Is there no way user then can import a default short-cut into an existing winbox session that opens loader automatically after inititating such by some actions in running program?


Like many other users that not (yet) use "Dude" program winbox is the main tool to work and monitor the network. Many small users run a PC with a winbox session open with several certain sub-windows opened.
Like I do, I run the WAN and LAN interface traffic graph together with a netwatch tool and the simple queues to see who is making most use of the network etc.
These settings are always the same on that PC and on a big monitor just visible for visual check.
At the same time on another PC do other controls things. Configuring, fine tuning, managing etc. Here other submenus for same router is used and if same subwindow in use then with different columns visible etc.

Now every time when you close a winbox session, or when the PC's are shut down (power cut, just every night before going to bed etc.) only the last running winbox session with its settings is recorded.
Thus next time (day) when PC's are started up again/winbox is opened again, the settings of the last closed winbox is used.

So my daily routine is to make my monitor PC showing the right winbox format (sub windows, column and column size etc) again before I can see what is happening with my network and I can start the day. Not a big deal but on a daily base becomes a bit irritating...

Winbox does have a pre defined setting stored in its code somewhere (since each meny/sub-menu's window opens in a certain default format) it would be nice if users were able to set their own set of pre defined winbox settings.

Now please don't mention the option of using the "dude" program. I tried it a couple of times and ran in too many problems so left it. And I do happen to know several other managers of MT based networks never came into using it.

It would be very nice if winbox program could be developed more into a even more user friendly program.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 3:45 pm

yeah! how does The Dude open new WinBox session? =) there's no need to have WinBox Loader on local computer :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24276
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 3:46 pm

It has it built-in
No answer to your question? How to write posts
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 3:50 pm

so what's problem to build Winbox Loader into WinBox? =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24276
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 3:55 pm

Size matters.
No answer to your question? How to write posts
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 5:57 pm

Size matters.
to whom?

<40kb is almost nothing. Nowadays with PC's running MB big programs this is hardly an argument....
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 10:58 pm

It sits inside the npk and inside the RouterBOARD. A bunch of DLLs. Size does matter.

Maybe its time for a second generation RouterOS running on more space, not compatible with the older routers. A separate branch containing more functionality, because now memory is cheaper.
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: RouterOS v5 beta4 released

Mon Jul 12, 2010 11:42 pm

It sits inside the npk and inside the RouterBOARD. A bunch of DLLs. Size does matter.
it IS already in RouterOS - you can download it via web-interface ;)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: RouterOS v5 beta4 released

Tue Jul 13, 2010 1:36 am

considered that a complete npk package is several Mb's or even some of the single packages are MB's big I don't think a couple of kb's make a difference any more.

A simple code that give user the ability to couple a short cut to its winbox.exe program with a given IP (or mac)taken from running session in a pull down menu for opening a new session shouldn't need so much more code that the program becomes too big?

And what about the other changes we would like to see and that have been mentioned before.
Why a minimum size of menu and sub-menu windows.? Sometimes I want windows even smaller or I have to overlap windows in my main window to get all info in one main router window.
Why default column listing in several sub-menu windows?

Example:
If a winbox -Wireless / Registration - session is opened I get a default setting. This each time when the router has been rebooted. Who decides which are the wanted options here?
I have no interest in "Last activity" or "Uptime" or if the registered device is an "AP" or "WDS". But these are the default settings I cannot change.
What I want to see for example is "Ack. Timeout", "Tx Signal Strength", Tx/Rx CCQ amongst others so I can see at one glare how the radio links are performing.

There are plenty other examples where the pre-set default settings have to be changed each time again (many times when I log into a client CPE I have to set the windows settings again. Apart from my upgrades and thus reboots many users switch their routers off over night and thus are settings back to default.) and that becomes a bit frustrating at times...

Winbox is a very handy and smart tool but I am sure that without too much effort some programmer of MT can make it a even more useful tool!
Lets not forget that I still prefer MT over other make because one of the reasons is the winbox tool that gives you a GUI in windows but that doesn't rely on htm.
One of the weak points of MT's big competitor UBNT is that all their units basically have to be access with a browser session, which is nice, but in real network management can be a pain.
(Yeah I know, they have telnet too, but I could never find the proper commands for them...)

So please MT, spend some of your resources on the winbox tool to make it even better then it already is!
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24276
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v5 beta4 released

Tue Jul 13, 2010 8:27 am

OK, we will think about it. Thanks for the suggestions.
No answer to your question? How to write posts
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: RouterOS v5 beta4 released

Tue Jul 13, 2010 11:15 am

OK, we will think about it. Thanks for the suggestions.
Ok, we'll be waiting with anxiety! :D
 
dominicbatty
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Wed Jul 07, 2010 12:26 pm

RouterOS v5 beta4 released

Tue Jul 13, 2010 3:43 pm

Has anyone noticed that the ping command does not return any response when used in v.5.0 beta 4 under some conditions.

I have a script ... :log info ("ping result=" . "$[/ping 8.8.8.8 count=5]") which should put "ping result=5" into the log file if it runs ok.

If I run this script using "/system script run 0" - it returns "ping result=5"
If I run the script using the "Run Script" button in Winbox it returns "ping result="
If I run the script using the scheduler it also returns "ping result="

It looks like under the "Run Script" or Mikrotik Scheduler that the /ping command does not return any results. It's sending my failover script into meltdown as everything is considered to be failed as no pings are returned. I don't have a v4 router to try and I only started beta testing at v4. It would be handy if someone could test on a v4 platform for me.

Thanks, Dom.
 
dominicbatty
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Wed Jul 07, 2010 12:26 pm

Re: RouterOS v5 beta4 released

Tue Jul 13, 2010 3:44 pm

That last sentence had too many v4's in it and should read ...

I don't have a v4.xx router to try and I only started beta testing v5.0 at beta4. It would be handy if someone could test on a v4.xx platform for me.
 
dominicbatty
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Wed Jul 07, 2010 12:26 pm

Re: RouterOS v5 beta4 released

Tue Jul 13, 2010 5:18 pm

ok, Mikrotik have confirmed this is a known problem to be resolved in v5.0 beta 5. No timescale at the moment for the beta 5 release.
 
mangust
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Jun 14, 2007 11:14 am

Re: RouterOS v5 beta4 released

Thu Jul 15, 2010 12:31 pm

OK, we will think about it. Thanks for the suggestions.
[user@xxx] > export
.......
/system resource irq
set (unknown) cpu=auto
set (unknown) cpu=auto
set (unknown) cpu=auto
set (unknown) cpu=auto
set (unknown) cpu=auto
set (unknown) cpu=auto
set (unknown) cpu=auto
set (unknown) cpu=auto
set (unknown) cpu=auto
set (unknown) cpu=auto
....

Does this correct?

Who is online

Users browsing this forum: MSN [Bot] and 34 guests