Page 1 of 1

RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 9:20 am
by normis
What's new in 5.0beta6 (2010-Aug-10 13:22):

*) sstp - fixed memory leak;
*) wireless - changed band setting and added channel-width setting
*) wireless - support for 11n rates in 5&10mhz channels
*) wireless nv2 - fixed multiple problems including occasional tx stall;
*) made gps accessible through SNMP;
*) snmp - added GETBULK support, no more table caching - solves problems
with huge tables, routing tables currently are not available;
*) ssh - fixed public key authentication in case
when client is not verifying if server will accept the key;
*) fixed problem - MetaROUTER did not work on RB800, RB1000 & RB1100;
*) intel 82576 (uncommon expensive chip) crash/reboot to be fixed in next release
*) RouterOS supports up to 16 cores in your PC system (previous limitation was 8)

Issues:
*) user manager is not working - will be fixed in next version;
*) switch menu is gone from Winbox, fix will be soon

Newsletter: http://download.mikrotik.com/newsletter27.pdf

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 9:39 am
by martini
release date of RouterOS v5 beta7 with fixed i82576 problems ?????????????

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 9:40 am
by normis
which ones you mean?

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 9:53 am
by martini
QOS with enabled multicore

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 9:57 am
by normis
yes, we are working on it.

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 10:17 am
by xezen
is the snmp odi for gps been set in this version?


In RouterOS v5.0beta6 the will be SNMP support for GPS.

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 10:17 am
by martini
2 normis - found that when i map every tx and rx ethernet queue (i82576) to processor core (disable automatic sharing) - queue start working, and global-in and global-out also working (multicore enabled)

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 10:49 am
by sergejs
The values available over SNMP for gps,

/system gps> print oid
date-and-time: .1.3.6.1.4.1.14988.1.1.12.1.0
longitude: .1.3.6.1.4.1.14988.1.1.12.2.0
latitude: .1.3.6.1.4.1.14988.1.1.12.3.0
altitude: .1.3.6.1.4.1.14988.1.1.12.4.0
speed: .1.3.6.1.4.1.14988.1.1.12.5.0
sattelites: .1.3.6.1.4.1.14988.1.1.12.6.0
is-valid: .1.3.6.1.4.1.14988.1.1.12.7.0

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 12:36 pm
by xezen
does it support 5GHz-turbo

with nv2

as i have 433ah with 3 radios

5ghz
5GHZ-turbo
2.4g-only

i want to try it with the 2.4g-only but not shore if it will affect the 5ghz-turbo

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 1:19 pm
by mars
memory leak still there in x86 and leak very fast

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 3:23 pm
by angboontiong
Normis..

Just wonder know the 7Ghz 26Mhz channel bandwidth microwave can provide <1ms latency.
anywhere Mikrotik can make it happen?

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 6:25 pm
by angboontiong
Normis...

Another problem found...
with RouterOS v5 beta 6, i set it running on the MPLS + NV2 and apply the NV2-qos-default.
the dude manager is not able to read the snmp.

when i downgrade back to the RouterOS v5 beta 5, then i having no issue with it.

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 8:39 pm
by axiang
IRQ cause new problems can not be upgraded
Figure specify the CPU upgrade package can not be upgraded configuration upload no response after reboot
CPU power into the system to restore it to normal and auto reboot after the upgrade

translate.google


新的问题 IRQ 引起 无法升级
如图 指定CPU 配置 上传升级包无法升级 reboot 后无响应
断电进入系统 恢复 CPU 为 auto 后 reboot 才正常 并升级

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 9:47 pm
by wildbill442
Normis...

Another problem found...
with RouterOS v5 beta 6, i set it running on the MPLS + NV2 and apply the NV2-qos-default.
the dude manager is not able to read the snmp.

when i downgrade back to the RouterOS v5 beta 5, then i having no issue with it.
I too noticed SNMP data is not available for all interfaces (ethernet, wireless, etc).

System info / CPU / mem / etc seems to work fine..

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 11:02 pm
by wbhampton
I have found that WDS mode does not work using any of the nv2 protocols.

Re: RouterOS v5 beta 6

Posted: Wed Aug 11, 2010 11:52 pm
by ManyX
I can not choose 40MHz channel width Band:5GHz-only-N I gets incompatible band and channel-width

Check "channel width" M h z

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 12:36 am
by Arlic
the routeros v5 has added G turbo and 5Ghz Turbo for AR5413 and AR5212, coz the specification of the chipsets says, the chipsets support turbo mode, AR5413 support 2.4Ghz turbo and 5Ghz turbo, AR5212 support 2.4Ghz turbo mode

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 3:35 am
by angboontiong
I have found that WDS mode does not work using any of the nv2 protocols.
Mikrotik have highly this in the RouterOS v5 beta 5.

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 3:41 am
by angboontiong
IRQ cause new problems can not be upgraded
Figure specify the CPU upgrade package can not be upgraded configuration upload no response after reboot
CPU power into the system to restore it to normal and auto reboot after the upgrade

translate.google


1) 新的问题 IRQ 引起 无法升级
2) 如图 指定CPU 配置 上传升级包无法升级 reboot 后无响应
3) 断电进入系统 恢复 CPU 为 auto 后 reboot 才正常 并升级
Wish you allow me me help for some correction for this translation ^_^:
1) The IRQ cause the system not able to upgrade.
2) As shown in the photo, if using manual setting for the CPU. there is no respond after upload the files and reboot the system for upgrading purpose.
3) Recycle the power, after enter the system, restore back the CPU setting to auto, then it can upgrade the system.

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 7:49 am
by normis
Yes, there are some issues with the multicore IRQ selection, it's fixed in beta7
Yes, there are also some SNMP issues that are fixed in beta7

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 8:34 am
by angboontiong
Yes, there are some issues with the multicore IRQ selection, it's fixed in beta7
Yes, there are also some SNMP issues that are fixed in beta7
Normis..
So far the beta6 is perform good if we ignore that few issue which will fix in the next release.
BTW, can be the latency bring down to <5ms?

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 8:38 am
by normis
You say that "if using manual setting for the CPU. there is no respond after upload the files and reboot the system for upgrading purpose", but RouterOs v5beta6 is the Newest version. What are you upgrading to ?

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 9:58 am
by omidkosari
What about Ticket#2010062166000111 or http://forum.mikrotik.com/viewtopic.php?f=2&t=42698 PPPoE options like DHCP options ?

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 12:02 pm
by mangust
Feature request:
Backup file should have hostname instead of "Mikrotik-" (or option to do that).
I use arag & drop to save backup configs and tired to rename backup file :).

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 12:15 pm
by normis
more practical would be to use a script that saves with custom name and automatically emails you the files :)
/system backup save name=whatyouwant
but I will see if we can change the default name to the identity name + timestamp for example.

Re: RouterOS v5 beta 6

Posted: Thu Aug 12, 2010 2:06 pm
by mangust
more practical would be to use a script that saves with custom name and automatically emails you the files :)
/system backup save name=whatyouwant
but I will see if we can change the default name to the identity name + timestamp for example.
It's all true. But sometimes I'm too lazy to write a such long command :) (plus timestamp is a keyword).
So, identity name + timestamp as a default name for backup file will be just great!!!

Re: RouterOS v5 beta 6

Posted: Fri Aug 13, 2010 2:01 am
by gustkiller
2 normis - found that when i map every tx and rx ethernet queue (i82576) to processor core (disable automatic sharing) - queue start working, and global-in and global-out also working (multicore enabled)
how did you set tc /rx queue in mikrotik? what command?

Re: RouterOS v5 beta 6

Posted: Fri Aug 13, 2010 3:28 am
by wispwest
I see posted TCP throughput increase using Nv2 on 802.11n, but is there any increase on 5Ghz Turbo as well?

Re: RouterOS v5 beta 6

Posted: Fri Aug 13, 2010 8:17 am
by NetworkPro
memory leak still there in x86 and leak very fast
OMG confirmed

on a RB433AH - stable though...

Re: RouterOS v5 beta 6

Posted: Fri Aug 13, 2010 10:39 am
by axiang
bonding might be some problems sometimes can not follow the desired work and cause system crashes, such as interfaces lost. . . .

pppoe mode can not have the desired effect?

NIC 82546EB X 2
Switch HP 2650(J4899B)

Re: RouterOS v5 beta 6

Posted: Fri Aug 13, 2010 6:37 pm
by tanxw998
please update kernel to 2.6.35 , atuo save irq problem 、improve netwokr performence
palese !!!

tanks

Re: RouterOS v5 beta 6

Posted: Fri Aug 13, 2010 10:21 pm
by Chupaka
please update kernel to 2.6.35 , atuo save irq problem 、improve netwokr performence
palese !!!

tanks
http://forum.mikrotik.com/viewtopic.php ... 28#p221228

Re: RouterOS v5 beta 6

Posted: Sat Aug 14, 2010 6:07 pm
by avantwireless
We tested on a simple 10mhz wide link with 2.4 radios sr2 and KXS30SG radios and they would only connect in B no matter what was set. quickly went back to 5b5 all better...

Re: RouterOS v5 beta 6 110 Km Link.

Posted: Sun Aug 15, 2010 7:34 pm
by dibatech
Point A: RB433AH
Point B: RB411

Only good old fashioned NStreme works as nv2 ,nv2 nstreme and nv2 nstreme 802.11 briefly ascotiates, but disconnects almost immediatly.


log:
00:28:01 wireless,info 00:0C:42:3A:XX:XX@wlan1 established connection on 5520, SSID XXX
00:28:06 wireless,info 00:0C:42:3A:XX:XX@wlan1: lost connection, ranging timeout
00:28:06 wireless,info 00:0C:42:3A:XX:XX@wlan1 established connection on 5520, SSID XXX
00:28:11 wireless,info 00:0C:42:3A:XX:XX@wlan1: lost connection, ranging timeout
00:28:11 wireless,info 00:0C:42:3A:XX:XX@wlan1 established connection on 5520, SSID XXX
00:28:16 wireless,info 00:0C:42:3A:XX:XX@wlan1: lost connection, ranging timeout
00:28:17 wireless,info 00:0C:42:3A:XX:XX@wlan1 established connection on 5520, SSID XXX

Ping times looks ok though with 5 beta 6 with nstreme.
Packet size=30
[admin@Megs_2] > /ping 172.21.200.33
HOST SIZE TTL TIME STATUS
172.21.200.33 56 64 3ms
172.21.200.33 56 64 3ms
172.21.200.33 56 64 2ms
172.21.200.33 56 64 2ms
172.21.200.33 56 64 2ms
172.21.200.33 56 64 2ms
172.21.200.33 56 64 3ms
sent=7 received=7 packet-loss=0% min-rtt=2ms avg-rtt=2ms max-rtt=3ms

Packet size=1500
[admin@Megs_2] > /ping 172.21.200.33 size=1500
HOST SIZE TTL TIME STATUS
172.21.200.33 1500 64 7ms
172.21.200.33 1500 64 10ms
172.21.200.33 1500 64 9ms
172.21.200.33 1500 64 9ms
172.21.200.33 1500 64 6ms
172.21.200.33 1500 64 6ms
172.21.200.33 1500 64 9ms
172.21.200.33 1500 64 9ms
sent=8 received=8 packet-loss=0% min-rtt=6ms avg-rtt=8ms max-rtt=10ms

Re: RouterOS v5 beta 6

Posted: Sun Aug 15, 2010 9:10 pm
by babbage
Hello normis,
You may have a look at ticket #2010072666000136
Nobody told me about beta5 upgrade problem (IRQ stuff). Check mine and support replies. Of course I am going to test new betas but with installing on another system...
Thanks

Re: RouterOS v5 beta 6

Posted: Tue Aug 17, 2010 5:59 am
by digitexwireless
There is no P Throughput on the Signal tab when monitoring a connection using Nv2. We are using a RB433UAH with a single XR3 for testing. Is this by design or a bug?

Re: RouterOS v5 beta 6

Posted: Tue Aug 17, 2010 10:58 am
by uldis
We tested on a simple 10mhz wide link with 2.4 radios sr2 and KXS30SG radios and they would only connect in B no matter what was set. quickly went back to 5b5 all better...
Please provide us with the support output file from your setup.
Send it to support@mikrotik.com
What band you have configured? You need to use 2Ghz-only-G band.

Re: RouterOS v5 beta 6

Posted: Tue Aug 17, 2010 1:58 pm
by avantwireless
Wilco... it was set for g only...

Re: RouterOS v5 beta 6

Posted: Wed Aug 18, 2010 9:50 am
by mangust
What's new in 5.0beta6 (2010-Aug-10 13:22):
....
*) intel 82576 (uncommon expensive chip) crash/reboot to be fixed in next release
....
Any news about next release :) ?

Re: RouterOS v5 beta 6

Posted: Wed Aug 18, 2010 4:25 pm
by gustkiller
i hope it get here before our new hp dl servers with those nics arrives.

Re: RouterOS v5 beta 6

Posted: Wed Aug 18, 2010 5:09 pm
by odie
just upgraded a production link in our network with beta6 und R52Hn cards
built in Huber&Suhner 23 Antennas using only 1 channel about 13 KM
seems to work fine ;-))
getting up to 35 Mbit with conservative settings and low power setting
also latency is very low...
waiting for finals....

Re: RouterOS v5 beta 6

Posted: Thu Aug 19, 2010 6:25 am
by angboontiong
Normis..

The watch dog feature seem not work properly...

Re: RouterOS v5 beta 6

Posted: Sun Aug 22, 2010 3:44 am
by InoX
since beta 6 my server with 2x82557/8/9/0/1 Ethernet Pro 100 (rev: 8 ) is not working anymore. Realtek gigabit card was ok. Downgraded to beta5. Working now. Card were enabled but no traffic was passing. Tried to Disable/Enable but cards staid disabled with error 6...and also Stop button from torch page, is missing.

Re: RouterOS v5 beta 6

Posted: Sun Aug 22, 2010 5:51 pm
by HaQs
When a ROS beta7 is expected ?

Re: RouterOS v5 beta 6

Posted: Mon Aug 23, 2010 12:54 pm
by adryfia
When a ROS beta7 is expected ?
Just waiting sir, because so much bugs in ROS 5 beta. Just waiting :)

Re: RouterOS v5 beta 6

Posted: Mon Aug 23, 2010 1:04 pm
by exebug
Also waiting ;)

Re: RouterOS v5 beta 6

Posted: Mon Aug 23, 2010 3:16 pm
by iw4eky
Hi,
I've just verified that two boards are not reachable if behind a bridged link with a Nv2 wireless link (like the one shown by "himmi" in his post):

DEVICE A...............DEVICE B - Station.................DEVICE C - AP...........DEVICE D
RB1100 eth1---------- eth1---wlan1 >>>>>> <<<<<<<< wlan1----eth1 --------- eth1 RB1100

BRIDGE in device B with ports "eth1" and "wlan1"
BRIDGE in device C with ports "eth1" and "wlan1"

I can see al 4 devices as Neighbors but ping is quite weird:

From D I can ping C and B, but not A
From A I can ping only B

Looks like an issue related to the "bridge" interfaces, this happens with Nv2 and Nstreme as "wireless-protocol" and I'm not using WDS since it's known as non working yet. And yes, all IP addresses are properly set!

Bye,
mattia

Re: RouterOS v5 beta 6

Posted: Mon Aug 23, 2010 3:23 pm
by grahamedia
Using NV2 @RouterOS v5 beta6 in X86 Alix board, make the hardware freeze / deadlock, after 1-4 hours connection PTP.. and have to reboot with unplug the adaptor of the hardware..

Better but still problem in RB433AH, using NV2, there was no problem to freeze the hardware, but the connection, disconnect ofter serveral hours connection..

Looks like RouterOS v5 beta 6 still have much repairement for using NV2, and we hope in RouterOS v5 beta 7, will solved these problem

8)

Re: RouterOS v5 beta 6

Posted: Mon Aug 23, 2010 3:52 pm
by uldis
iw4eky, in case of Nv2 it is just like 802.11 - you need to make a EOIP or VPLS/MPLS link over it to wireless link if you want to make transparent bridge.

grahamedia, give us more detailed info what exactly doesn't work in Nv2with alix board? Any support output files generated after lockup?

Re: RouterOS v5 beta 6

Posted: Mon Aug 23, 2010 4:16 pm
by grahamedia
We were using MPLS for Transparent Bridging, and both side using Alix G2D2 + XR5 for PTP connection over 20 KM, with nstream mode, the throughput are 30/30 Mbps with TCP, and we were very exciting after using nv2 the throughput increasing to 40/40 Mbps..

But after 2 hours, suddenly one side of hardware lockup, and the connection loss.. we cannot remote the hardware, so we turning off and on again to make it work again.. and after 1 hour, the other side lockup too, and so on..

There was no chance to look the message report, because we have to reboot the hardware, and the log was cleared after that..

Using nstream, with same configuration have stable result, and work no problem at all

And we have tried with RB433AH + XR5 @both side, with NV2, the hardware were stable, but the connection after 1 days drop, and not reconnect after that, except we disable and enable the interface again, or change it to other mode like nstream or 802.11

Re: RouterOS v5 beta 6

Posted: Mon Aug 23, 2010 10:37 pm
by digitexwireless
So we have tried the NV2 in a high interference area and it really seems to work. Took a customer who had good signal of -65 but P Throughput of less than 100 and transferred at a 2-3 meg down and 1 meg up using NV2. Looking forward to using this in the field on a permanent basis.

Any ETA on the radius authentication being added to NV2? We cannot field test without radius support. The tower I have in mind has 42 clients and interference is always an issue. If we can get the radius support, I will be glad to test it as it beats the heck out of changing out clients to another frequency.

Re: RouterOS v5 beta 6

Posted: Tue Aug 24, 2010 11:26 am
by perit
Hi all, I was using ROS v5b5 on a Dell PowerEdge R210. Since I upgraded to v5b6 both onboard ethernet interfaces are no more working:

This with v5b6 (same display on v5b5 follows below):

[admin@MikroTik] > interface ethernet print
Flags: X - disabled, R - running, S - slave
# NAME MTU MAC-ADDRESS ARP

[admin@MikroTik] /system resource irq> print
# IRQ USERS CPU ACTIVE-CPU COUNT
0 4 serial auto 3 503
1 9 acpi auto 1 0
2 14 ide0 auto 1 0
3 15 ide1 auto 1 0
4 22 usb2 auto 1 93
usb1
5 24 hpet2 auto 0 23575
6 25 hpet3 auto 1 23181
7 26 hpet4 auto 2 23166
8 27 hpet5 auto 3 23124
9 32 ahci auto 2 861

[admin@MikroTik] /system resource> pci print
# DEVICE VENDOR NAME IRQ
0 03:03.0 Matrox Graphics, Inc. MGA G200eW WPCM450 (rev... 6
1 02:00.1 Broadcom Corporation NetXtreme II BCM5716 Gi... 10
2 02:00.0 Broadcom Corporation NetXtreme II BCM5716 Gi... 15
3 00:1f.2 Intel Corporation 5 Series/3400 Series Ch... 11
4 00:1f.0 Intel Corporation 3400 Series Chipset LPC... 0
5 00:1e.0 Intel Corporation 82801 PCI Bridge (rev: ... 0
6 00:1d.0 Intel Corporation 5 Series/3400 Series Ch... 14
7 00:1c.0 Intel Corporation 5 Series/3400 Series Ch... 0
8 00:1a.0 Intel Corporation 5 Series/3400 Series Ch... 14
9 00:10.1 Intel Corporation Core Processor QPI Rout... 0
10 00:10.0 Intel Corporation Core Processor QPI Link... 0
11 00:08.3 Intel Corporation Core Processor Miscella... 0
12 00:08.2 Intel Corporation Core Processor System C... 0
13 00:08.1 Intel Corporation Core Processor Semaphor... 0
14 00:08.0 Intel Corporation Core Processor System M... 0
15 00:03.0 Intel Corporation Core Processor PCI Expr... 0
16 00:00.0 Intel Corporation Core Processor DMI (rev... 0
[admin@MikroTik]



Same commands with v5b5:

admin@MikroTik] > interface ethernet print
Flags: X - disabled, R - running, S - slave
# NAME MTU MAC-ADDRESS ARP
0 R ether1 1500 B8:AC:6F:8B:63:3E enabled
1 R ether2 1500 B8:AC:6F:8B:63:3F enabled

[admin@MikroTik] > system resource irq print
# IRQ USERS CPU ACTIVE-CPU COUNT
0 4 serial auto 3 227
1 9 acpi auto 1 0
2 14 ide0 auto 1 0
3 15 ide1 auto 1 0
4 22 usb2 auto 1 88
usb1
5 24 hpet2 auto 3 9943
6 25 hpet3 auto 2 9912
7 26 hpet4 auto 0 10147
8 27 hpet5 auto 1 9964
9 32 ahci auto 1 766
10 33 eth0-0 auto 2 102
11 34 eth0-1 auto 1 11
12 35 eth0-2 auto 1 36
13 36 eth0-3 auto 1 56
14 37 eth0-4 auto 1 8
15 42 eth1-0 auto 1 1
16 43 eth1-1 auto 1 0
17 44 eth1-2 auto 1 0
18 45 eth1-3 auto 1 0
19 46 eth1-4 auto 1 0

[admin@MikroTik] > system resource pci print
# DEVICE VENDOR NAME IRQ
0 03:03.0 Matrox Graphics, Inc. MGA G200eW WPCM450 (rev... 6
1 02:00.1 Broadcom Corporation NetXtreme II BCM5716 Gi... 10
2 02:00.0 Broadcom Corporation NetXtreme II BCM5716 Gi... 15
3 00:1f.2 Intel Corporation 5 Series/3400 Series Ch... 11
4 00:1f.0 Intel Corporation 3400 Series Chipset LPC... 0
5 00:1e.0 Intel Corporation 82801 PCI Bridge (rev: ... 0
6 00:1d.0 Intel Corporation 5 Series/3400 Series Ch... 14
7 00:1c.0 Intel Corporation 5 Series/3400 Series Ch... 0
8 00:1a.0 Intel Corporation 5 Series/3400 Series Ch... 14
9 00:10.1 Intel Corporation Core Processor QPI Rout... 0
10 00:10.0 Intel Corporation Core Processor QPI Link... 0
11 00:08.3 Intel Corporation Core Processor Miscella... 0
12 00:08.2 Intel Corporation Core Processor System C... 0
13 00:08.1 Intel Corporation Core Processor Semaphor... 0
14 00:08.0 Intel Corporation Core Processor System M... 0
15 00:03.0 Intel Corporation Core Processor PCI Expr... 0
16 00:00.0 Intel Corporation Core Processor DMI (rev... 0


Any hint ?
Thanks in advance.

Re: RouterOS v5 beta 6

Posted: Tue Aug 24, 2010 8:35 pm
by angboontiong
We were using MPLS for Transparent Bridging, and both side using Alix G2D2 + XR5 for PTP connection over 20 KM, with nstream mode, the throughput are 30/30 Mbps with TCP, and we were very exciting after using nv2 the throughput increasing to 40/40 Mbps..

But after 2 hours, suddenly one side of hardware lockup, and the connection loss.. we cannot remote the hardware, so we turning off and on again to make it work again.. and after 1 hour, the other side lockup too, and so on..

There was no chance to look the message report, because we have to reboot the hardware, and the log was cleared after that..

Using nstream, with same configuration have stable result, and work no problem at all

And we have tried with RB433AH + XR5 @both side, with NV2, the hardware were stable, but the connection after 1 days drop, and not reconnect after that, except we disable and enable the interface again, or change it to other mode like nstream or 802.11
Hi...
would you mind to shared about the Alix G2D2 in the other topic or email?

Re: RouterOS v5 beta 6

Posted: Thu Aug 26, 2010 12:06 pm
by temuri426
can i upgrade my rb333 to RouterOS v5 beta 6 ?

Re: RouterOS v5 beta 6

Posted: Fri Aug 27, 2010 10:30 am
by rpingar
when will b7 be vailable?

the snmp problem is preventing us to put it in a real enviroment.

regards
ros

Re: RouterOS v5 beta 6

Posted: Fri Aug 27, 2010 1:17 pm
by angboontiong
Another issue is the hide ssid not function.

Re: RouterOS v5 beta 6

Posted: Sat Aug 28, 2010 12:50 pm
by netus
And another issue is the DHCP server or client not function on wireless interface.
Server is offering the lease but a client is searching forever.

Few of my clients get the IP but basicly they have status "searching..." (and on server side "offered") forever.

Wireless interface mode is:
on the server side - "ap bridge" no wds.
on the clinet side - "station".

No bridge, very simple configuration.

Hardware: RB433AH + R52nM and RB711M

Re: RouterOS v5 beta 6

Posted: Mon Aug 30, 2010 10:39 am
by netus
can i upgrade my rb333 to RouterOS v5 beta 6 ?
Yes, You can.

Before upgrade the software to level 4 or 5, you need to upgrade the license key.

To do that:
1. upgrade the software to ver. 3.30.
2. upgrade the firmware [/system routerboard upgrade]
3. upgrade the license key useing WinBox
4. now you can upgrate the software to level 4 or 5
5. upgrade the firmware, if there is new one

Re: RouterOS v5 beta 6

Posted: Fri Sep 03, 2010 12:22 pm
by mwheeler
Lads, I'm having some issues OSPF flapping into exstart mode on the new Beta 6 on a RB750G, and just recently winbox / API / web interface has dropped out. I'm guessing I have to upload a support.rif file to support@mikrotik.com ? I haven't rebooted the box yet, and telnet works. This happened a few days ago, and rebooting solved... At time of looking, HDD, Mem and CPU looked good. Mem is usually a bit higher though on this system, usually idles around 10MB free.

uptime: 2d20h23m
version: "5.0beta6"
free-memory: 4944KiB
total-memory: 29764KiB
cpu: "MIPS 24Kc V7.4"
cpu-count: 1
cpu-frequency: 680MHz
cpu-load: 0%
free-hdd-space: 21580KiB
total-hdd-space: 61440KiB
write-sect-since-reboot: 441362
write-sect-total: 554662
bad-blocks: 0%
architecture-name: "mipsbe"
board-name: "RB750G"
platform: "MikroTik"


02:47:55 route,bgp,info Failed to open TCP connection: Network is unreachable
02:47:56 route,bgp,info RemoteAddress=172.28.1.37
02:48:00 route,ospf,info OSPFv2 neighbor 172.28.1.253: state change from ExStart to 2-Way
02:48:01 route,ospf,info OSPFv2 neighbor 172.28.1.251: state change from ExStart to Init
02:48:01 route,ospf,info OSPFv2 neighbor 172.28.1.250: state change from ExStart to Init
02:48:01 route,ospf,info OSPFv2 neighbor 172.28.1.253: state change from ExStart to Init
02:48:01 route,ospf,info Database Description packet has init bit set in middle of an exchange
02:48:01 route,ospf,info OSPFv2 neighbor 172.28.1.253: state change from Exchange to 2-Way

Re: RouterOS v5 beta 6

Posted: Fri Sep 03, 2010 12:57 pm
by netus
Found problem with the ARP

Clients can ping AccessPoint but can't ping each other.
Of course Default Forward and ARP on the wireless interfaces is enabled.
All devices in one network.

After setting up static ARP all work fine.

Re: RouterOS v5 beta 6

Posted: Fri Sep 03, 2010 1:21 pm
by mangust
What's new in 5.0beta6 (2010-Aug-10 13:22):
....
*) intel 82576 (uncommon expensive chip) crash/reboot to be fixed in next release
....
Any news about next release :) ?
OK,
Looks like it’s a problem to get stable BETA in nearest feature.
Could somebody suggest me 4GB port adapter, which can be supported by 4.x version?

Re: RouterOS v5 beta 6

Posted: Fri Sep 03, 2010 10:20 pm
by fsoaress76
power edge 510

HD ATA

Instalei em outra maquina, depois coloquei no dell, levantou só as placas Gigabit quad port.

registrei o Router-OS, tudo ok.

Quando estava configurando os ip nas interfeces, disappeared all INTERFACES


Placas de redes

2 Placa de rede Intel Gigabit Quad Port, Copper, PCIe-4
2 interfaces onboard Broadcom® NetXtreme II™ 5709c Gigabit Ethernet NIC

Help!! Help!!

Re: RouterOS v5 beta 6

Posted: Tue Sep 07, 2010 9:46 am
by birendersinghbudhwar
When v5 beta7 is releasing ...?

Re: RouterOS v5 beta 6

Posted: Tue Sep 07, 2010 9:47 am
by normis
next version will be out next week

Re: RouterOS v5 beta 6

Posted: Tue Sep 07, 2010 11:17 am
by omidkosari
new version has this feature request http://forum.mikrotik.com/viewtopic.php?f=2&t=42698 ?

Re: RouterOS v5 beta 6

Posted: Wed Sep 08, 2010 2:55 am
by yarda
The values available over SNMP for gps,

/system gps> print oid
date-and-time: .1.3.6.1.4.1.14988.1.1.12.1.0
longitude: .1.3.6.1.4.1.14988.1.1.12.2.0
latitude: .1.3.6.1.4.1.14988.1.1.12.3.0
altitude: .1.3.6.1.4.1.14988.1.1.12.4.0
speed: .1.3.6.1.4.1.14988.1.1.12.5.0
sattelites: .1.3.6.1.4.1.14988.1.1.12.6.0
is-valid: .1.3.6.1.4.1.14988.1.1.12.7.0
I would like if ask me anyone form Mikrotik team.
Please, add longitude and latitude to RoS version 4.x as static value (for example /system location ;-) ) and set some possible SNMP output. It will be usefull for administration large networks and managment through dude, trust me as ISP wit more than 800 RB on our site. Thank you very much.

Re: RouterOS v5 beta 6

Posted: Wed Sep 08, 2010 12:13 pm
by Lakis
next version will be out next week
:) Finlay something hope Nv2 for wds fixed

Re: RouterOS v5 beta 6

Posted: Wed Sep 08, 2010 12:20 pm
by Lakis
Another issue is the hide ssid not function.
Hm.. I have 3 p2p (ap-bridge<->station wds) links with Hide SSID ver. 5beta6 all working, dont really sure what is not function

Re: RouterOS v5 beta 6

Posted: Fri Sep 10, 2010 4:03 pm
by npero
next version will be out next week
Please first resolve bug with restart on x86 with bridge filter.

I send you now supout.rif form last non public version.

Re: RouterOS v5 beta 6

Posted: Fri Sep 10, 2010 5:43 pm
by Alessio Garavano
next version will be out next week
Please first resolve bug with restart on x86 with bridge filter.

I send you now supout.rif form last non public version.

Bridge Filter is not working on v5 really?

I upgrade a lot of RBs and the bridge filter is not working...

Re: RouterOS v5 beta 6

Posted: Fri Sep 10, 2010 6:44 pm
by npero
next version will be out next week
Please first resolve bug with restart on x86 with bridge filter.

I send you now supout.rif form last non public version.

Bridge Filter is not working on v5 really?

I upgrade a lot of RBs and the bridge filter is not working...

On x86 working in beta 6 in some non official test version have problem when is bridge filter enabled router restart.
Working but cause reboot.
Beta 6 is not affected, only the new version. I don't tested on RB only on x86 if you what to test this new version contact support.
I already contact support I thing they resolve this problem go to public with new version.

Re: RouterOS v5 beta 6

Posted: Mon Sep 13, 2010 5:01 pm
by angboontiong
Another issue is the hide ssid not function.
Hm.. I have 3 p2p (ap-bridge<->station wds) links with Hide SSID ver. 5beta6 all working, dont really sure what is not function
i can scan the ssid from other wireless bridge, but when i fall back to the V4.11, the ssid is not able to scan anymore.

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 9:03 am
by birendersinghbudhwar
When next version is coming as per normis mikrotik is supposed to release this week.

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 11:20 am
by mangust
When next version is coming as per normis mikrotik is supposed to release this week.
+1

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 11:21 am
by normis
we have some complications with one big change, we are still working on it.

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 12:38 pm
by mangust
we have some complications with one big change, we are still working on it.
Normis you are the BOSS… However, ROS is not OS for Wireless only, give us a chance to test BGP, QOS and other functions on high-load X86 systems with new Intel chipsets , I’m really waiting for this from 5B2.

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 12:52 pm
by normis
I didn't say the change is about wireless. We are working on routing actually.

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 2:48 pm
by nz_monkey
ooh routing changes, exciting :)

We seem to be pushing the boundaries of routing in RouterOS at a few sites now, it will be good to see what improvements come through.

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 3:08 pm
by gustkiller
wow !! lightining fast bgp and show ip bgp like commands?

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 8:29 pm
by Ripper
What happened with SSH protocol earlier i used R3.3 now upgrade to 5b6 and my PHP self-made billing cannot connect to MT via SSH...
    $methods = array ( 'kex' => 'diffie-hellman-group1-sha1' );
    $shell = ssh2_connect($host, 22, $methods);
I've tried your PHP MT API but no luck too... http://wiki.mikrotik.com/wiki/API_PHP_class

Thanks for any advice ….

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 9:07 pm
by Chupaka
no luck? why? some errors? have you enabled API port under /ip services?

Re: RouterOS v5 beta 6

Posted: Wed Sep 15, 2010 10:20 pm
by Ripper
At MT3.3 my billing (PHP module ssh2) works fine ... with same settings it couldn’t connect via SSH to MT5b6

With API PHP it tried to connect «Connection attempt #5" times and sad ERROR...

I had same shit with 3.3 while i fined method diffie-hellman-group1-sha1 after that everything goes fine...

I've tried to connect via ssh from same host where php server hosts with successful result.

Re: RouterOS v5 beta 6

Posted: Thu Sep 16, 2010 11:05 am
by janisk
what commands and in what way you are sending to RouterOS ssh.

in version 5.0 there is completely new SSH, so please report what you have found.

Re: RouterOS v5 beta 6

Posted: Thu Sep 16, 2010 3:13 pm
by Ripper
ON 3.3 thats works perfect

SSH
function routeros_Connect($host, $username, $password) {
	
    if (!function_exists("ssh2_connect")) die("function ssh2_connect doesn't exist");   
    $methods = array ( 'kex' => 'diffie-hellman-group1-sha1' );
    $shell = ssh2_connect($host, 22, $methods);
    ssh2_auth_password($shell, $username, $password);
    return $shell;
}
function routeros_SendCommand($shell, $command) {

    $stream = ssh2_exec($shell, $command);
    stream_set_blocking( $stream, true );
    $data = "";
    while( $buffer = fread($stream, 4096) ) {
       $data .= $buffer;
    }
    fclose($stream);

   
    return $data;
}
execute
routeros_SendCommand(routeros_Connect('server_ip','server_login','server_password'),'command');
but in 5.0b6 noluck with that


When i logining thru console it sad that security protocol DSA1

I need any solution to fix it as soon as possible because my costumers can’t work (((...

SSH2 don't say any error just freezes.

As i understand in new version change security protocol to which exactly?

I've litle bit tuned PHP API and it's connect but if I use it i need do much edits on my php billing code ... ((
I need some way to fix ssh ....

Re: RouterOS v5 beta 6

Posted: Fri Sep 17, 2010 11:40 am
by honzam
5.0RC1 will be this week or next to?