Community discussions

MikroTik App
 
couresportivo
newbie
Topic Author
Posts: 42
Joined: Thu Mar 26, 2009 11:30 am

Feature request. Routeros version rollback.

Sat Aug 21, 2010 6:07 pm

I would love to test some of the development versions on a 25m link, where I have some flexibility. But it is such a pain to visit after version upgrade if the link is lost,not just safe mode. Full reversion to last known good after x time

Ideally check boxes for last version and last backup with timer/scheduler

I dont know if backup includes os version, I suspect not just device settings, but no use if you cannot connect
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6043
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Feature request. Routeros version rollback.

Mon Aug 23, 2010 9:33 am

It will be hard to store all versions you have been installing on 64Mb NAND
 
couresportivo
newbie
Topic Author
Posts: 42
Joined: Thu Mar 26, 2009 11:30 am

Re: Feature request. Routeros version rollback.

Mon Aug 23, 2010 11:30 am

MRZ

The majority of my AP's are RB433AH and a couple of RB600. But I would have thought that even on a 64mb Nand there would have been sufficient room for a 12/13mb for the core os. You could always delete all the npk's prior, not store them all.

All my devices keep a local daily backup and a copy emailed to me, which is overwritten daily. I only get issues if I change the os release,and most issues can be resolved remotely, but I am reluctant to upgrade as it can have a high time cost. I want to change the os version to make use of bug fixes and enhancements.

The effect being that it would reboot in to the last known working, with backup. At least it would negate a day out for an engineer. If the issue was space for UM/Hotspot/Dude, they can always be remotely sent down as long as you have a connection.

If a connection goes down I would get 50 phone calls straight away.

I am sure the code would be relatively simple
 
charliebrown
Member Candidate
Member Candidate
Posts: 130
Joined: Wed Dec 17, 2008 3:27 am

Re: Feature request. Routeros version rollback.

Mon Aug 23, 2010 12:29 pm

Even just a running/backup version system like cisco use would be handy
 
0ldman
Forum Guru
Forum Guru
Posts: 1447
Joined: Thu Jul 27, 2006 5:01 am

Re: Feature request. Routeros version rollback.

Mon Aug 23, 2010 11:47 pm

Another request for that.

Even just last running version/config.
 
couresportivo
newbie
Topic Author
Posts: 42
Joined: Thu Mar 26, 2009 11:30 am

Re: Feature request. Routeros version rollback.

Mon Aug 23, 2010 11:58 pm

I just dont want to drive 50-100 miles if it goes tits up :)
 
mehran
just joined
Posts: 18
Joined: Sat May 01, 2010 10:18 am

Re: Feature request. Routeros version rollback.

Tue Aug 24, 2010 6:56 pm

Hi,
Assuming your current version is 4.10 and want to upgrade to 4.11 and if failed return to 4.10
So try this:
put both "routeros-mipsbe-4.10.npk" and "routeros-mipsbe-4.11.npk" into your RB433AH
then paste following code in a terminal or ssh screen:
/system script
add name=downgrade policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
    :delay 600;\r\
    \n:log warning \"### Downgrading Router ###\";\r\
    \n/system package downgrade"

/system scheduler
add comment="" disabled=no interval=0s name=downgrade on-event=\
    "/system script run downgrade" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive \
    start-time=startup

then reboot your router. it will upgraded to 4.11 and after that you have 600 seconds to login and in the
System -> Scripts -> Jobs stop the active downgrade script by selecting and pressing minus button
If you can't do this it will automatically downgrade to 4.10 after 600 seconds. also you can change this delay inside script.
good luck
 
couresportivo
newbie
Topic Author
Posts: 42
Joined: Thu Mar 26, 2009 11:30 am

Re: Feature request. Routeros version rollback.

Tue Aug 24, 2010 7:13 pm

Thanks Mehran

that looks like it will work.

For clarification do I have to upload a new version of 4.10 as well as 4.11 or does it use the existing 4.10
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: Feature request. Routeros version rollback.

Tue Aug 24, 2010 7:19 pm

You have to upload both.
 
couresportivo
newbie
Topic Author
Posts: 42
Joined: Thu Mar 26, 2009 11:30 am

Re: Feature request. Routeros version rollback.

Tue Aug 24, 2010 7:34 pm

Thanks guys

Will probably save me a drive one day

the beers are on me
 
mehran
just joined
Posts: 18
Joined: Sat May 01, 2010 10:18 am

Re: Feature request. Routeros version rollback.

Wed Aug 25, 2010 12:08 am

u r welcome
if it works for you don't forget to give karma :wink:
 
mehran
just joined
Posts: 18
Joined: Sat May 01, 2010 10:18 am

Re: Feature request. Routeros version rollback.

Wed Aug 25, 2010 8:11 am

** NOTICE **

forgot to mention
to prevent accidentally downgrade on next reboot after successful upgrade do as follows:
1- Disable System -> Scheduler -> downgrade till next upgrade
2- Remove "routeros-mipsbe-4.10.npk" or file belonging to previous version

Who is online

Users browsing this forum: cedie, Google [Bot], jspool and 83 guests