Page 1 of 1

Problem wifh port forwarding along with TP-Link WR340G route

Posted: Sat Aug 21, 2010 8:35 pm
by jalokim
Hi,

In customers that have wifirouters i'm installing tp-link wr340g router and:
- disabling dhcp serwer on router
- disabling nat and plugging cable from mt to LAN1-4 port
- changing def ip to 10.0.2.2

And i have problem with forwarding 80 port to this router.

One of customers have reset it to default ip (192.168.1.1).

So, on MT i've set up dhcp-clinet on eth to get ip from tp-link's router (and got it) and use dst-nat to forward 80 port on mt public ip to 80 port of router.

Packets are sent, but .... no login and setup page is shown.

Can you help with this?

M.

Re: Problem wifh port forwarding along with TP-Link WR340G r

Posted: Sat Aug 21, 2010 8:41 pm
by fewi
Maybe. Can you show the configuration you tried?

Re: Problem wifh port forwarding along with TP-Link WR340G r

Posted: Sat Aug 21, 2010 9:28 pm
by jalokim
Maybe. Can you show the configuration you tried?
Yup, sorry.
[admin@MikroTik] > ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat action=masquerade src-address=10.0.2.0/24 

 1   chain=srcnat action=masquerade src-address=192.168.1.0/24 

 2   chain=dstnat action=dst-nat to-addresses=192.168.1.1 to-ports=80 
     protocol=tcp dst-address=88.220.xxx.xxx dst-port=80 

 3   chain=srcnat action=src-nat to-addresses=192.168.1.2 to-ports=80 
     protocol=tcp dst-address=192.168.1.1 dst-port=80
192.168.1.1 is ip address of router's lan
192.168.1.2 is ip address of mt on eth1
I've also tried to aquire ip addres from tp-link's dhcp server:
[admin@MikroTik] > ip dhcp-client print detail 
Flags: X - disabled, I - invalid 
 0   interface=ether1 use-peer-dns=yes use-peer-ntp=yes status=bound 
     address=192.168.1.102/24 gateway=192.168.1.1 dhcp-server=192.168.1.1 
     primary-dns=192.168.1.1 expires-after=1h55m37s