Community discussions

MUM Europe 2020
 
kwasek404
just joined
Topic Author
Posts: 2
Joined: Mon Aug 23, 2010 10:41 am

MT crashes

Mon Aug 23, 2010 10:48 am

MT crashes

After few test which we conducted, we came to a conclusion that MT doesn't free up RAM. This causes MT to crash after some time. Also after disabling firewall rules doesnt't free up CPU resources. Only deleting it does.
Bellow few examples:

Image

Image

Image

What is intersting, although MT has some amount of free RAM resources, it crashes.

OSPF was enabled on this devices. End users were connected with pppoe, but this problem occured also without OSPF enabled.
We also made an experiment:
One MT was in AP mode, two other MT's were trying to establish pppoe session with non existing accounts. After one day MT, which was in AP mode, crashed. Time after which AP crashes depends on RAM and CPU speed installed.

We made this experiment using 3.30, 4.11, 5.0 firmware. The problem occures on all of them.
Many other companies has reported this problem to us.
 
User avatar
Ibersystems
Forum Guru
Forum Guru
Posts: 1684
Joined: Wed Apr 12, 2006 12:29 am
Location: Cabrils, Barcelona - Spain
Contact:

Re: MT crashes

Mon Aug 23, 2010 11:33 am

I have a hotspot and a webproxy in a rb1000 without problems like that.
system resource pri
                   uptime: 18w6d18h6m46s
                  version: "4.6"
              free-memory: 761128kB
             total-memory: 1036636kB
                      cpu: "e500v2"
                cpu-count: 1
            cpu-frequency: 1333MHz
                 cpu-load: 21
           free-hdd-space: 3488kB
          total-hdd-space: 61440kB
  write-sect-since-reboot: 7501780
         write-sect-total: 8161860
               bad-blocks: 3
        architecture-name: "powerpc"
               board-name: "RB1000"
Martín
martinruiz at ibersystems.es
Experto en redes WiFi y enlaces WiFi.

Facebook: @Ibersystems
Twitter: @Ibersystems

Certified in Traffic Shaping, Wireless, Internetworking, Routing and User Management.
MTCTCE - MTCWE - MTCINE - MTCUME - MTCRE
 
ravael
just joined
Posts: 5
Joined: Fri Sep 15, 2006 11:11 am

Re: MT crashes

Wed Aug 25, 2010 2:36 am

I also have this problem with many many various routerboards, alixes or pc. No matter what hardware, it will crash after few days/hours. MT doesn't free up ram ;/
 
kwasek404
just joined
Topic Author
Posts: 2
Joined: Mon Aug 23, 2010 10:41 am

Re: MT crashes

Wed Aug 25, 2010 11:47 am

I have a hotspot and a webproxy in a rb1000 without problems like that.
system resource pri
                   uptime: 18w6d18h6m46s
                  version: "4.6"
              free-memory: 761128kB
             total-memory: 1036636kB
                      cpu: "e500v2"
                cpu-count: 1
            cpu-frequency: 1333MHz
                 cpu-load: 21
           free-hdd-space: 3488kB
          total-hdd-space: 61440kB
  write-sect-since-reboot: 7501780
         write-sect-total: 8161860
               bad-blocks: 3
        architecture-name: "powerpc"
               board-name: "RB1000"

Ibersystems, this is different service. Problem occures in ppp.

any solutions?
Last edited by kwasek404 on Wed Aug 25, 2010 12:48 pm, edited 1 time in total.
 
kensai
just joined
Posts: 1
Joined: Wed Aug 25, 2010 2:02 pm

Re: MT crashes

Wed Aug 25, 2010 2:22 pm

I also have this problem with many many various routerboards, alixes or pc. No matter what hardware, it will crash after few days/hours. MT doesn't free up ram ;/
I have the same problem.
 
legba
just joined
Posts: 14
Joined: Wed Apr 07, 2010 11:59 am

Re: MT crashes

Wed Aug 25, 2010 5:54 pm

We also suffer from that issue on 30-40 MT with PPPoE Server enabled.

After some days/hours without any regularity - it just simply hangs.
 
User avatar
mylek
just joined
Posts: 4
Joined: Sun Jan 31, 2010 10:25 am
Location: Poland
Contact:

Re: MT crashes

Wed Aug 25, 2010 10:26 pm

Also I have the same problem. PPPoE server running on x86 sometimes with 1GB of RAM, sometime RB433. ROS version 3.30, 4.10, 5beta6. For now only solutios is watchdog fixed on localhost or nearest nieghtbor.
 
ryz
just joined
Posts: 13
Joined: Sun May 27, 2007 5:10 pm

Re: MT crashes

Tue Aug 31, 2010 10:29 pm

We have the same problem, mt sometimes hangs out.
We use PPPOE Server+radius.


Ryz
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8341
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: MT crashes

Tue Sep 14, 2010 1:53 am

have anyone written to support@? =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
ravael
just joined
Posts: 5
Joined: Fri Sep 15, 2006 11:11 am

Re: MT crashes

Mon Nov 22, 2010 4:51 am

yeah, many times. They dont see any problems...
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: MT crashes

Mon Nov 22, 2010 7:25 am

Did you send a supout.rif taken when the problem exists? They should be able to track it from there.

Or maybe share ticket numbers in this thread so multiple people can report it and refer to other people's tickets.
 
xxiii
Member Candidate
Member Candidate
Posts: 230
Joined: Wed May 31, 2006 12:55 am

Re: MT crashes

Mon Nov 22, 2010 9:53 pm

Is this specifically when PPPoE logins are failing?

Who is online

Users browsing this forum: No registered users and 140 guests