Community discussions

MikroTik App
 
oceanic1
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Mon Sep 14, 2009 11:15 am

icmp protocol

Tue Aug 24, 2010 1:15 pm

Hello Guys,

I need script to block icmp protocol on my network, I want Clients not to have ability to ping on the network
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6043
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: icmp protocol

Tue Aug 24, 2010 1:34 pm

set up firewall rule to block ICMP, you don't need any scripts for that.
 
mehran
just joined
Posts: 18
Joined: Sat May 01, 2010 10:18 am

Re: icmp protocol

Tue Aug 24, 2010 7:09 pm

to block pinging outside network:
/ip firewall filter add chain=forward action=drop protocol=icmp icmp-options=8:0-255
to block pinging router itself:
/ip firewall filter add chain=input action=drop protocol=icmp icmp-options=8:0-255
 
oceanic1
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Mon Sep 14, 2009 11:15 am

Re: icmp protocol

Wed Aug 25, 2010 10:33 am

Thanks for the replies, it works...

How can I block the access to scan my network through some network scanner to get mac addresses list on my network?
 
mehran
just joined
Posts: 18
Joined: Sat May 01, 2010 10:18 am

Re: icmp protocol

Wed Aug 25, 2010 2:44 pm

mac address is on Layer2 and everyone on the same subnet can discover it.
except on Wireless that could be isolated.
you can prevent to discovering your network IP addresses by using MikroTik firewall.

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], YaCy [Bot] and 59 guests